summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Hommey <glandium@debian.org>2005-03-28 16:24:10 +0000
committerMike Hommey <glandium@debian.org>2005-03-28 16:24:10 +0000
commit56e6b400ed7320af32b171e72b3e244461536976 (patch)
tree97e963a707b6c3e500217b68dbb93597e00c9b7e
parent036affd1bcd40597e02894fdeb5ac17fff012a6b (diff)
downloadlibxml2-56e6b400ed7320af32b171e72b3e244461536976.tar.gz
fix installation of python files and make proper use of DESTDIR at install time, fixing FTBFS on buildds.
-rw-r--r--debian/changelog8
-rwxr-xr-xdebian/rules6
2 files changed, 11 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 91c37f5..8976a81 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+libxml2 (2.6.16-6) unstable; urgency=low
+
+ * The "pbuilder has its caveats, too" release.
+ * debian/rules: fix installation of python files and make proper use of
+ DESTDIR at install time, fixing FTBFS on buildds.
+
+ -- Mike Hommey <glandium@debian.org> Mon, 28 Mar 2005 18:12:15 +0200
+
libxml2 (2.6.16-5) unstable; urgency=low
* debian/watch: use svn-upgrade instead of uupdate.
diff --git a/debian/rules b/debian/rules
index 2639704..f2a5e3b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -73,7 +73,7 @@ install-stamp: build-stamp
mv -f python/Makefile python/Makefile.bak
echo install: > python/Makefile
- $(MAKE) prefix=`pwd`/debian/tmp/usr install
+ $(MAKE) DESTDIR=`pwd`/debian/tmp install
mv -f python/Makefile.bak python/Makefile
mv debian/tmp/usr/share/aclocal/libxml.m4 debian/tmp/usr/share/aclocal/libxml2.m4
@@ -105,13 +105,13 @@ install-stamp: build-stamp
touch install-stamp
build-python%-stamp: build-stamp
- cd python && $(MAKE) clean && $(MAKE) PYTHON=/usr/bin/python$* pythondir=`pwd`/../debian/tmp/usr/lib/python$*/site-packages PYTHON_VERSION=$* PYTHON_INCLUDES=/usr/include/python$*
+ cd python && $(MAKE) clean && $(MAKE) PYTHON=/usr/bin/python$* PYTHON_VERSION=$* PYTHON_INCLUDES=/usr/include/python$*
touch $@
install-python%-stamp: build-python%-stamp
rm build-python$*-stamp
- cd python && $(MAKE) PYTHON=/usr/bin/python$* pythondir=`pwd`/../debian/tmp/usr/lib/python$*/site-packages PYTHON_VERSION=$* PYTHON_INCLUDES=/usr/include/python$* install
+ cd python && $(MAKE) DESTDIR=`pwd`/../debian/tmp PYTHON=/usr/bin/python$* PYTHON_VERSION=$* PYTHON_INCLUDES=/usr/include/python$* install
sed s/PYVERS/$*/ debian/python-libxml2.install.in > debian/python$*-libxml2.install
cp debian/python-libxml2.examples.in debian/python$*-libxml2.examples