summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Hommey <mh@glandium.org>2004-07-31 08:35:29 +0000
committerMike Hommey <mh@glandium.org>2004-07-31 08:35:29 +0000
commita8b6cf1e3a00e278d84b5a577e630d7cbd9be7c0 (patch)
tree8e414d37971aa7e63621b828d4c01d344db05b6e
parent0691e7e9bcecbc376eea8d0b32bad0fabc0791d2 (diff)
downloadlibxml2-a8b6cf1e3a00e278d84b5a577e630d7cbd9be7c0.tar.gz
NOW, it must be okay
-rw-r--r--debian/changelog2
-rwxr-xr-xdebian/rules15
2 files changed, 12 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 87cfacd..c971aa4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,7 +6,7 @@ libxml2 (2.6.11-3) unstable; urgency=low
system and restore them so that calling the clean target actually gives
the same tree as before a build.
- -- Mike Hommey <mh@glandium.org> Sat, 31 Jul 2004 16:44:06 +0900
+ -- Mike Hommey <mh@glandium.org> Sat, 31 Jul 2004 17:34:22 +0900
libxml2 (2.6.11-2) unstable; urgency=medium
diff --git a/debian/rules b/debian/rules
index 95f9cf0..3542780 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,7 +3,8 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
-WORKAROUND_BACKUP_FILES=python/libxml2-py.c include/libxml/xmlversion.h libxml2.spec python/setup.py doc/xmlcatalog.1
+WORKAROUND_REMOVED_FILES=include/libxml/xmlversion.h libxml2.spec python/setup.py doc/xmlcatalog.1
+WORKAROUND_MODIFIED_FILES=python/libxml2-py.c
CFLAGS = -Wall -g
@@ -22,7 +23,7 @@ build-stamp:
dh_testdir
# Workaround backups because of non-idempotent upstream:
- for file in $(WORKAROUND_BACKUP_FILES); do \
+ for file in $(WORKAROUND_REMOVED_FILES) $(WORKAROUND_MODIFIED_FILES); do \
cp -f -a $${file} $${file}-tmp; \
done
@@ -47,6 +48,11 @@ clean:
-rm -f example/Makefile
rm COPYING && cp Copyright COPYING
+ # Restore workaround backups of removed files
+ -for file in $(WORKAROUND_REMOVED_FILES); do \
+ mv -f $${file}-tmp $${file}; \
+ done
+
-test -r /usr/share/misc/config.sub && \
cp -f /usr/share/misc/config.sub config.sub
-test -r /usr/share/misc/config.guess && \
@@ -70,8 +76,9 @@ install-stamp: build-stamp
mv debian/tmp/usr/share/aclocal/libxml.m4 debian/tmp/usr/share/aclocal/libxml2.m4
- # Restore workaround backups
- -for file in $(WORKAROUND_BACKUP_FILES); do \
+ # Restore workaround backups of modified files.
+ # Use cat instead of mv for svn-buildpackage.
+ -for file in $(WORKAROUND_MODIFIED_FILES); do \
test -r $${file}-tmp && \
cat $${file}-tmp > $${file} && \
rm -f $${file}-tmp; \