summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Hommey <glandium@debian.org>2008-03-04 22:36:22 +0100
committerMike Hommey <glandium@debian.org>2008-03-04 22:36:22 +0100
commit077c26c93907018e0562908bf636b76898fca1cd (patch)
tree2516bc0ae5553327f1b17ebae25f2f701e6ecf09
parent6bc848377155e136631a22ec0846088d973c536b (diff)
downloadlibxml2-077c26c93907018e0562908bf636b76898fca1cd.tar.gz
* debian/rules: Brown paper bag: uncomment $(MAKE) distclean.
Closes: #442656. * xstc/Makefile.am, xstc/Makefile.in: Properly clean generated files.
-rw-r--r--debian/changelog8
-rwxr-xr-xdebian/rules2
-rw-r--r--xstc/Makefile.am6
-rw-r--r--xstc/Makefile.in18
4 files changed, 20 insertions, 14 deletions
diff --git a/debian/changelog b/debian/changelog
index 05603dc..a71fd8a 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+libxml2 (2.6.31.dfsg-2) UNRELEASED; urgency=low
+
+ * debian/rules: Brown paper bag: uncomment $(MAKE) distclean.
+ Closes: #442656.
+ * xstc/Makefile.am, xstc/Makefile.in: Properly clean generated files.
+
+ -- Mike Hommey <glandium@debian.org> Tue, 04 Mar 2008 22:02:17 +0100
+
libxml2 (2.6.31.dfsg-1) unstable; urgency=low
* New upstream release.
diff --git a/debian/rules b/debian/rules
index b376353..ac5cb49 100755
--- a/debian/rules
+++ b/debian/rules
@@ -59,7 +59,7 @@ clean:
dh_testroot
rm -f build-stamp install*-stamp
- #-$(MAKE) distclean
+ -$(MAKE) distclean
-rm -f example/Makefile
rm COPYING && cp Copyright COPYING
diff --git a/xstc/Makefile.am b/xstc/Makefile.am
index 2d24f02..8aa0d51 100644
--- a/xstc/Makefile.am
+++ b/xstc/Makefile.am
@@ -128,8 +128,4 @@ valgrind:
echo '## Running the regression tests under Valgrind' ; \
$(MAKE) CHECKER='valgrind -q' MAKEFLAGS+=--silent pytests ; fi);
-clean:
- rm -f $(PYSCRIPTS) test.log
-
-distclean:
- rm -rf $(PYSCRIPTS) test.log # TESTDIRS
+CLEANFILES=$(PYSCRIPTS) test.log
diff --git a/xstc/Makefile.in b/xstc/Makefile.in
index 0395671..4cf8967 100644
--- a/xstc/Makefile.in
+++ b/xstc/Makefile.in
@@ -1,8 +1,8 @@
-# Makefile.in generated by automake 1.10 from Makefile.am.
+# Makefile.in generated by automake 1.10.1 from Makefile.am.
# @configure_input@
# Copyright (C) 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002,
-# 2003, 2004, 2005, 2006 Free Software Foundation, Inc.
+# 2003, 2004, 2005, 2006, 2007, 2008 Free Software Foundation, Inc.
# This Makefile.in is free software; the Free Software Foundation
# gives unlimited permission to copy and/or distribute it,
# with or without modifications, as long as this notice is preserved.
@@ -72,6 +72,7 @@ DEFS = @DEFS@
DEPDIR = @DEPDIR@
DLLTOOL = @DLLTOOL@
DOCB_OBJ = @DOCB_OBJ@
+DSYMUTIL = @DSYMUTIL@
ECHO = @ECHO@
ECHO_C = @ECHO_C@
ECHO_N = @ECHO_N@
@@ -113,6 +114,7 @@ MODULE_EXTENSION = @MODULE_EXTENSION@
MODULE_PLATFORM_LIBS = @MODULE_PLATFORM_LIBS@
MV = @MV@
M_LIBS = @M_LIBS@
+NMEDIT = @NMEDIT@
OBJDUMP = @OBJDUMP@
OBJEXT = @OBJEXT@
PACKAGE = @PACKAGE@
@@ -282,6 +284,7 @@ NISTTESTDEF_2 = NISTXMLSchemaDatatypes.testSet
# The local data and scripts
#
EXTRA_DIST = xstc.py xstc-to-python.xsl
+CLEANFILES = $(PYSCRIPTS) test.log
all: all-am
.SUFFIXES:
@@ -374,6 +377,7 @@ install-strip:
mostlyclean-generic:
clean-generic:
+ -test -z "$(CLEANFILES)" || rm -f $(CLEANFILES)
distclean-generic:
-test -z "$(CONFIG_CLEAN_FILES)" || rm -f $(CONFIG_CLEAN_FILES)
@@ -381,8 +385,12 @@ distclean-generic:
maintainer-clean-generic:
@echo "This command is intended for maintainers to use"
@echo "it deletes files that may require special tools to rebuild."
+clean: clean-am
+
clean-am: clean-generic clean-libtool mostlyclean-am
+distclean: distclean-am
+ -rm -f Makefile
distclean-am: clean-am distclean-generic
dvi: dvi-am
@@ -552,12 +560,6 @@ valgrind:
-@(if [ -x $(PYTHON) ] ; then \
echo '## Running the regression tests under Valgrind' ; \
$(MAKE) CHECKER='valgrind -q' MAKEFLAGS+=--silent pytests ; fi);
-
-clean:
- rm -f $(PYSCRIPTS) test.log
-
-distclean:
- rm -rf $(PYSCRIPTS) test.log # TESTDIRS
# Tell versions [3.59,3.63) of GNU make to not export all variables.
# Otherwise a system limit (for SysV at least) may be exceeded.
.NOEXPORT: