summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Hommey <glandium@debian.org>2010-03-18 11:05:51 +0100
committerMike Hommey <glandium@debian.org>2010-03-20 09:08:33 +0100
commit915eccc859fa89dd07e120165b79bf934290fec7 (patch)
tree11b3f0a4ae5492674f4c7db0e82e08baa84745c6
parent7d356004cff07e21bc5fe8b0f8fc6418adb99c35 (diff)
downloadlibxml2-915eccc859fa89dd07e120165b79bf934290fec7.tar.gz
Force -Wl,--as-needed at the beginning of the gcc command line
-rwxr-xr-xdebian/rules4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 465c200..ed0b3a5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -33,7 +33,7 @@ build-stamp:
dh_testdir
# ./configure
- mkdir build; cd build && LDFLAGS="-Wl,--as-needed" CFLAGS="$(CFLAGS)" ../configure $(confflags) --prefix=/usr --with-history --without-python
+ mkdir build; cd build && CC="gcc -Wl,--as-needed" CFLAGS="$(CFLAGS)" ../configure $(confflags) --prefix=/usr --with-history --without-python
# Build libxml2
$(MAKE) -C build
@@ -85,7 +85,7 @@ install-stamp: build-stamp
touch install-stamp
build-python%-stamp: build-stamp
- mkdir build-python$*; cd build-python$* && LDFLAGS="-Wl,--as-needed" CFLAGS="$(CFLAGS)" ../configure $(confflags) --prefix=/usr --with-history --with-python=/usr/bin/python$*
+ mkdir build-python$*; cd build-python$* && CC="gcc -Wl,--as-needed" CFLAGS="$(CFLAGS)" ../configure $(confflags) --prefix=/usr --with-history --with-python=/usr/bin/python$*
mv build-python$*/python build/python$*
$(MAKE) -C build/python$*