summaryrefslogtreecommitdiff
path: root/ChangeLog
diff options
context:
space:
mode:
authorMike Hommey <glandium@debian.org>2005-04-04 18:23:13 +0000
committerMike Hommey <glandium@debian.org>2005-04-04 18:23:13 +0000
commit0fc063df3ab2ad380d532d210dd1001de473e51b (patch)
tree6f88f0a0f845dd6aec7807b18cb5618d93e159ac /ChangeLog
parent50e5b428562964b1eb2f876370058b34b47c5e90 (diff)
downloadlibxml2-0fc063df3ab2ad380d532d210dd1001de473e51b.tar.gz
Load /tmp/tmp.98zkCi/libxml2-2.6.19 intoupstream/2.6.19
packages/libxml2/branches/upstream/current.
Diffstat (limited to 'ChangeLog')
-rw-r--r--ChangeLog204
1 files changed, 204 insertions, 0 deletions
diff --git a/ChangeLog b/ChangeLog
index a64f9b1..7860d96 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,207 @@
+Sat Apr 2 12:48:41 CEST 2005 Daniel Veillard <daniel@veillard.com>
+
+ * doc/* configure.in NEWS: preparing release 2.6.19, updated docs and
+ rebuilding.
+
+Sat Apr 2 13:27:32 CEST 2005 Daniel Veillard <daniel@veillard.com>
+
+ * xstc/Makefile.am: integrated fixup-tests.py
+
+Fri Apr 1 19:14:18 CEST 2005 Daniel Veillard <daniel@veillard.com>
+
+ * xmlschemastypes.c: fixed a lack of comment and missing test for
+ a pointer in the API.
+
+Fri Apr 1 17:54:22 CEST 2005 Kasimier Buchcik <libxml2-cvs@cazic.net>
+
+ * xstc/fixup-tests.py: A tiny script to fixup some of the schema
+ files used for the tests.
+
+Fri Apr 1 17:33:50 CEST 2005 Kasimier Buchcik <libxml2-cvs@cazic.net>
+
+ * xmlschemas.c include/libxml/schemasInternals.h
+ result/schemas/src-element2-*.err result/schemas/element-*.err:
+ Committing again, since the CVS server aborted.
+
+Fri Apr 1 15:29:27 CEST 2005 Kasimier Buchcik <libxml2-cvs@cazic.net>
+
+ * xmlschemastypes.c: Corrected 'length' facet validation for
+ QNames and notations. Corrected xmlSchemaGetCanonValue: some
+ data types did not return a value if already in normalized
+ form.
+ * xmlschemas.c include/libxml/schemasInternals.h:
+ Eliminated creation of structs for <restriction>, <extension>,
+ <simpleContent>, <complexContent>, <list> and <union>: the
+ information is now set directly on the corresponding simple/
+ complex type. Added some more complex type constraints.
+ Added facet derivation constraints. Introduced "particle"
+ components, which seem to be really needed if applying
+ constraints. Corrected/change some of the parsing functions.
+ This is all a bit scary, since a significant change to the code.
+ * result/schemas/src-element2-*.err result/schemas/element-*.err:
+ Adapted regression test results.
+
+Fri Apr 1 16:07:59 CEST 2005 Daniel Veillard <daniel@veillard.com>
+
+ * doc/apibuild.py doc/elfgcchack.xsl: revamped the elfgcchack.h
+ format to cope with gcc4 change of aliasing allowed scopes, had
+ to add extra informations to doc/libxml2-api.xml to separate
+ the header from the c module source.
+ * *.c: updated all c library files to add a #define bottom_xxx
+ and reimport elfgcchack.h thereafter, and a bit of cleanups.
+ * doc//* testapi.c: regenerated when rebuilding the API
+
+Thu Mar 31 17:20:32 CEST 2005 Daniel Veillard <daniel@veillard.com>
+
+ * xmlsave.c: fixed bug reported by Petr Pajas, in the absence of
+ encoding UTF-8 should really be assumed. This may break if
+ the HTTP headers indicates for example ISO-8859-1 since this
+ then becomes a well formedness error.
+
+Thu Mar 31 16:57:18 CEST 2005 Daniel Veillard <daniel@veillard.com>
+
+ * SAX.c: fixed #172260 redundant assignment.
+ * parser.c include/libxml/parser.h: fixed xmlSAXParseDoc() and
+ xmlParseDoc() signatures #172257.
+
+Thu Mar 31 16:11:10 CEST 2005 Daniel Veillard <daniel@veillard.com>
+
+ * parser.c: fix potential crash if ctxt->sax->ignorableWhitespace
+ is NULL as reported by bug #172255
+
+Thu Mar 31 15:36:52 CEST 2005 Daniel Veillard <daniel@veillard.com>
+
+ * relaxng.c: fixed a problem in Relax-NG validation #159968
+ * test/relaxng/list.* result/relaxng/list_*: added the test
+ to the regression suite
+
+Thu Mar 31 13:06:02 CEST 2005 Daniel Veillard <daniel@veillard.com>
+
+ * python/libxml.c: fixed bug #168504
+
+Thu Mar 31 12:22:54 CEST 2005 Daniel Veillard <daniel@veillard.com>
+
+ * config.h.in configure.in nanoftp.c nanohttp.c xmllint.c
+ macos/src/config-mac.h: use XML_SOCKLEN_T instead of SOCKLEN_T
+ since apparently IBM can't avoid breaking common defines #166922
+
+Thu Mar 31 10:41:45 CEST 2005 Daniel Veillard <daniel@veillard.com>
+
+ * encoding.c: fix unitinialized variable in not frequently used
+ code bug #172182
+
+Thu Mar 31 00:45:18 CEST 2005 Daniel Veillard <daniel@veillard.com>
+
+ * python/generator.py python/libxml.py: another patch from Brent
+ Hendricks to add new handlers with the various validity contexts
+ * python/tests/Makefile.am python/tests/validDTD.py
+ python/tests/validRNG.py python/tests/validSchemas.py: also
+ added the regression tests he provided
+
+Wed Mar 30 09:39:27 CEST 2005 Daniel Veillard <daniel@veillard.com>
+
+ * python/generator.py python/libxml.c: applied patch from Brent
+ Hendricks to avoid leak in python bindings when using schemas
+ error handlers.
+
+Tue Mar 29 22:29:28 CEST 2005 Daniel Veillard <daniel@veillard.com>
+
+ * HTMLtree.c: fixing bug 168196, <a name=""> must be URI escaped too
+
+Sun Mar 27 13:24:24 CEST 2005 Daniel Veillard <daniel@veillard.com>
+
+ * tree.c: cleanup of the Prop related functions and xmlNewNodeEatName
+ by Rob Richards
+
+Thu Mar 24 19:01:22 PST 2005 William Brack <wbrack@mmm.com.hk>
+
+ * gentest.py, testapi.c: fixed problem with 'minimal library'
+ compilation (LIBXML_PATTERN_ENABLED not properly checked) reported
+ by Greg Morgan
+
+Thu Mar 24 12:01:30 CET 2005 Kasimier Buchcik <libxml2-cvs@cazic.net>
+
+ * xmlschemas.c: Fixed call to a facet error report: the type of
+ the error was wrong, resulting in a segfault (bug #171220, reported
+ by GUY Fabrice).
+
+Mon Mar 21 22:58:37 CET 2005 Kasimier Buchcik <libxml2-cvs@cazic.net>
+
+ * xmlschemas.c: Removed a stupid bug in xmlSchemaValidateAttributes,
+ failing to build a linked list correctly (bug #169898, reported
+ by bing song, hmm...).
+
+Mon Mar 21 21:09:07 CET 2005 Kasimier Buchcik <libxml2-cvs@cazic.net>
+
+ * xmlschemas.c: Fixed a segfault, which occured during bubbling
+ of IDC nodes (bug #170779 and #170778, reported by GUY Fabrice):
+ a variable was missed to be reset in a loop. Deactivated bubbling,
+ if not referenced by a keyref.
+
+Sun Mar 20 11:13:02 PST 2005 Aleksey Sanin <aleksey@aleksey.com>
+
+ * c14n.c include/libxml/xmlerror.h: special case "DAV:" namespace
+ in c14n relative namespaces check and add structured error messages
+ to c14n code
+
+Thu Mar 17 12:55:23 CET 2005 Kasimier Buchcik <libxml2-cvs@cazic.net>
+
+ * xmlschemas.c: Removed inheritance of "mixed" content type for
+ short-hand restrictions of "anyType" (reported by Guy Fabrice
+ to the mailing list). Added the namespace conversion (chameleon
+ includes) for the base type reference of <restriction> and
+ <extension>.
+ * test/schemas/bug152470_1.xsd: Adapted due to the above change
+ of "mixed" inheritance.
+
+Thu Mar 17 11:03:59 CET 2005 Daniel Veillard <daniel@veillard.com>
+
+ * xmlschemas.c: fixed a = -> == error pointed by GUY Fabrice
+
+Wed Mar 16 22:53:53 CET 2005 Daniel Veillard <daniel@veillard.com>
+
+ * xmlschemas.c: more debug messages from Matthew Burgess
+ * xmlschemastypes.c: xmlSchemaValidateLengthFacet API missing check.
+
+Wed Mar 16 17:37:04 CET 2005 Kasimier Buchcik <libxml2-cvs@cazic.net>
+
+ * xmlschemastypes.c: Aaaannnd putting back the previous changes done
+ by Daniel, which I overwrote with the previous commit.
+
+Wed Mar 16 17:20:25 CET 2005 Kasimier Buchcik <libxml2-cvs@cazic.net>
+
+ * xmlschemas.c xmlschemastypes.c include/libxml/xmlschemastypes.h:
+ Hopefully finished validation against facets to use the normalized
+ value of both, the facets and instance values. Added
+ xmlSchemaValidateLengthFacetWhtsp(), xmlSchemaValidateFacetWhtsp()
+ and xmlSchemaGetValType() to the schema API.
+
+Wed Mar 16 13:55:31 CET 2005 Daniel Veillard <daniel@veillard.com>
+
+ * libxml.spec.in: do not package .la files
+ * xmllint.c: applied patch from Gerry Murphy for xmllint return code
+ * xmlschemastypes.c: fixed a couple of missing tests of parameters
+ at public API entry points.
+
+Tue Mar 15 23:31:14 HKT 2005 William Brack <wbrack@mmm.com.hk>
+
+ * xmlschemastypes.c: a couple of more changes to various
+ decimal-handling routines. Fixes python some problems
+ turned up by the python tests.
+ * Makefile.am: change SchemasPythonTests message to warn
+ that there are 10 'expected' errors (rather than 6) since
+ we now reject a '+' sign on an unsigned.
+
+Tue Mar 15 15:43:27 CET 2005 Kasimier Buchcik <libxml2-cvs@cazic.net>
+
+ * xmlschemastypes.c xmlschemastypes.h: In preparation to use
+ normalized values of facets during validation: changed the
+ arguments of some string comparison functions; added a static
+ xmlSchemaValidateFacetInternal() with more arguments to be
+ more flexible. Prepared XML_SCHEMA_FACET_ENUMERATION validation
+ to use the comparison functions. Fixed some assignments in
+ xmlSchemaValAtomicType(): total digit count, lo, mi, hi.
+
Sun Mar 13 19:32:03 CET 2005 Daniel Veillard <daniel@veillard.com>
* NEWS configure.in testapi.c doc/*: preparing release of 2.6.18