summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMike Hommey <glandium@debian.org>2010-03-18 07:41:21 +0100
committerMike Hommey <glandium@debian.org>2010-03-18 07:42:59 +0100
commit8a4aad62c5cb21da7cd5cc42e54fc02c6ad86966 (patch)
treef80336aa670a71c716fc4b0363f6ced3c86940bb /Makefile.am
parentddaa8a96ed86663861266bf05ab7bd299dadcf61 (diff)
parenteb5d521a2df72fa829a7f8196b957c696e7ccc58 (diff)
downloadlibxml2-8a4aad62c5cb21da7cd5cc42e54fc02c6ad86966.tar.gz
Merge branch 'upstream'
Conflicts: aclocal.m4 config.guess config.sub configure ltmain.sh
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 03ffdcd..635e395 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,7 @@
## Process this file with automake to produce Makefile.in
+ACLOCAL_AMFLAGS = -I m4
+
SUBDIRS = include . doc example xstc @PYTHON_SUBDIR@
DIST_SUBDIRS = include . doc example python xstc
@@ -157,7 +159,7 @@ testModule_LDADD= $(LDADDS)
#noinst_LTLIBRARIES = testdso.la
testdso_la_SOURCES = testdso.c
-testdso_la_LDFLAGS = -module -rpath $(libdir)
+testdso_la_LDFLAGS = -module -no-undefined -avoid-version -rpath $(libdir)
# that one forces the rebuild when "make rebuild" is run on doc/
rebuild_testapi: