summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMike Hommey <glandium@debian.org>2009-09-25 22:17:31 +0200
committerMike Hommey <glandium@debian.org>2009-09-25 22:17:31 +0200
commit67a17fecb5b5fe2058af6405bc9601875f3e75a1 (patch)
tree73a7ed49173098b5c59eeb8a33747d3b803d2309 /configure.in
parentc3e4f3c26035bc93a69e5aa2ad435809e8be8a4e (diff)
downloadlibxml2-67a17fecb5b5fe2058af6405bc9601875f3e75a1.tar.gz
Import upstream version 2.7.5upstream/2.7.5.dfsg
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 7b8fd44..4d540cf 100644
--- a/configure.in
+++ b/configure.in
@@ -5,7 +5,7 @@ AC_CANONICAL_HOST
LIBXML_MAJOR_VERSION=2
LIBXML_MINOR_VERSION=7
-LIBXML_MICRO_VERSION=4
+LIBXML_MICRO_VERSION=5
LIBXML_MICRO_VERSION_SUFFIX=
LIBXML_VERSION=$LIBXML_MAJOR_VERSION.$LIBXML_MINOR_VERSION.$LIBXML_MICRO_VERSION$LIBXML_MICRO_VERSION_SUFFIX
LIBXML_VERSION_INFO=`expr $LIBXML_MAJOR_VERSION + $LIBXML_MINOR_VERSION`:$LIBXML_MICRO_VERSION:$LIBXML_MINOR_VERSION
@@ -742,6 +742,7 @@ if test "$with_python" != "no" ; then
PYTHON_SITE_PACKAGES=`$PYTHON -c "from distutils import sysconfig; print sysconfig.get_python_lib()"`
fi
fi
+ PYTHON_LIBS=`python$PYTHON_VERSION-config --libs`
fi
if test "$with_python" != ""
then
@@ -761,6 +762,7 @@ else
fi
AC_SUBST(pythondir)
AC_SUBST(PYTHON_SUBDIR)
+AC_SUBST(PYTHON_LIBS)
dnl check for dso support
WITH_MODULES=0
@@ -884,7 +886,7 @@ if test "$with_threads" = "no" ; then
else
echo Enabling multithreaded support
dnl Use pthread by default
- if test "$with_threads" = "pthread" | test "$with_threads" = "" ; then
+ if test "$with_threads" = "pthread" | test "$with_threads" = "" | test "$with_threads" = "yes" ; then
AC_CHECK_HEADER(pthread.h,
AC_CHECK_LIB(pthread, pthread_join,[
THREAD_LIBS="-lpthread"