summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMike Hommey <glandium@debian.org>2007-04-17 20:40:00 +0200
committerMike Hommey <glandium@debian.org>2007-04-17 20:40:00 +0200
commit789259a1b6850d30acffbb62b11456b9ed7a8f59 (patch)
tree842f2f9042a4264898ec29078aa029640078c393 /configure.in
parent968041a8b2ec86c39b5074024ce97d136ecd9a95 (diff)
downloadlibxml2-789259a1b6850d30acffbb62b11456b9ed7a8f59.tar.gz
Load /tmp/libxml2-2.6.28 intoupstream/2.6.28.dfsg
libxml2/branches/upstream/current.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 17 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index b2174c6..c355498 100644
--- a/configure.in
+++ b/configure.in
@@ -5,20 +5,28 @@ AC_CANONICAL_HOST
LIBXML_MAJOR_VERSION=2
LIBXML_MINOR_VERSION=6
-LIBXML_MICRO_VERSION=27
+LIBXML_MICRO_VERSION=28
LIBXML_MICRO_VERSION_SUFFIX=
LIBXML_VERSION=$LIBXML_MAJOR_VERSION.$LIBXML_MINOR_VERSION.$LIBXML_MICRO_VERSION$LIBXML_MICRO_VERSION_SUFFIX
LIBXML_VERSION_INFO=`expr $LIBXML_MAJOR_VERSION + $LIBXML_MINOR_VERSION`:$LIBXML_MICRO_VERSION:$LIBXML_MINOR_VERSION
LIBXML_VERSION_NUMBER=`expr $LIBXML_MAJOR_VERSION \* 10000 + $LIBXML_MINOR_VERSION \* 100 + $LIBXML_MICRO_VERSION`
-if test -f CVS/Entries; then
+if test -f CVS/Entries ; then
extra=`grep ChangeLog CVS/Entries | grep -v LIBXML | sed -e s\%/ChangeLog/1\.%% -e s\%/.*$%%`
echo extra=$extra
if test "$extra" != ""
then
LIBXML_VERSION_EXTRA="-CVS$extra"
fi
+else if test -d .svn ; then
+ extra=`svn info | grep Revision | sed 's+Revision: ++'`
+ echo extra=$extra
+ if test "$extra" != ""
+ then
+ LIBXML_VERSION_EXTRA="-SVN$extra"
+ fi
+fi
fi
AC_SUBST(LIBXML_MAJOR_VERSION)
AC_SUBST(LIBXML_MINOR_VERSION)
@@ -498,8 +506,9 @@ fi
if test $enable_ipv6 = yes; then
have_ipv6=no
AC_TRY_COMPILE([
+ #include <sys/types.h>
#include <sys/socket.h>
- #include <sys/types.h>], [
+ ], [
struct sockaddr_storage ss;
socket(AF_INET6, SOCK_STREAM, 0)
],
@@ -521,8 +530,9 @@ if test $enable_ipv6 = yes; then
dnl ********************************************************************
AC_MSG_CHECKING([struct sockaddr::ss_family])
AC_TRY_COMPILE([
+ #include <sys/types.h>
#include <sys/socket.h>
- #include <sys/types.h>], [
+ ], [
struct sockaddr_storage ss ;
ss.ss_family = 0 ;
],
@@ -533,8 +543,9 @@ if test $enable_ipv6 = yes; then
if test x$have_ss_family = xno ; then
AC_MSG_CHECKING([broken struct sockaddr::ss_family])
AC_TRY_COMPILE([
+ #include <sys/types.h>
#include <sys/socket.h>
- #include <sys/types.h>], [
+ ], [
struct sockaddr_storage ss ;
ss.__ss_family = 0 ;
],
@@ -788,8 +799,7 @@ dnl (-Wunreachable-code)
dnl
if [[ "${LOGNAME}" = "veillard" -a "`pwd`" = "/u/veillard/XML" ]] || \
[[ "${LOGNAME}" = "veillard" -a "`pwd`" = "/home/veillard/libxml2" ]] || \
- [[ "${LOGNAME}" = "bill" -a "`pwd`" = "/home/bill/gnomecvs/xmltest" ]] || \
- [[ "${LOGNAME}" = "wbrack" -a "`pwd`" = "/Users/wbrack/gnomecvs/xmltest" ]]
+ [[ "${LOGNAME}" = "bill" -a "`pwd`" = "/home/bill/gnomesvn/libxml2" ]]
then
if test "$with_minimum" != "yes"
then