summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
authorAron Xu <aron@debian.org>2012-04-14 01:34:28 +0800
committerAron Xu <aron@debian.org>2012-04-14 01:34:28 +0800
commit6205aa529c62396b509525bc4283e765ae0ebee8 (patch)
treee306d6310f4a3524ed4548a32fec8938cbc9e2a8 /debian/patches
parent3d829c1d964f278b9043ae8c4dc0a53600e86a1d (diff)
downloadlibxml2-6205aa529c62396b509525bc4283e765ae0ebee8.tar.gz
Initial commit on migrating to 3.0 source format (not complete).
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/01_build-system.patch55
-rw-r--r--debian/patches/series1
2 files changed, 56 insertions, 0 deletions
diff --git a/debian/patches/01_build-system.patch b/debian/patches/01_build-system.patch
new file mode 100644
index 0000000..16a9c9f
--- /dev/null
+++ b/debian/patches/01_build-system.patch
@@ -0,0 +1,55 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -8,10 +8,10 @@
+
+ INCLUDES = -I$(top_builddir)/include -I@srcdir@/include @THREAD_CFLAGS@ @Z_CFLAGS@
+
+-noinst_PROGRAMS=testSchemas testRelax testSAX testHTML testXPath testURI \
+- testThreads testC14N testAutomata testRegexp \
+- testReader testapi testModule runtest runsuite testchar \
+- testdict runxmlconf testrecurse
++#noinst_PROGRAMS=testSchemas testRelax testSAX testHTML testXPath testURI \
++# testThreads testC14N testAutomata testRegexp \
++# testReader testapi testModule runtest runsuite testchar \
++# testdict runxmlconf testrecurse
+
+ bin_PROGRAMS = xmllint xmlcatalog
+
+@@ -157,7 +157,7 @@
+ testModule_DEPENDENCIES = $(DEPS)
+ testModule_LDADD= $(LDADDS)
+
+-noinst_LTLIBRARIES = testdso.la
++#noinst_LTLIBRARIES = testdso.la
+ testdso_la_SOURCES = testdso.c
+ testdso_la_LDFLAGS = -module -no-undefined -avoid-version -rpath $(libdir)
+
+--- a/configure.in
++++ b/configure.in
+@@ -70,6 +70,8 @@
+ AC_LIBTOOL_WIN32_DLL
+ AM_PROG_LIBTOOL
+
++AM_MAINTAINER_MODE
++
+ dnl
+ dnl if the system support linker version scripts for symbol versioning
+ dnl then add it
+@@ -84,7 +86,7 @@
+ esac
+ fi
+ AC_SUBST(VERSION_SCRIPT_FLAGS)
+-AM_CONDITIONAL([USE_VERSION_SCRIPT], [test -z "$VERSION_SCRIPT_FLAGS"])
++AM_CONDITIONAL([USE_VERSION_SCRIPT], [test -n "$VERSION_SCRIPT_FLAGS"])
+
+ dnl
+ dnl We process the AC_ARG_WITH first so that later we can modify
+@@ -1319,7 +1321,7 @@
+ *) M_LIBS="-lm"
+ ;;
+ esac
+-XML_LIBS="-lxml2 $Z_LIBS $THREAD_LIBS $ICONV_LIBS $M_LIBS $LIBS"
++XML_LIBS="-lxml2"
+ XML_LIBTOOLLIBS="libxml2.la"
+ AC_SUBST(WITH_ICONV)
+
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..56dd302
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1 @@
+01_build-system.patch