summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMatthias Klose <doko@debian.org>2015-09-22 13:37:01 +0800
committerAron Xu <aron@debian.org>2015-09-22 13:37:01 +0800
commit08766acaa78dcf7b2174cca94d5e102f910df6dd (patch)
tree3072dda866636b63046afb7c179e485e56af0fcb /debian
parent8cf3006167b0d48de8da96c475785549fbb1ad07 (diff)
downloadlibxml2-08766acaa78dcf7b2174cca94d5e102f910df6dd.tar.gz
Don't hardcode the libicuXX-dbg dependency. Closes: #798642
Diffstat (limited to 'debian')
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules3
2 files changed, 4 insertions, 1 deletions
diff --git a/debian/control b/debian/control
index a1a6813..152172f 100644
--- a/debian/control
+++ b/debian/control
@@ -85,7 +85,7 @@ Package: libxml2-dbg
Architecture: any
Section: debug
Priority: extra
-Depends: libxml2 (= ${binary:Version}), libicu52-dbg, ${misc:Depends}
+Depends: libxml2 (= ${binary:Version}), ${dep:libicudbg}, ${misc:Depends}
Multi-Arch: same
Description: Debugging symbols for the GNOME XML library
XML is a metalanguage to let you design your own markup language.
diff --git a/debian/rules b/debian/rules
index 8264b07..5b849df 100755
--- a/debian/rules
+++ b/debian/rules
@@ -138,6 +138,9 @@ endif
override_dh_makeshlibs:
dh_makeshlibs -a $(if $(WITH_UDEB),--add-udeb=libxml2-udeb )-V 'libxml2 (>= 2.7.4)' -- -c4
+override_dh_gencontrol:
+ dh_gencontrol -- -Vdep:libicudbg="`dpkg-query -f '$${Depends}' -W libicu-dev | sed 's/.*\(libicu[0-9]*\).*/\1/'`-dbg"
+
%:
ifeq ($(DEB_BUILD_PROFILE),stage1)
dh $@ --with autoreconf