summaryrefslogtreecommitdiff
path: root/ChangeLog
diff options
context:
space:
mode:
Diffstat (limited to 'ChangeLog')
-rw-r--r--ChangeLog362
1 files changed, 362 insertions, 0 deletions
diff --git a/ChangeLog b/ChangeLog
index acbcb90..72bf7c1 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,365 @@
+Sun Jan 16 21:00:53 CET 2005 Daniel Veillard <daniel@veillard.com>
+
+ * configure.in NEWS doc/*: preparing release of 2.6.17,
+ updated and rebuilt the docs
+
+Sun Jan 16 19:58:36 CET 2005 Daniel Veillard <daniel@veillard.com>
+
+ * parser.c: better fix for #151694 not killing c14n regression tests
+ * xmlschemastypes.c: fixing bug #157653
+
+Sun Jan 16 19:01:06 CET 2005 Daniel Veillard <daniel@veillard.com>
+
+ * parser.c: fixing bug #151694, line should always be set in the
+ elements.
+
+Sun Jan 16 01:04:18 CET 2005 Daniel Veillard <daniel@veillard.com>
+
+ * xmlschemastypes.c: trying to fix at least the message from
+ bug #158628
+ * include/libxml/xmlsave.h xmlsave.c: added first xmlsave option
+ for format, c.f. bug #159997
+
+Sat Jan 15 18:44:30 CET 2005 Daniel Veillard <daniel@veillard.com>
+
+ * python/libxml.py: make __str__ call serialize() on nodes, c.f.
+ bug #157872
+
+Sat Jan 15 18:18:07 CET 2005 Daniel Veillard <daniel@veillard.com>
+
+ * nanoftp.c: applied patch from Dan McNichol for compilation on AIX
+
+Sat Jan 15 13:35:19 CET 2005 Daniel Veillard <daniel@veillard.com>
+
+ * relaxng.c: fixed bug #157633 in relaxng choice optimization
+ * result/relaxng/choice0* test/relaxng/choice0*: added regression
+ tests about it.
+ * doc/*: rebuilt
+ * testdso.c: removed a warning due to a missing void in signature.
+
+Thu Jan 13 17:42:55 CET 2005 Kasimier Buchcik <libxml2-cvs@cazic.net>
+
+ * include/libxml/schemasInternals.h xmlschemas.c:
+ Exposed targetNamespace for simple/complex types, model groups,
+ attribute groups and notations (reported by Michael Hewarth
+ to the mailing list). Added targetNamespace to xmlSchemaType,
+ xmlSchemaAttributeGroup and xmlSchemaNotation.
+ Tiny cosmetic change to the content model error report output.
+ * result//all_*.err result//any3_0_0.err result//choice_*.err
+ result//list0_0_1.err result//list0_1_1.err: Adapted output
+ of regression tests.
+
+Thu Jan 13 13:20:51 CET 2005 Kasimier Buchcik <libxml2-cvs@cazic.net>
+
+ * xmlschemas.c: Put the fix of Daniel (from Tue Jan 11 14:41:47 CET)
+ back in, since I missed to update xmlschemas.c before doing
+ the previous commit.
+
+Thu Jan 13 12:59:25 CET 2005 Kasimier Buchcik <libxml2-cvs@cazic.net>
+
+ * xmlschemas.c: Integrated xmlRegExecErrInfo and xmlRegExecNextValues
+ from xmlregexp.c to report expected elements on content model errors.
+ * all_*.err any3_0_0.err choice_*.err list0_0_1.err list0_1_1.err:
+ Adapted output of regression tests.
+
+Thu Jan 13 12:24:09 CET 2005 Daniel Veillard <daniel@veillard.com>
+
+ * config.h.in configure.in xmlmodule.c: trying to work around
+ the compilation problem on HP-UX
+
+Wed Jan 12 22:03:33 CET 2005 Daniel Veillard <daniel@veillard.com>
+
+ * pattern.c: fixed the fixed size array structure problem reported by
+ Patrick Streule
+
+Wed Jan 12 15:15:02 CET 2005 Daniel Veillard <daniel@veillard.com>
+
+ * elfgcchack.h testapi.c doc/libxml2-api.xml doc/*: regenerated
+ the API description, rebuilt, improved navigation in documentation
+ a bit.
+
+Wed Jan 12 14:17:14 CET 2005 Daniel Veillard <daniel@veillard.com>
+
+ * include/libxml/xmlregexp.h xmlregexp.c: extended xmlRegExecErrInfo()
+ and xmlRegExecNextValues() to return error transition strings too,
+ and sink state detection and handling.
+
+Tue Jan 11 14:41:47 CET 2005 Daniel Veillard <daniel@veillard.com>
+
+ * xmlschemas.c: fixed bug #163641 when the value passed for
+ an atomic list type is NULL.
+
+Tue Jan 11 10:14:33 HKT 2005 William Brack <wbrack@mmm.com.hk>
+
+ * Makefile.am configure.in: fixed dependency on python 2.3,
+ also small improvement for cygwin (bug 163273)
+
+Sun Jan 9 18:46:32 CET 2005 Daniel Veillard <daniel@veillard.com>
+
+ * gentest.py testapi.c: William noticed I forgot to add special
+ support for xmlmodules.c define
+ * xmlregexp.c include/libxml/xmlregexp.h: added terminal to
+ xmlRegExecErrInfo() API, adding new xmlRegExecNextValues()
+ entry point and refactored to use both code.
+
+Mon Jan 10 01:02:41 HKT 2006 William Brack <wbrack@mmm.com.hk>
+
+ * doc/xml.html, doc/FAQ.html: added an FAQ under Developer for
+ setting up a "private" library (after some list posts about
+ people having trouble doing it)
+
+Sat Jan 8 23:04:10 CET 2005 Daniel Veillard <daniel@veillard.com>
+
+ * xmlregexp.c: fixing behaviour for xmlRegExecErrInfo in case of
+ rollback
+
+Fri Jan 7 14:54:51 CET 2005 Daniel Veillard <daniel@veillard.com>
+
+ * TODO: small update
+ * xmlregexp.c: trying to add an API to get useful error informations
+ back from a failing regexp context.
+
+Thu Jan 6 17:35:41 HKT 2005 William Brack <wbrack@mmm.com.hk>
+
+ * xpath.c: fixed problem with xmlXPathErr when error number
+ subscript was out of range (bug 163055)
+
+Thu Jan 6 09:57:03 HKT 2005 William Brack <wbrack@mmm.com.hk>
+
+ * uri.c: fixed problem with xmlURIEscape when query part was
+ empty (actually fixed xmlURIEscapeStr to return an empty
+ string rather than NULL for empty string input) (bug 163079)
+
+Tue Jan 4 17:08:45 PST 2005 Aleksey Sanin <aleksey@aleksey.com>
+
+ * parser.c, parserInternal.c: fixed "col" calculation for
+ struct _xmlParserInput (based on patch from Rob Richards)
+ * include/libxml/xmlerror.h, error.c: propagated error column
+ number in the xmlError structure
+
+Tue Jan 4 22:47:22 CET 2005 Daniel Veillard <daniel@veillard.com>
+
+ * parser.c: fixed namespace bug in push mode reported by
+ Rob Richards
+ * test/ns6 result//ns6*: added it to the regression tests
+ * xmlmodule.c testModule.c include/libxml/xmlmodule.h:
+ added an extra option argument to module opening and defined
+ a couple of flags to the API.
+
+Tue Jan 4 21:16:05 CET 2005 Daniel Veillard <daniel@veillard.com>
+
+ * xmlmodule.c include/libxml/xmlmodule.h: applied patch from
+ Bjorn Reese, plus some cleanups
+ * elfgcchack.h doc/elfgcchack.xsl: fixed the stylesheet to
+ add the new header
+ * doc/* testapi.c: regenerated the API
+
+Tue Jan 4 18:47:19 CET 2005 Daniel Veillard <daniel@veillard.com>
+
+ * configure.in: making DSO support an option
+ * xmlmodule.c xmlreader.c include/libxml/xmlmodule.h: code
+ and documentation cleanups
+ * elfgcchack.h testapi.c doc/*: regenerated the docs and
+ checks for new module
+ * test/valid/REC-xml-19980210.xml: fix a small change introduced
+ previously
+
+Tue Jan 4 16:07:52 CET 2005 Daniel Veillard <daniel@veillard.com>
+
+ * Makefile.am config.h.in configure.in error.c libxml-2.0.pc.in
+ testModule.c testdso.c xml2-config.in xmllint.c xmlmodule.c
+ include/libxml/Makefile.am include/libxml/xmlerror.h
+ include/libxml/xmlmodule.h include/libxml/xmlversion.h.in
+ include/libxml/xmlwin32version.h.in: applied DSO support
+ patch 2 from Joel Reed
+
+Tue Jan 4 15:30:15 CET 2005 Daniel Veillard <daniel@veillard.com>
+
+ * configure.in: applied patch from Marcin Konicki for BeOS
+
+Mon Jan 3 13:57:21 PST 2005 Aleksey Sanin <aleksey@aleksey.com>
+
+ * parser.c: added GetLineNumber and GetColumnNumber functions for xmlReader
+
+Sun Jan 2 17:51:18 HKT 2005 William Brack <wbrack@mmm.com.hk>
+
+ Re-examined the problems of configuring a "minimal" library.
+ Synchronized the header files with the library code in order
+ to assure that all the various conditionals (LIBXML_xxxx_ENABLED)
+ were the same in both. Modified the API database content to more
+ accurately reflect the conditionals. Enhanced the generation
+ of that database. Although there was no substantial change to
+ any of the library code's logic, a large number of files were
+ modified to achieve the above, and the configuration script
+ was enhanced to do some automatic enabling of features (e.g.
+ --with-xinclude forces --with-xpath). Additionally, all the format
+ errors discovered by apibuild.py were corrected.
+ * configure.in: enhanced cross-checking of options
+ * doc/apibuild.py, doc/elfgcchack.xsl, doc/libxml2-refs.xml,
+ doc/libxml2-api.xml, gentest.py: changed the usage of the
+ <cond> element in module descriptions
+ * elfgcchack.h, testapi.c: regenerated with proper conditionals
+ * HTMLparser.c, SAX.c, globals.c, tree.c, xmlschemas.c, xpath.c,
+ testSAX.c: cleaned up conditionals
+ * include/libxml/[SAX.h, SAX2.h, debugXML.h, encoding.h, entities.h,
+ hash.h, parser.h, parserInternals.h, schemasInternals.h, tree.h,
+ valid.h, xlink.h, xmlIO.h, xmlautomata.h, xmlreader.h, xpath.h]:
+ synchronized the conditionals with the corresponding module code
+ * doc/examples/tree2.c, doc/examples/xpath1.c, doc/examples/xpath2.c:
+ added additional conditions required for compilation
+ * doc/*.html, doc/html/*.html: rebuilt the docs
+
+Sat Dec 25 18:10:02 HKT 2004 William Brack <wbrack@mmm.com.hk>
+
+ * parserInternals.c: fixed to skip (if necessary) the BOM for
+ encoding 'utf-16'. Completes the fix for bug #152286.
+ * tree.c, parser.c: minor warning cleanup, no change to logic
+
+Fri Dec 24 16:31:22 HKT 2004 William Brack <wbrack@mmm.com.hk>
+
+ * python/generator.py: added most required entires to
+ foreign encoding table, plus some additional logic to
+ assure only the 1st param uses the 't#' format. Fixes
+ bug #152286, but may still have some other UTF-16 problems.
+
+Thu Dec 23 23:44:08 HKT 2004 William Brack <wbrack@mmm.com.hk>
+
+ * Makefile.am, gentest.py: enhanced for enabling build in
+ a different directory. Added (optional) param to gentest.py
+ to specify the source directory (bug #155468)
+ * doc/Makefile.am: changed destination of NEWS from (top_srcdir)
+ to (top_builddir) (bug #155468)
+ * python/Makefile.am, python/generator.py: enhanced for enabling
+ build in a different directory(bug #155468). Added (optional)
+ param to generator.py to specify the source directory. Added
+ a new table of functions which have possible "foreign" encodings
+ (e.g. UTF16), and code to use python 't' format instead of
+ 'z' format (mostly solving bug #152286, but still need to
+ populate the table).
+
+Tue Dec 21 08:10:44 MST 2004 John Fleck <jfleck@inkstain.net>
+
+ * doc/site.xsl, doc/xml.html, plus rebuilt all the html pages
+ Change reference to new site for Solaris binaries, fixing bug
+ 160598
+
+
+Mon Dec 20 08:02:57 PST 2004 William Brack <wbrack@mmm.com.hk>
+
+ * parser.c: reset input->base within xmlStopParser
+ * xmlstring.c: removed call to xmlUTF8Strlen from within
+ xmlUTF8Strpos (Bill Moseley pointed out it was not
+ useful)
+
+Fri Dec 17 16:03:41 PST 2004 William Brack <wbrack@mmm.com.hk>
+
+ * valid.c: changed xmlErrValidWarning to use ctxt->warning
+ instead of ctxt->error for its reports (bug #160662)
+
+Fri Dec 17 14:52:17 PST 2004 William Brack <wbrack@mmm.com.hk>
+
+ * python/generator.py: modified to allow the ns and nsDefs
+ accessors to return None instead of error when no namespace
+ is present (bug #)
+
+Fri Dec 17 11:40:21 PST 2004 William Brack <wbrack@mmm.com.hk>
+
+ * doc/Makefile.am: changed maintainer-clean dependency with
+ suggestion from Crispin Flowerday (bug #157634)
+ * debugXML.c: fixed crash when ATTRIBUTE or DOCUMENT nodes
+ were specified with debugDumpNode (bug #160621)
+
+Fri Dec 10 11:24:41 CET 2004 Daniel Veillard <daniel@veillard.com>
+
+ * valid.c: fixed ID deallocation problem based on patch from
+ Steve Shepard fixes bug #160893
+ * xmlmemory.c: improving comment.
+ * testapi.c: new test for xmlDictExists() is generated.
+
+Wed Dec 1 22:35:37 HKT 2004 William Brack <wbrack@mmm.com.hk>
+
+ * dict.c, xpath.c, include/libxml/hash.h: fixed up some gcc warnings,
+ no change to logic. New macro XML_CAST_FPTR to circumvent gcc
+ warnings on function pointer <-> object pointer (a hack).
+
+Mon Nov 29 14:07:18 CET 2004 Daniel Veillard <daniel@veillard.com>
+
+ * xpath.c: fixed a memory leak on errors in some circumstances #159812
+
+Fri Nov 26 23:20:48 HKT 2004 William Brack <wbrack@mmm.com.hk>
+
+ * xmlIO.c: added a check within xmlOutputBufferWriteEscape to prevent
+ a dead loop on bad data (bug 159550)
+
+Fri Nov 26 13:09:04 CET 2004 Kasimier Buchcik <libxml2-cvs@cazic.net>
+
+ * xmlschemas.c: Fixed strict/lax element wildcards: the children
+ of elements for which a declaration existed were still processed
+ by the wildcard mechanism (reported by philippe ventrillon to the
+ mailing list).
+ Changed the import and include machanism to share dictionaries.
+
+Fri Nov 26 11:44:36 CET 2004 Daniel Veillard <daniel@veillard.com>
+
+ * HTMLparser.c parser.c: make sure xmlCtxtReadFile and htmlCtxtReadFile
+ go through the catalog resolution.
+ * gentest.py testapi.c: fix a side effect wrning of the change
+
+Wed Nov 24 13:41:52 CET 2004 Daniel Veillard <daniel@veillard.com>
+
+ * dict.c include/libxml/dict.h: added xmlDictExists() to the
+ dictionnary interface.
+ * xmlreader.c: applying xmlTextReaderHasAttributes fix for namespaces
+ from Rob Richards
+
+Wed Nov 17 13:54:37 CET 2004 Kasimier Buchcik <libxml2-cvs@cazic.net>
+
+ * xmlschemas.c: tiny enhancement for content model error reports (#157190, #143948).
+ Removed abbreviations: CT, ST and WC (#157190, reported by Frans Englich).
+ Initial: no report of local components.
+ * result/schemas/all* result/schemas/any3_0_0.err result/schemas/choice*
+ result/schemas/cos-st-restricts-1-2-err_0_0.err result/schemas/derivation-ok-extension-err_0_0.err
+ result/schemas/derivation-ok-extension_0_0.err result/schemas/derivation-ok-restriction-2-1-1_0_0.err
+ result/schemas/derivation-ok-restriction-4-1-err_0_0.err result/schemas/deter0_0_0.err
+ result/schemas/extension1_0_2.err result/schemas/facet-unionST-err1_0_0.err
+ result/schemas/hexbinary_0_1.err result/schemas/list* result/schemas/restriction-attr1_0_0.err
+ result/schemas/vdv-first4_0_1.err result/schemas/vdv-first4_0_2.err: Adapted output.
+
+Mon Nov 15 13:04:28 CET 2004 Kasimier Buchcik <libxml2-cvs@cazic.net>
+
+ * xmlschemas.c: Moved execution of xmlSchemaCheckDefaults to
+ xmlSchemaTypeFixup; this ensures facets of inherited types to be checked
+ prior to facets of derived types - which caused a seg fault otherwise
+ (bug #158216, reported by Frans Englich).
+
+Sun Nov 14 22:23:18 HKT 2004 William Brack <wbrack@mmm.com.hk>
+
+ * gentest.py, testapi.c: further enhancement, now all
+ compilation warnings have been fixed.
+ * xmlschemastypes.c: added NULL check for one function
+
+Fri Nov 12 23:58:14 HKT 2004 William Brack <wbrack@mmm.com.hk>
+
+ * xpath.c: trivial change (changed CHECK_CONTEXT to CHECK_CTXT
+ on a couple of lines)
+ * gentest.py, testapi.c: enhanced to reduce compilation warnings
+
+Fri Nov 12 16:12:48 CET 2004 Kasimier Buchcik <libxml2-cvs@cazic.net>
+
+ * xmlschemas.c: Un-commented a TODO in xmlSchemaParseElement.
+
+Fri Nov 12 14:55:36 CET 2004 Kasimier Buchcik <libxml2-cvs@cazic.net>
+
+ * xmlschemas.c: Correct symbol space for 'all' and 'choice'.
+ * xmlschemastypes.c include/xmlschemastypes.h: Added 'replace'
+ normalization for 'normalizedString'.
+ Added xmlSchemaWhiteSpaceReplace to the API.
+
+Thu Nov 11 21:43:02 CET 2004 Daniel Veillard <daniel@veillard.com>
+
+ * Makefile.am: forgot a $(srcdir)
+ * encoding.c: stupid error wrong name #157976
+
Wed Nov 10 15:35:25 CET 2004 Daniel Veillard <daniel@veillard.com>
* NEWS configure.in doc/*: preparing release of libxml2-2.6.16