summaryrefslogtreecommitdiff
path: root/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.in b/Makefile.in
index cace61f..c69a6fb 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -1334,7 +1334,7 @@ uninstall-man: uninstall-man1 uninstall-man3
#testOOM_DEPENDENCIES = $(DEPS)
#testOOM_LDADD= $(LDADDS)
-check-local: tests
+check-local: all tests
testall : tests SVGtests SAXtests
@@ -2122,7 +2122,7 @@ Relaxtests: xmllint$(EXEEXT)
RelaxNGPythonTests:
@(if [ -x $(PYTHON) ] ; then \
- PYTHONPATH=$(top_builddir)/python:$(top_builddir)/python/.libs ; \
+ PYTHONPATH=$(top_builddir)/python:$(top_builddir)/python/.libs:$$PYTHONPATH ; \
export PYTHONPATH; \
echo "## Relax-NG Python based test suite 1" ; \
$(CHECKER) $(PYTHON) $(srcdir)/check-relaxng-test-suite.py ; \
@@ -2132,7 +2132,7 @@ RelaxNGPythonTests:
SchemasPythonTests:
@(if [ -x $(PYTHON) ] ; then \
- PYTHONPATH=$(top_builddir)/python:$(top_builddir)/python/.libs; \
+ PYTHONPATH=$(top_builddir)/python:$(top_builddir)/python/.libs:$$PYTHONPATH; \
export PYTHONPATH; \
echo "## XML Schemas datatypes Python based test suite" ; \
$(CHECKER) $(PYTHON) $(srcdir)/check-xsddata-test-suite.py ; \