summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 0 insertions, 11 deletions
diff --git a/debian/rules b/debian/rules
index 7cf0966..66612bb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -19,17 +19,6 @@ ifeq (illumos-amd64,$(DEB_HOST_ARCH))
TARGETS += 32
endif
-# illumos libraries are linked via sunld which forces "base version"
-# for every unversioned symbol (GNU ld option --default-imported-symver).
-# GNU ld doesn't do it by default, this results in undefined symbols
-# in libraries using libxml2 (libpool, libbrand and others) e. g.:
-# debian/tmp/usr/lib/x86_64-illumos//libpool.so: undefined reference to
-# `__xmlLoadExtDtdDefaultValue@libxml2.so.2'. This option forces GNU ld create
-# and use a default symbol version (the soname) for unversioned exported symbols.
-ifeq (illumos,$(DEB_HOST_ARCH_OS))
-LDFLAGS += -Wl,--default-symver
-endif
-
WITH_UDEB := $(shell dpkg-vendor --derives-from Ubuntu && echo yes)
ifdef WITH_UDEB