summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog37
-rw-r--r--debian/control27
-rw-r--r--debian/lib32xml2-dev.install2
-rw-r--r--debian/lib32xml2.install1
-rwxr-xr-xdebian/rules16
5 files changed, 82 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index a2f9950..0f5cfa2 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -62,6 +62,43 @@ libxml2 (2.9.0+dfsg1-4) experimental; urgency=low
-- Aron Xu <aron@debian.org> Wed, 28 Nov 2012 22:34:15 +0800
+libxml2 (2.9.0+dfsg1-3+dyson5) unstable; urgency=low
+
+ * Rebuilt. For unknown reasons python module was not linked to libxml
+
+ -- Igor Pashev <pashev.igor@gmail.com> Sun, 24 Nov 2013 23:05:18 +0400
+
+libxml2 (2.9.0+dfsg1-3+dyson4) unstable; urgency=low
+
+ * Undo usage of -Wl,--default-symver on illumos: failed to link plist with
+ libplist which is linked to libxml2 (_etext was not at base version in
+ libxml2), similar to the issues with filter symbols in libpthread and
+ others.
+
+ -- Igor Pashev <pashev.igor@gmail.com> Wed, 28 Aug 2013 13:54:28 +0400
+
+libxml2 (2.9.0+dfsg1-3+dyson3) unstable; urgency=low
+
+ * Use -Wl,--default-symver on illumos per libraries
+ linked via sunld and expecting <foo>@libxml2.so.2
+ for unversioned symbols
+ * Build depends on lib32z1-dev [illumos-any]
+
+ -- Igor Pashev <pashev.igor@gmail.com> Sat, 10 Nov 2012 00:43:17 +0000
+
+libxml2 (2.9.0+dfsg1-3+dyson2) unstable; urgency=low
+
+ * Remove -V option from dh_shlibdeps:
+ it breaks lib32xml2 and we do not have such an old libxml.
+
+ -- Igor Pashev <pashev.igor@gmail.com> Tue, 30 Oct 2012 15:42:31 +0400
+
+libxml2 (2.9.0+dfsg1-3+dyson1) unstable; urgency=low
+
+ * Build 32-bit libxml2
+
+ -- Igor Pashev <pashev.igor@gmail.com> Mon, 29 Oct 2012 10:58:07 +0400
+
libxml2 (2.9.0+dfsg1-3) experimental; urgency=low
[ Aron Xu ]
diff --git a/debian/control b/debian/control
index 1220df1..8f0fb90 100644
--- a/debian/control
+++ b/debian/control
@@ -13,6 +13,33 @@ Vcs-Git: git://anonscm.debian.org/debian-xml-sgml/libxml2.git
Vcs-Browser: http://anonscm.debian.org/gitweb/?p=debian-xml-sgml/libxml2.git
XS-Testsuite: autopkgtest
+Package: lib32xml2
+Priority: optional
+Architecture: illumos-amd64
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: GNOME XML library (32-bit)
+ XML is a metalanguage to let you design your own markup language.
+ A regular markup language defines a way to describe information in
+ a certain class of documents (eg HTML). XML lets you define your
+ own customized markup languages for many classes of document. It
+ can do this because it's written in SGML, the international standard
+ metalanguage for markup languages.
+ .
+ This package provides a library providing an extensive API to handle
+ such XML data files.
+ .
+ This is 32-bit version of the library.
+
+Package: lib32xml2-dev
+Architecture: illumos-amd64
+Section: libdevel
+Depends: lib32xml2 (= ${binary:Version}), ${misc:Depends}, libxml2-dev (= ${binary:Version})
+Description: Development files for the GNOME XML library (32-bit)
+ This package contains files needed to develop 32-bit applications
+ using the libxml2 library.
+ .
+ The libxml2 library provides an extensive API to handle XML data files.
+
Package: libxml2
Priority: standard
Architecture: any
diff --git a/debian/lib32xml2-dev.install b/debian/lib32xml2-dev.install
new file mode 100644
index 0000000..87437ed
--- /dev/null
+++ b/debian/lib32xml2-dev.install
@@ -0,0 +1,2 @@
+usr/lib32/libxml2.so
+usr/lib32/libxml2.a
diff --git a/debian/lib32xml2.install b/debian/lib32xml2.install
new file mode 100644
index 0000000..159243c
--- /dev/null
+++ b/debian/lib32xml2.install
@@ -0,0 +1 @@
+usr/lib32/libxml2.so.*
diff --git a/debian/rules b/debian/rules
index 55b006d..9116dbd 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,6 +1,8 @@
#!/usr/bin/make -f
export DH_VERBOSE=1
+include /usr/share/dpkg/architecture.mk
+
# The versions of python currently supported
PYVERS=$(shell pyversions -s)
# The current default version of python
@@ -16,6 +18,9 @@ LDFLAGS = `dpkg-buildflags --get LDFLAGS` -Wl,--as-needed
CPPFLAGS = `dpkg-buildflags --get CPPFLAGS`
TARGETS := main $(PYVERS) $(PYVERS:%=%-dbg)
+ifeq (illumos-amd64,$(DEB_HOST_ARCH))
+TARGETS += 32
+endif
WITH_UDEB := $(shell dpkg-vendor --derives-from Ubuntu && echo yes)
@@ -47,6 +52,11 @@ doconfigure-python%: CONFIGURE_FLAGS += --with-python=/usr/bin/$*
#doconfigure-udeb: CONFIGURE_FLAGS += --without-history --with-minimum --with-tree --with-output
doconfigure-udeb: CONFIGURE_FLAGS += --without-history --with-tree --with-output --without-python
+# For dyson we need 32-bit library, but we don't have 32-bit liblzma
+doconfigure-32: CONFIGURE_FLAGS += --without-python --libdir=/usr/lib32 --without-lzma
+doconfigure-32: CC += -m32
+doconfigure-32: CACHE_FILE = /dev/null
+
override_dh_auto_build: $(TARGETS:%=dobuild-%)
dobuild-%: BUILD_DIR=builddir/$*
@@ -73,6 +83,10 @@ override_dh_auto_clean:
override_dh_auto_install: $(TARGETS:%=doinstall-%)
find debian/ -name *.la -delete
+doinstall-32:
+ $(MAKE) -C builddir/32 install-libLTLIBRARIES \
+ DESTDIR=$(CURDIR)/debian/tmp
+
doinstall-main:
dh_auto_install --builddirectory=builddir/main
mv debian/tmp/usr/share/aclocal/libxml.m4 debian/tmp/usr/share/aclocal/libxml2.m4
@@ -137,7 +151,7 @@ endif
dh_strip
override_dh_makeshlibs:
- dh_makeshlibs -a $(if $(WITH_UDEB),--add-udeb=libxml2-udeb )-V 'libxml2 (>= 2.7.4)' -- -c4
+ dh_makeshlibs -a $(if $(WITH_UDEB),--add-udeb=libxml2-udeb ) -- -c4
%:
ifeq ($(DEB_BUILD_PROFILE),stage1)