summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index e2d2fa6..adb3225 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -28,10 +28,19 @@ man_MANS = xmllint.1 xmlcatalog.1
all: web $(top_srcdir)/NEWS libxml2.xsa $(man_MANS)
-api: libxml2-api.xml libxml2-refs.xml $(APIPAGES) $(srcdir)/html/index.html $(WIN32_DIR)/libxml2.def.src
+api: libxml2-api.xml libxml2-refs.xml $(APIPAGES) $(srcdir)/html/index.html $(WIN32_DIR)/libxml2.def.src ../elfgcchack.h
web: $(PAGES)
+../elfgcchack.h: $(srcdir)/elfgcchack.xsl $(srcdir)/libxml2-api.xml
+ -@(if [ -x $(bindir)/xsltproc ] ; then \
+ echo "Rebuilding the elfgcchack.h header" ; \
+ $(bindir)/xsltproc --nonet $(srcdir)/elfgcchack.xsl $(srcdir)/libxml2-api.xml > elfgcchack.h ; \
+ if [ "`diff -q elfgcchack.h ../elfgcchack.h`" ] ; then \
+ echo "updating ../elfgcchack.h"; \
+ cp elfgcchack.h ../elfgcchack.h; \
+ fi ; rm -f elfgcchack.h ; fi );
+
$(PAGES): xml.html site.xsl
-@(if [ -x $(bindir)/xsltproc ] ; then \
echo "Rebuilding the HTML Web pages from xml.html" ; \