summaryrefslogtreecommitdiff
path: root/libxml2.spec
diff options
context:
space:
mode:
Diffstat (limited to 'libxml2.spec')
-rw-r--r--libxml2.spec59
1 files changed, 31 insertions, 28 deletions
diff --git a/libxml2.spec b/libxml2.spec
index a6d422d..f5648f8 100644
--- a/libxml2.spec
+++ b/libxml2.spec
@@ -1,6 +1,6 @@
Summary: Library providing XML and HTML support
Name: libxml2
-Version: 2.6.20
+Version: 2.6.21
Release: 1
License: MIT
Group: Development/Libraries
@@ -64,31 +64,34 @@ at parse time or later once the document has been modified.
# try to use compiler profiling, based on Arjan van de Ven <arjanv@redhat.com>
# initial test spec. This really doesn't work okay for most tests done.
#
-GCC_VERSION=`gcc --version | grep "^gcc" | awk '{ print $3 }' | sed 's+\([0-9]\)\.\([0-9]\)\..*+\1\2+'`
-if [ $GCC_VERSION -ge 34 ]
-then
- PROF_GEN='-fprofile-generate'
- PROF_USE='-fprofile-use'
-fi
-
-if [ "$PROF_GEN" != "" ]
-then
- # First generate a profiling version
- CFLAGS="${RPM_OPT_FLAGS} ${PROF_GEN}" %configure
- make
- # Run a few sampling
- make dba100000.xml
- ./xmllint --noout dba100000.xml
- ./xmllint --stream dba100000.xml
- ./xmllint --noout --valid test/valid/REC-xml-19980210.xml
- ./xmllint --stream --valid test/valid/REC-xml-19980210.xml
- # Then generate code based on profile
- CFLAGS="${RPM_OPT_FLAGS} ${PROF_USE}" %configure
- make
-else
- %configure
- make
-fi
+# Well except it's just broken most of the time.
+#GCC_VERSION=`gcc --version | grep "^gcc" | awk '{ print $3 }' | sed 's+\([0-9]\)\.\([0-9]\)\..*+\1\2+'`
+#if [ $GCC_VERSION -ge 34 ]
+#then
+# PROF_GEN='-fprofile-generate'
+# PROF_USE='-fprofile-use'
+#fi
+#
+#if [ "$PROF_GEN" != "" ]
+#then
+# # First generate a profiling version
+# CFLAGS="${RPM_OPT_FLAGS} ${PROF_GEN}" %configure
+# make
+# # Run a few sampling
+# make dba100000.xml
+# ./xmllint --noout dba100000.xml
+# ./xmllint --stream dba100000.xml
+# ./xmllint --noout --valid test/valid/REC-xml-19980210.xml
+# ./xmllint --stream --valid test/valid/REC-xml-19980210.xml
+# # Then generate code based on profile
+# CFLAGS="${RPM_OPT_FLAGS} ${PROF_USE}" %configure
+# make
+#else
+# %configure
+# make
+#fi
+%configure
+make
gzip -9 ChangeLog
%install
@@ -150,8 +153,8 @@ rm -fr %{buildroot}
%doc doc/python.html
%changelog
-* Mon Jul 11 2005 Daniel Veillard <veillard@redhat.com>
-- upstream release 2.6.20 see http://xmlsoft.org/news.html
+* Sun Sep 4 2005 Daniel Veillard <veillard@redhat.com>
+- upstream release 2.6.21 see http://xmlsoft.org/news.html
* Thu Jan 2 2003 Daniel Veillard <veillard@redhat.com>
- integrated drv_libxml2 xml.sax driver from Stéphane Bidoul