summaryrefslogtreecommitdiff
path: root/python/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'python/tests/Makefile.am')
-rw-r--r--python/tests/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/python/tests/Makefile.am b/python/tests/Makefile.am
index 1ae9b6c..f41cd6d 100644
--- a/python/tests/Makefile.am
+++ b/python/tests/Makefile.am
@@ -28,6 +28,7 @@ PYTESTS= \
reader6.py \
reader7.py \
reader8.py \
+ readernext.py \
walker.py \
ctxterror.py\
readererr.py\
@@ -37,7 +38,8 @@ PYTESTS= \
sync.py \
tstLastError.py \
indexes.py \
- dtdvalid.py
+ dtdvalid.py \
+ tstmem.py
XMLS= \
tst.xml \
@@ -52,6 +54,8 @@ tests: $(PYTESTS)
@echo "## running Python regression tests"
-@(PYTHONPATH="..:../.libs:$(srcdir)/..:$$PYTHONPATH" ; \
export PYTHONPATH; \
+ LD_LIBRARY_PATH="$(top_builddir)/.libs:$$LD_LIBRARY_PATH" ; \
+ export LD_LIBRARY_PATH; \
for test in $(PYTESTS) ; \
do log=`$(PYTHON) $(srcdir)/$$test` ; \
if [ "`echo $$log | grep OK`" = "" ] ; then \