summaryrefslogtreecommitdiff
path: root/debian/patches/lldb-libname.diff
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2016-12-29 13:40:27 +0300
committerIgor Pashev <pashev.igor@gmail.com>2016-12-29 13:40:27 +0300
commitdf36a469d77312f6dc0dccf08252542c16cf3308 (patch)
treec7089deec82cde1a5ac416aff1daadb097225ba3 /debian/patches/lldb-libname.diff
downloadllvm-toolchain-3.8-df36a469d77312f6dc0dccf08252542c16cf3308.tar.gz
llvm-toolchain-3.8 (1:3.8.1-16)debian/3.8.1-16
Diffstat (limited to 'debian/patches/lldb-libname.diff')
-rw-r--r--debian/patches/lldb-libname.diff13
1 files changed, 13 insertions, 0 deletions
diff --git a/debian/patches/lldb-libname.diff b/debian/patches/lldb-libname.diff
new file mode 100644
index 0000000..e0f84e3
--- /dev/null
+++ b/debian/patches/lldb-libname.diff
@@ -0,0 +1,13 @@
+Index: llvm-toolchain-snapshot_3.7~svn241915/lldb/lib/Makefile
+===================================================================
+--- llvm-toolchain-snapshot_3.7~svn241915.orig/lldb/lib/Makefile
++++ llvm-toolchain-snapshot_3.7~svn241915/lldb/lib/Makefile
+@@ -191,7 +191,7 @@ ifeq ($(HOST_OS), $(filter $(HOST_OS), L
+ LLVMLibsOptions += -Wl,--no-undefined
+ # Link in python
+ LLVMLibsOptions += $(PYTHON_BUILD_FLAGS) -lrt -ledit -lncurses -lpanel -lpthread
+- LLVMLibsOptions += -Wl,--soname,lib$(LIBRARYNAME)$(SHLIBEXT).$(SONAME_EXTENSION)
++ LLVMLibsOptions += -Wl,--soname,lib$(LIBRARYNAME)-$(LLVM_VERSION_MAJOR).$(LLVM_VERSION_MINOR)$(SHLIBEXT)
+ ifneq (,$(filter $(shell dpkg-architecture -qDEB_HOST_ARCH), mips mipsel powerpc powerpcspe))
+ # Link GCC atomic helper library
+ LLVMLibsOptions += -latomic