summaryrefslogtreecommitdiff
path: root/debian/patches/lldb/lldb-addversion-suffix-to-llvm-server-exec.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/lldb/lldb-addversion-suffix-to-llvm-server-exec.patch')
-rw-r--r--debian/patches/lldb/lldb-addversion-suffix-to-llvm-server-exec.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/debian/patches/lldb/lldb-addversion-suffix-to-llvm-server-exec.patch b/debian/patches/lldb/lldb-addversion-suffix-to-llvm-server-exec.patch
new file mode 100644
index 0000000..598deb5
--- /dev/null
+++ b/debian/patches/lldb/lldb-addversion-suffix-to-llvm-server-exec.patch
@@ -0,0 +1,34 @@
+lldb-server exec users always /usr/bin/lldb-server. Server is required
+for any debugging with lldb which makes it unusable unless default version
+package has been installed. Small changes to code and debian/rules allows
+a workaround for lldb-server start up.
+
+To use this one needs to add cmake definition during configure. eg
+-DDEBIAN_VERSION_SUFFIX=-$(LLVM_VERSION)
+
+Better implementation would be to use /usr/share/llvm-$(VERSION)/bin but
+that change seems to require a big change to the path handling code
+which could then break something else.
+
+This probably should have upstream bug but I couldn't find any existing report.
+
+Index: llvm-toolchain-snapshot_8~svn349668/lldb/source/Plugins/Process/gdb-remote/GDBRemoteCommunication.cpp
+===================================================================
+--- llvm-toolchain-snapshot_8~svn349668.orig/lldb/source/Plugins/Process/gdb-remote/GDBRemoteCommunication.cpp
++++ llvm-toolchain-snapshot_8~svn349668/lldb/source/Plugins/Process/gdb-remote/GDBRemoteCommunication.cpp
+@@ -33,13 +33,14 @@
+ #include "lldb/Utility/StreamString.h"
+ #include "llvm/ADT/SmallString.h"
+ #include "llvm/Support/ScopedPrinter.h"
++#include "llvm/Config/llvm-config.h"
+
+ #include "ProcessGDBRemoteLog.h"
+
+ #if defined(__APPLE__)
+ #define DEBUGSERVER_BASENAME "debugserver"
+ #else
+-#define DEBUGSERVER_BASENAME "lldb-server"
++# define DEBUGSERVER_BASENAME "lldb-server-" LLVM_VERSION_STRING
+ #endif
+
+ #if defined(__APPLE__)