summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 17 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e23ad14..845c510 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,11 +2,14 @@ dnl Process this file with autoconf to produce a configure script.
AC_INIT
AC_CONFIG_SRCDIR([update-menus/update-menus.cc])
-AM_INIT_AUTOMAKE(menu,2.1.45)
+AM_INIT_AUTOMAKE(menu,2.1.46.1)
AM_CONFIG_HEADER(config.h)
AM_MAINTAINER_MODE dnl Be nice with packagers, i.e. ourself
dnl Checks for programs.
+AC_PROG_CC
+gl_EARLY
AC_PROG_CXX
+AC_C_RESTRICT
AC_PROG_INSTALL
@@ -21,6 +24,8 @@ AC_CHECK_HEADERS(fcntl.h sys/file.h syslog.h unistd.h libintl.h)
dnl Checks for library functions.
AC_TYPE_SIGNAL
AC_CHECK_FUNCS(mkdir strdup strerror)
+AM_ICONV
+gl_INIT
dnl Available po files.
PO_PROGRAMS=`cd ${srcdir}/po; echo *.po`
@@ -37,6 +42,16 @@ AC_SUBST(PO_PROGRAMS)
AC_SUBST(PO_SECTIONS)
AC_SUBST(PO_SUTOROOT)
-AC_CONFIG_FILES([po-su-to-root/Makefile po/Makefile scripts/Makefile po-sections/Makefile doc/Makefile update-menus/Makefile install-menu/Makefile Makefile])
+AC_CONFIG_FILES([\
+ Makefile \
+ doc/Makefile \
+ install-menu/Makefile \
+ lib/Makefile \
+ po-sections/Makefile \
+ po-su-to-root/Makefile \
+ po/Makefile \
+ scripts/Makefile \
+ update-menus/Makefile \
+])
AC_OUTPUT