summaryrefslogtreecommitdiff
path: root/debian/changelog
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2014-02-02 12:06:00 +0400
committerIgor Pashev <pashev.igor@gmail.com>2014-02-02 12:06:00 +0400
commit909bf4011cb077cdd2c15c658143c29fe043a68a (patch)
treed8ab456667a719a54291bd2b1f95b6f09e265178 /debian/changelog
parent5006a9595c2948c3fe6c1e6019972d9cc013e80d (diff)
parent960975a175c2a21df749727162d5677cdc97a36e (diff)
downloadapt-909bf4011cb077cdd2c15c658143c29fe043a68a.tar.gz
Merge git://anonscm.debian.org/apt/apt
Conflicts: Makefile apt-inst/makefile apt-pkg/makefile buildlib/config.h.in buildlib/configure.mak buildlib/copy.mak buildlib/defaults.mak buildlib/library.mak buildlib/po4a_manpage.mak buildlib/podomain.mak cmdline/apt-get.cc cmdline/makefile configure.ac debian/apt.install.in debian/control debian/rules doc/makefile methods/makefile po/LINGUAS po/makefile test/interactive-helper/makefile test/libapt/makefile
Diffstat (limited to 'debian/changelog')
-rw-r--r--debian/changelog546
1 files changed, 544 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 5235bc79..00081452 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,534 @@
-apt (0.9.8.2) UNRELEASED; urgency=low
+apt (0.9.15) unstable; urgency=low
+
+ * upload version from debian/experimental to unstable
+
+ -- Michael Vogt <mvo@debian.org> Sat, 25 Jan 2014 21:57:00 +0100
+
+apt (0.9.14.3~exp5) experimental; urgency=medium
+
+ [ Anthony Towns ]
+ * methods/rred: minor robustness improvements
+
+ [ Michael Vogt ]
+ * make "apt-mark help" shows all commands
+ * make "apt show" output more user friendly
+ * add "apt full-upgrade" and tweak "apt upgrade"
+ * set APT::Sources::Use-Deb822=false until the format
+ is fully finalized
+
+ -- Michael Vogt <mvo@debian.org> Fri, 24 Jan 2014 23:21:04 +0100
+
+apt (0.9.14.3~exp4) experimental; urgency=medium
+
+ * implement deb822 suggestions by Anthony Towns and Julian Andres Klode:
+ - add Description tag for deb822 sources
+ - add support for Enabled: no in deb822 sources.list
+ - add support for multiple URIs in deb822 style sources.list
+ - add support for multipl types in one line
+ * add integration test for apt search and apt show
+ * do not ignore ioctl(TIOCSCTTY) errors
+
+ -- Michael Vogt <mvo@debian.org> Wed, 22 Jan 2014 18:59:07 +0100
+
+apt (0.9.14.3~exp3) experimental; urgency=low
+
+ * implement deb822 suggestions by donkult (thanks!):
+ - rename "Dist" to "Suites"
+ - rename "Section" to "Sections"
+ - rename "Architectures-Delete" to "Architectures-Remove"
+ - rename "Uri" to "URI"
+ * add "apt list --manual-installed"
+ * add "apt upgrade --dist"
+ * add "apt purge"
+ * flock() the file edited in "apt edit-sources"
+ * apt-private/private-show.cc:
+ - do not show Description-lang: header
+ * reword apt !isatty() warning
+ * add missing integration test for "apt list" and fix bugs
+ found by it
+
+ -- Michael Vogt <mvo@debian.org> Sat, 18 Jan 2014 21:09:24 +0100
+
+apt (0.9.14.3~exp2) experimental; urgency=medium
+
+ [ Julian Andres Klode ]
+ * debian/rules: Call dh_makeshlibs for 'apt'
+
+ [ Anthony Towns ]
+ * reimplement rred to allow applying all the diffs in a single pass
+ * correct IndexDiff vs DiffIndex in Debug output
+
+ [ David Kalnischkies ]
+ * reenable unlimited pdiff files download
+ * integrate Anthonys rred with POC for client-side merge
+
+ [ Michael Vogt ]
+ * document deb822 style sources.list in sources.list(5)
+ * rename "Dist:" in deb822 style sources.list to "Suite:"
+ * rename URL to Uri in deb822-sources
+ * support multiple "Suite:" entries in deb822 style sources.list:
+ "Suite: stable testing unstable"
+
+ -- Michael Vogt <mvo@debian.org> Thu, 16 Jan 2014 21:43:22 +0100
+
+apt (0.9.14.3~exp1) experimental; urgency=low
+
+ [ Michael Vogt ]
+ * add support for "deb822" style sources.list format and add
+ APT::Sources::Use-Deb822 to support disabling it
+
+ [ David Kalnischkies ]
+ * implement POC client-side merging of pdiffs via apt-file
+
+ [ Trần Ngọc Quân ]
+ * l10n: vi.po(617t): Update Vietnamese translation
+
+ -- Michael Vogt <mvo@debian.org> Sun, 05 Jan 2014 15:13:32 +0100
+
+apt (0.9.14.2) unstable; urgency=low
+
+ [ Joe Hansen ]
+ * Danish translation update. Closes: #732166
+
+ [ Peter Green ]
+ * add apt-vendor for raspbian. Closes: #732749
+
+ [ Thomas Bechtold ]
+ * apt-pkg/contrib/gpgv.cc: use /tmp as fallback dir if the
+ directory from $TMPDIR is not available (closes: #728500)
+
+ [ Michael Vogt ]
+ * vendor/getinfo:
+ - fix ubuntu-codename
+ * vendor/steamos/*:
+ - add steamos support
+ * bugfix/bts731738-fancy-progess:
+ - fix terminal size issues with e.g. "less" when "APT::Progress-Fancy=1"
+ is used (closes: #731738)
+ * feature/policy-parser-bts732746:
+ - allow more flexibility in /etc/apt/preferences, e.g. comment only
+ sections (closes: #732746)
+ * move TMPDIR handling into GetTempDir() and use that instead of
+ getenv("TMPDIR")
+ * update apt-key net-update and add integration test with the buildin
+ apt webserver
+ * run autopkgtest against the installed apt
+
+ -- Michael Vogt <mvo@debian.org> Sun, 29 Dec 2013 16:41:16 +0100
+
+apt (0.9.14.1) unstable; urgency=medium
+
+ * fix apt-get source -t dist regression (closes: #731853)
+ and add testcase
+ * clarify error message when apt-get source=ver fails
+ (thans to David Kalnischkies)
+ * Fix conffile prompt regression (LP: #1260297)
+ and add testcase
+ * improve error message for apt-get source pkg:arch{=ver,/release}
+
+ -- Michael Vogt <mvo@debian.org> Thu, 12 Dec 2013 18:34:29 +0100
+
+apt (0.9.14) unstable; urgency=low
+
+ [ David Kalnischkies ]
+ * merge ubuntus apport reporting changes to reduce diff
+ * enable NOISE for build logs to enable analyse
+ * introduce a vendor system to change sources.list
+ * add a vendor specific file to have configurable entities
+ * use a substvar to set the archive-keyring in debian/control
+ * cherry-pick ubuntus (disabled) net-update fixes
+ * generate apt-key script with vendor info about keys
+ * drop old /var/state to /var/lib transition artefacts
+
+ [ Steve Langasek ]
+ * prepare-release: declare the packages needed as source build deps.
+
+ [ Michael Vogt ]
+ * enable release based selection for deb-src (closes: 731102)
+ * document Dpkg::Progress-Fancy (closes: 726169), thanks to James McCoy
+ * vendor/makefile: fix build error for parallel builds
+ * Handle SIGWINCH in APT::Progress-Fancy=1
+
+ -- Michael Vogt <mvo@debian.org> Sat, 07 Dec 2013 14:54:31 +0100
+
+apt (0.9.13.1) unstable; urgency=low
+
+ [ Colin Watson ]
+ * fix "apt-get --purge build-dep" (closes: #720597)
+ * fix regression that APT::Keep-Fds is not honored (closes: #730490)
+
+ [ Michael Vogt ]
+ * add "-f" option to "build-dep" as sbuild is using it to fix
+ regression with cross-building (LP: #1255806)
+ * add autopkgtest support for the integration testsuite
+ * merge mvo/feature/short-list
+ * merge mvo/feature/edit-sources
+ * fix segfault in pkgDepCache::SetCandidateRelease() (closes: #709560)
+ * reset terminal on error (closes: #730795)
+ * fix apport report writing (LP: #1254499)
+
+ -- Michael Vogt <mvo@debian.org> Fri, 29 Nov 2013 20:50:17 +0100
+
+apt (0.9.13) unstable; urgency=low
+
+ [ TJ Guthrie ]
+ * Changed MinAgeSec to MinAge in /etc/cron.daily/apt:200,204
+ LP: #1206047
+
+ -- Michael Vogt <mvo@debian.org> Sun, 24 Nov 2013 10:56:22 +0100
+
+apt (0.9.13~exp1) experimental; urgency=low
+
+ * Improve the API for APT::Upgrade::Upgrade()
+ * Re-add "Calculating upgrade..." message
+ * move upgrade releated code into upgrade.{cc,h}
+ * Move ListUpdate/AquireUpdate into update.{cc,h}
+ * Add new apt-pkg/install-progress.h with APT::Progress::PackageManager
+ progress reporting classes
+ * Move the status-fd progress reporting out of the pkgDPkgPM class
+ and into PackageManagerProgressFd
+ * Fix reading dpkg --status-fd on reinstalls
+ * Add new APT::Status-deb822-Fd progress output
+ * add Acquire::http::Proxy-Auto-Detect to the apt.conf.5 manpage
+ (closes: 726597)
+ * Fix detection when multiarch packages are reported by dpkg as
+ disappeared Packages
+ * test/integration/run-tests: output the failed test names
+ * Code Cleanup in pkgDPkgPM
+ * prepare next ABI via #if (APT_PKG_MAJOR >= 4 && APT_PKG_MINOR >= 13)
+ * add new pid_t ExecFork(std::set<int> KeepFDs)
+ * Avoid flickering when "apt-get -o DpkgPM::Progress-Fancy=1" is use
+ * use sysconf(_SC_OPEN_MAX) in ExecFork()
+
+ -- Michael Vogt <mvo@debian.org> Fri, 01 Nov 2013 10:03:06 +0100
+
+apt (0.9.12.1) unstable; urgency=low
+
+ [ Michael Vogt ]
+ * do not send pkgname:arch over the APT::Status-Fd to not break
+ clients (closes: 726156). A new APT::Status-deb822-Fd will be
+ used to fix this.
+ * add integration tests for APT::Status-Fd
+ * add missing _() around the new "Progress" string
+
+ [ David Kalnischkies ]
+ * fix progress-segfault in case of dpkg errors/prompts (Closes: 726047)
+
+ -- Michael Vogt <mvo@debian.org> Tue, 15 Oct 2013 18:25:51 +0200
+
+apt (0.9.12) unstable; urgency=low
+
+ [ Christian Perrier ]
+ * Fix typo in apt-private/private-show.cc. Thanks to Benjamin
+ Keresa. Closes: #724073
+
+ [ Mark Hymers ]
+ * fix libapt-inst for >2G debs (closes: #725483)
+
+ [ David Kalnischkies ]
+ * don't strip :any from dependencies in single-arch (Closes: 723586)
+ * pkg from only trusted sources keeps being trusted (Closes: 617690)
+ * compression-neutral message for missing data.tar member (Closes: 722710)
+ * print-uris prints regardless of quiet-level again (Closes: 722207)
+ * retry without partial data after a 416 response (Closes: 710924)
+ * replace "filesize - 1" trick in http with proper 416 handling
+ * fix partial (206 and 416) support in https
+ * handle complete responses to https range requests (Closes: 617643, 667699)
+ (LP: 1157943)
+ * don't consider holds for autoremoval (Closes: 724995)
+ * put fetch errors in 'source' on our errorstack
+ * use pkgAcqArchive in 'download' for proper errors
+ * fix lzma-support detection via xz binary
+ * do not ++ on erased package pointers in autoremove
+
+ [ Michael Vogt ]
+ * Add new "apt-get upgrade --with-new-pkgs" option (and add man-page for it).
+ So "apt-get upgrade --with-new-pkgs" will pull in new dependencies but
+ never remove packages
+ * Rename "--dpkg-progress" to "--show-progress" and document it in
+ apt-get.8. This will show global install progress information in the
+ terminal.
+ * Fix status-fd progress calculation for certain multi-arch install/upgrade
+ situations
+ * add new -o DpkgPM::Progress-Fancy for nicer dpkg progress output
+ on vt100+ terminals
+ * fix libapt-inst for >2G debs (closes: #725483), thanks to Mark Hymers
+ * debian/apt.postinst: use --compare-versions lt instead of lt-nl,
+ to ensure the apt-auto-removal file is correctly create,
+ thanks to Ben Hutchings
+ * update Uploaders to match recent uploaders better
+ * Set the default "Acquire::PDiffs::FileLimit" to 20. If the amount
+ of pdiffs is bigger things tend to get slower. Set
+ Acquire::PDiffs::FileLimit "0";
+ in /etc/apt/apt.conf to get the old behavior back.
+
+ -- Michael Vogt <mvo@debian.org> Wed, 09 Oct 2013 22:39:41 +0200
+
+apt (0.9.11.4) unstable; urgency=low
+
+ [ Oskari Saarenmaa ]
+ * don't truncate 100 char long paths in tar extraction.
+ Thanks to Mika Eloranta for the testcase! (Closes: #689582)
+
+ [ David Kalnischkies ]
+ * do not trust FileFd::Eof() in pkgTagFile::Fill()
+ Thanks to Cyril Brulebois (Closes: 723705)
+
+ -- Michael Vogt <mvo@debian.org> Fri, 20 Sep 2013 16:12:07 +0200
+
+apt (0.9.11.3) unstable; urgency=low
+
+ [ Michael Vogt ]
+ * Add DPkgPM::Progress option to enable terminal install
+ progress
+ * fix typo (mkostemp->mkstemp)
+ * Remove invalid "-f" option for apt-get check, thanks to
+ Philipp Weis (closes: #721477)
+ * Fix regression of "apt-cache unmet -i", thanks to Daniel Schepler
+ (closes: #722324)
+
+ [ David Kalnischkies ]
+ * use FileFd in HashSum test to unbreak non-linux ports.
+ Thanks to Aaron M. Ucko (Closes: 721723)
+
+ -- Michael Vogt <mvo@debian.org> Tue, 10 Sep 2013 17:32:02 +0200
+
+apt (0.9.11.2) unstable; urgency=low
+
+ [ Milo Casagrande ]
+ * Update Italian translation. Closes: #721030
+
+ [ Trần Ngọc Quân ]
+ * Update Vietnamese translation. Closes: #720752
+
+ [ Michael Vogt ]
+ * dselect/install:
+ - remove "-f" option for apt-get clean/auto-clean (closes: #720532)
+ * apt-private/private-cmndline.cc:
+ - fix typo in CmdMatches() selection for dselect-upgrade (closes: #720532)
+ * use SPtr<pkgProblemResolver> in DoInstall() to simplify the code
+ * allow pkg manipulation in the upgrade/dist-upgrade commandline, like
+ apt-get dist-upgrade 2vcard- 4g8+ (thanks to Thorsten Glaser for the
+ suggestion)
+
+ [ Angel Guzman Maeso ]
+ * replace usage of potential dangerous mktemp with mkstemp
+
+ -- Michael Vogt <mvo@debian.org> Sat, 31 Aug 2013 16:45:31 +0200
+
+apt (0.9.11.1) unstable; urgency=low
+
+ [ Michael Vogt ]
+ * more coverity fixes:
+ - explicit init
+ - always chdir("/") after chroot()
+ - ftparchive/override.cc: fix "skip empty lines" code, the pointer
+ needs to get de-referenced first
+ * dselect/update:
+ - remove "-f" option for apt-get update to fix breakage (closes: 720532)
+
+ [ Christopher Baines ]
+ * Add test for bug #507998
+
+ [ David Kalnischkies ]
+ * add a breaks libapt-inst for FileFd changes in 0.9.9 (Closes: 720449)
+ * add versions to manpages-it Replaces+Breaks
+
+ [ Ángel Guzmán Maeso ]
+ * apt-pkg:contrib Avoid compiler warning about sign-compare
+
+ -- Michael Vogt <mvo@debian.org> Sat, 24 Aug 2013 09:13:27 +0200
+
+apt (0.9.11) unstable; urgency=low
+
+ [ Daniel Hartwig ]
+ * Clarify units of Acquire::http::Dl-Limit (closes: #705445)
+ * Show a error message if {,dist-}upgrade is used with additional
+ arguments (closes: #705510)
+
+ [ Michael Vogt ]
+ * lp:~mvo/apt/config-clear:
+ - support Configuration.Clear() for a clear of the entire
+ configuration
+ * lp:~mvo/apt/add-glob-function:
+ - add Glob() to fileutl.{cc,h}
+ * feature/apt-binary2
+ - refactor large chunks of cmdline/*.cc into a new libapt-private
+ library that is shared between the internal apt cmdline tools
+ - install libapt-private* into the apt binary
+ - add PACKAGE_MATCHER_ABI_COMPAT define so that this branch can be
+ merged without breaking ABI
+ - add lintian override for no-shlibs-control-file so that
+ the internal libapt-private.so.0.0.0 can be shipped
+ - adjust apt.install.in to only install libapt-private.so.*
+
+ [ David Kalnischkies ]
+ * ensure that pkgTagFile isn't writing past Buffer length (Closes: 719629)
+ * allow Pre-Install-Pkgs hooks to get info over an FD != stdin
+ (Closes: #671726)
+
+ [ Christian PERRIER ]
+ * French translation update.
+
+ -- Michael Vogt <mvo@debian.org> Wed, 21 Aug 2013 17:51:09 +0200
+
+apt (0.9.10) unstable; urgency=low
+
+ The "Hello to Debconf" upload
+
+ [ Christian Perrier ]
+ * Vietnamese translation update. Closes: #718615
+ * Japanese translation update. Closes: #719279
+ * French translation update.
+
+ [ Michael Vogt ]
+ * work on fixing coverity scan results:
+ - fix some off-by-one errors
+ - fix some resource leaks
+ - fixes in chroot() handling
+ - fix some missing va_end()
+ * make the code -Wall clean again
+ * remove duplicated #include<list>
+ * add .travis.yml
+ * use the 'abi-complicance-checker' package and remove the buildin
+ copy for the abi checks
+
+ [ David Kalnischkies ]
+ * ensure that FileFd::Size returns 0 in error cases
+ * add missing Turkish (tr) to po/LINGUAS
+ * correct management-typo in description found by lintian
+ * implement debian/rules build-{arch,indep} as required by policy 3.9.4
+ * reenable automatic parallel build of APT
+ * exclude config.{sub,guess} from source package
+ * update the symbol files to reflect current state
+ * unset LANGUAGE for showing [Y/n] answer hints
+ * fix some unitialized data members
+ * specific pins below 1000 cause downgrades (Closes: 543966)
+ * use pkgTagFile to parse "header" of Release files
+ * fix: --print-uris removes authentication (Closes: 719263)
+ * always use our own trustdb.gpg in apt-key
+ * use a tmpfile for trustdb.gpg in apt-key.
+ Thanks to Andreas Beckmann for the initial patch! (Closes: #687611)
+ * do not double-slash paths in apt-key (Closes: 665411)
+ * make the keyring locations in apt-key configurable
+ * let apt-key del work better with softlink and single key keyrings
+ * do not call 'apt-key update' in apt.postinst
+
+ [ Colin Watson ]
+ * prefer native arch over higher priority for providers (Closes: #718482)
+
+ -- Michael Vogt <mvo@debian.org> Mon, 12 Aug 2013 21:45:07 +0200
+
+apt (0.9.9.4) unstable; urgency=low
+
+ [ David Kalnischkies ]
+ * pick up Translation-* even if only compressed available (Closes: 717665)
+ * request absolute URIs from proxies again (0.9.9.3 regession)
+ (Closes: 717891)
+
+ [ Michael vogt ]
+ * fix missing changelog entry for 0.9.9.3 (git-dch issue)
+
+ -- Michael Vogt <mvo@debian.org> Fri, 26 Jul 2013 09:58:17 +0200
+
+apt (0.9.9.3) unstable; urgency=low
+
+ [ Ben Hutchings ]
+ * debian/apt.auto-removal.sh:
+ - do not include debug symbol packages for the kernel in the
+ blacklist (closes: #717616)
+
+ [ Michael Vogt ]
+ * debian/apt.postinst:
+ - run /etc/kernel/postinst.d/apt-auto-removal once on upgrade
+ to ensure that the correct auto-removal list is generated
+ (closes: #717615)
+
+ [ David Kalnischkies ]
+ * skip all Description fields in apt-cache, not just first (Closes: 717254)
+ * fix 'apt-cache search' crash with missing description (Closes: 647590)
+
+ [ Raphael Geissert ]
+ * Do not send a connection: keep-alive, at all
+
+ -- Michael Vogt <mvo@debian.org> Thu, 25 Jul 2013 17:14:58 +0200
+
+apt (0.9.9.2) unstable; urgency=low
+
+ [ Programs translations ]
+ * Vietnamese updated by Tran Ngoc Quan. Closes: #717016
+
+ [ David Kalnischkies ]
+ * fix if-clause to generate hook-info for 'rc' packages (Closes: 717006)
+
+ -- Michael Vogt <mvo@debian.org> Wed, 17 Jul 2013 14:56:34 +0200
+
+apt (0.9.9.1) unstable; urgency=low
+
+ [ Michael Vogt ]
+ * debian/rules:
+ - call dh_clean in clean (closes: #714980)
+ * apt-pkg/packagemanager.cc:
+ - increate APT::pkgPackageManager::MaxLoopCount to 5000
+ * cherry pick debian/apt.auto-removal.sh feature from the
+ ubuntu/master branch
+
+ [ Steve Langasek ]
+ * debian/apt.conf.autoremove: don't include linux-image*,
+ linux-restricted-modules*, and linux-ubuntu-modules* packages in the
+ list to never be autoremoved.
+ * debian/apt.auto-removal.sh, debian/rules, debian/apt.dirs: install new
+ script to /etc/kernel/postinst.d/ which ensures we only automatically
+ keep the currently-running kernel, the being-installed kernel, and the
+ newest kernel, so we don't fill /boot up with an unlimited number of
+ kernels. LP: #923876.
+
+ [ Adam Conrad ]
+ * Fix up two things in debian/apt.auto-removal.sh:
+ - Use exact matches with $-terminated regexes, so we don't get
+ confusion between similarly-named kernel flavours.
+ - Keep linux-backports-modules in sync with installed kernels.
+
+ [ David Kalnischkies ]
+ * Version 3 for DPkg::Pre-Install-Pkgs with MultiArch info (Closes: #712116)
+ * implement arch+= and arch-= for sources.list
+ * prevent MarkInstall of unsynced Multi-Arch:same siblings
+
+ -- Michael Vogt <mvo@debian.org> Thu, 11 Jul 2013 20:44:31 +0200
+
+apt (0.9.9) unstable; urgency=low
+
+ [ Michael Vogt ]
+ * improve debug output for the Debug::pkgProblemResolver and
+ Debug::pkgDepCache::AutoInstall
+ * improve apt-cdrom output when no CD-ROM can be auto-detected
+ * document --no-auto-detect in apt-cdrom
+
+ [ David Kalnischkies ]
+ * build the en manpages in subdirectory doc/en
+ * remove -ldl from cdrom and -lutil from apt-get linkage
+ * rewrite pkgOrderList::DepRemove to stop incorrect immediate setting
+ (Closes: 645713)
+ * prefer Essentials over Removals in ordering score
+ * fix priority sorting by prefering higher in MarkInstall
+ * try all providers in order if uninstallable in MarkInstall
+ * do unpacks before configures in SmartConfigure (Closes: #707578)
+ * fix support for multiple patterns in apt-cache search (Closes: #691453)
+ * set Fail flag in FileFd on all errors consistently
+ * don't explicitly init ExtractTar InFd with invalid fd
+ * OpenDescriptor should autoclose fd always on error (Closes: #704608)
+ * fail in CopyFile if the FileFds have error flag set
+ * ensure state-dir exists before coyping cdrom files
+ * fix file location for configure-index.gz in apt.conf(5) (Closes: #711921)
+ * handle missing "Description" in apt-cache show (Closes: #712435)
+ * try defaults if auto-detection failed in apt-cdrom (Closes: #712433)
+ * support \n and \r\n line endings in ReadMessages
+ * do not redownload unchanged InRelease files
+ * trigger NODATA error for invalid InRelease files (Closes: #712486)
+
+ -- Michael Vogt <mvo@debian.org> Tue, 02 Jul 2013 08:58:33 +0200
+
+apt (0.9.8.2) unstable; urgency=low
[ Programs translations ]
* French translation : typo fix. Closes: #677272
@@ -9,8 +539,20 @@ apt (0.9.8.2) UNRELEASED; urgency=low
[ Michael Vogt ]
* buildlib/apti18n.h.in:
- fix build failure when building without NLS (closes: #671587)
+
+ [ Gregoire Menuel ]
+ * Fix double free (closes: #711045)
+
+ [ Raphael Geissert ]
+ * Fix crash when the "mirror" method does not find any entry
+ (closes: #699303)
+
+ [ Johan Kiviniemi ]
+ * cmdline/apt-key:
+ - Create new keyrings with mode 0644 instead of 0600.
+ - Accept a nonexistent --keyring file with the adv subcommand as well.
- -- Christian Perrier <bubulle@debian.org> Thu, 16 May 2013 22:28:22 +0200
+ -- Michael Vogt <mvo@debian.org> Thu, 06 Jun 2013 19:15:14 +0200
apt (0.9.8.1) unstable; urgency=low