From 87ddfb96f760c0e14f205667c9d580b4b274cc5c Mon Sep 17 00:00:00 2001
From: Michael Vogt <michael.vogt@ubuntu.com>
Date: Tue, 15 Mar 2005 16:30:24 +0000
Subject: * run check_size_constraints independent of AUTOCLEAN (thanks Matt)

---
 debian/apt.cron.daily | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

(limited to 'debian')

diff --git a/debian/apt.cron.daily b/debian/apt.cron.daily
index f3a1c736..466028ee 100644
--- a/debian/apt.cron.daily
+++ b/debian/apt.cron.daily
@@ -80,6 +80,10 @@ check_size_constraints()
     fi
 }
 
+
+# check cache size first
+check_size_constraints
+
 UpdateInterval=0
 DownloadUpgradeableInterval=0
 eval $(apt-config shell UpdateInterval APT::Periodic::Update-Package-Lists DownloadUpgradeableInterval APT::Periodic::Download-Upgradeable-Packages)
@@ -117,6 +121,5 @@ fi
 AUTOCLEAN_STAMP=/var/lib/apt/periodic/autoclean-stamp
 if check_stamp $AUTOCLEAN_STAMP $AutocleanInterval; then
     apt-get -qq autoclean
-    check_size_constraints
     update_stamp $AUTOCLEAN_STAMP
 fi
-- 
cgit v1.2.3


From 47536509f365de8a8670406a98e6708e1bdefdf7 Mon Sep 17 00:00:00 2001
From: Michael Vogt <michael.vogt@ubuntu.com>
Date: Tue, 15 Mar 2005 16:48:57 +0000
Subject: * check cache size after AUTOCLEAN was run (but independent)

---
 debian/apt.cron.daily | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

(limited to 'debian')

diff --git a/debian/apt.cron.daily b/debian/apt.cron.daily
index 466028ee..5b1c51ef 100644
--- a/debian/apt.cron.daily
+++ b/debian/apt.cron.daily
@@ -81,9 +81,6 @@ check_size_constraints()
 }
 
 
-# check cache size first
-check_size_constraints
-
 UpdateInterval=0
 DownloadUpgradeableInterval=0
 eval $(apt-config shell UpdateInterval APT::Periodic::Update-Package-Lists DownloadUpgradeableInterval APT::Periodic::Download-Upgradeable-Packages)
@@ -123,3 +120,6 @@ if check_stamp $AUTOCLEAN_STAMP $AutocleanInterval; then
     apt-get -qq autoclean
     update_stamp $AUTOCLEAN_STAMP
 fi
+
+# check cache size 
+check_size_constraints
-- 
cgit v1.2.3


From 8a139d4dbda22b1e4ad3e99b1267b1085293add6 Mon Sep 17 00:00:00 2001
From: Michael Vogt <michael.vogt@ubuntu.com>
Date: Tue, 22 Mar 2005 17:03:17 +0000
Subject: * MinAge implemented, cron script variables documented, bugfix in
 check_stamp() function

---
 debian/apt.cron.daily | 57 ++++++++++++++++++++++++++++++++++++++++++++++++++-
 1 file changed, 56 insertions(+), 1 deletion(-)

(limited to 'debian')

diff --git a/debian/apt.cron.daily b/debian/apt.cron.daily
index 5b1c51ef..7ee7e46d 100644
--- a/debian/apt.cron.daily
+++ b/debian/apt.cron.daily
@@ -2,6 +2,33 @@
 #
 
 #set -e
+#
+# This file understands the following apt configuration variables:
+#
+#  "APT::Periodic::Update-Package-Lists=1"
+#  - Do "apt-get update" automatically every n-days (0=disable)
+#    
+#  "APT::Periodic::Download-Upgradeable-Packages=0",
+#  - Do "apt-get upgrade --download-only" every n-days (0=disable)
+# 
+#  "APT::Periodic::AutocleanInterval"
+#  - Do "apt-get autoclean" every n-days (0=disable)
+#
+#  "APT::Archives::MaxAge",
+#  - Set maximum allowed age of a cache package file. If a cache 
+#    package file is older it is deleted (0=disable)
+#
+#  "APT::Archives::MaxSize",
+#  - Set maximum size of the cache in MB (0=disable). If the cache
+#    is bigger, cached package files are deleted until the size
+#    requirement is met (the biggest packages will be deleted 
+#    first).
+#
+#  "APT::Archives::MinAge"
+#  - Set minimum age of a package file. If a file is younger it
+#    will not be deleted (0=disable). Usefull to prevent races 
+#    and to keep backups of the packages for emergency.
+# 
 
 check_stamp()
 {
@@ -21,6 +48,11 @@ check_stamp()
     now=$(date --date=$(date --iso-8601) +%s)
     delta=$(($now-$stamp))
 
+    # intervall is in days,
+    interval=$(($interval*60*60*24))
+    #echo "stampfile: $1"
+    #echo "interval=$interval, now=$now, stamp=$stamp, delta=$delta"
+
     if [ $delta -ge $interval ]; then
         return 0
     fi
@@ -42,10 +74,12 @@ check_size_constraints()
 {
     # min-age in days
     MaxAge=0
+    MinAge=1
     MaxSize=0
     CacheDir="var/cache/apt"
     CacheArchive="archives/"
     eval $(apt-config shell MaxAge APT::Archives::MaxAge)
+    eval $(apt-config shell MinAge APT::Archives::MinAge)
     eval $(apt-config shell MaxSize APT::Archives::MaxSize)
     eval $(apt-config shell Dir Dir)
     eval $(apt-config shell CacheDir Dir::Cache)
@@ -60,12 +94,21 @@ check_size_constraints()
     Cache="${Dir%/}/${CacheDir%/}/${CacheArchive%/}/"
 
     # check age
-    if [ ! $MaxAge -eq 0 ]; then
+    if [ ! $MaxAge -eq 0 ] && [ ! $MinAge -eq 0 ]; then
+	find $Cache -name "*.deb"  -mtime +$MaxAge -and -not -mtime -$MinAge -print0 | xargs -r -0 rm -f
+    elif [ ! $MaxAge -eq 0 ]; then
 	find $Cache -name "*.deb"  -mtime +$MaxAge -print0 | xargs -r -0 rm -f
     fi
     
     # check size
     if [ ! $MaxSize -eq 0 ]; then
+	# maxSize is in MB
+	MaxSize=$(($MaxSize*1024))
+
+	#get current time
+	now=$(date --date=$(date --iso-8601) +%s)
+	MinAge=$(($MinAge*24*60*60))
+
 	# reverse-sort by mtime
 	for file in $(ls -rt $Cache/*.deb); do 
 	    du=$(du -s $Cache)
@@ -74,6 +117,18 @@ check_size_constraints()
 	    if [ $size -lt $MaxSize ]; then
 		break
 	    fi
+
+	    # check for MinAge of the file
+	    if [ ! $MinAge -eq 0 ]; then 
+		mtime=$(date --date=$(date -r $file --iso-8601) +%s)
+		delta=$(($now-$mtime))
+		#echo "$file ($delta), $MinAge"
+		if [ $delta -le $MinAge ]; then
+		    #echo "Skiping $file (delta=$delta)"
+		    continue
+		fi
+	    fi
+
 	    # delete oldest file
 	    rm -f $file
 	done
-- 
cgit v1.2.3


From 1df60952e243b794fd94cb1e2476fd9e19d230a0 Mon Sep 17 00:00:00 2001
From: Matt Zimmerman <matt.zimmerman@canonical.com>
Date: Sat, 26 Mar 2005 16:33:41 +0000
Subject: Open 0.6.36

---
 debian/changelog | 6 ++++++
 1 file changed, 6 insertions(+)

(limited to 'debian')

diff --git a/debian/changelog b/debian/changelog
index 2b093b0d..6f479648 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+apt (0.6.36) hoary; urgency=low
+
+  * 
+
+ -- Matt Zimmerman <mdz@ubuntu.com>  Sat, 26 Mar 2005 08:27:23 -0800
+
 apt (0.6.35) hoary; urgency=low
 
   * Merge apt--mvo--0:
-- 
cgit v1.2.3


From d73e594e888fbc099bba84726df72eedcee5272c Mon Sep 17 00:00:00 2001
From: Matt Zimmerman <matt.zimmerman@canonical.com>
Date: Sat, 26 Mar 2005 17:49:11 +0000
Subject: Update changelog

---
 debian/changelog | 12 +++++-------
 1 file changed, 5 insertions(+), 7 deletions(-)

(limited to 'debian')

diff --git a/debian/changelog b/debian/changelog
index 6f479648..f20dcc31 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,14 +1,12 @@
-apt (0.6.36) hoary; urgency=low
-
-  * 
-
- -- Matt Zimmerman <mdz@ubuntu.com>  Sat, 26 Mar 2005 08:27:23 -0800
-
 apt (0.6.35) hoary; urgency=low
 
-  * Merge apt--mvo--0:
+  * Merge apt--mvo--0 (incorporates 0.6.34ubuntu1):
     - Implement MaxSize and MaxAge in apt.cron.daily, to prevent the cache
       from growing too large (Ubuntu #6761)
+    * some comments about the pkgAcqMetaSig::Custom600Headers() added
+    * use gpg --with-colons
+    * commented the ftp no_proxy unseting in methods/ftp.cc
+    * added support for "Acquire::gpgv::options" in methods/gpgv.cc
 
  -- Matt Zimmerman <mdz@ubuntu.com>  Mon,  7 Mar 2005 20:08:33 -0800
 
-- 
cgit v1.2.3


From 0edc7fba37048fa7c9833d664c4231ee9ad2be40 Mon Sep 17 00:00:00 2001
From: Matt Zimmerman <matt.zimmerman@canonical.com>
Date: Sat, 26 Mar 2005 17:51:31 +0000
Subject: Update changelog

---
 debian/changelog | 12 ++++++++----
 1 file changed, 8 insertions(+), 4 deletions(-)

(limited to 'debian')

diff --git a/debian/changelog b/debian/changelog
index f20dcc31..1820b2cb 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -3,10 +3,14 @@ apt (0.6.35) hoary; urgency=low
   * Merge apt--mvo--0 (incorporates 0.6.34ubuntu1):
     - Implement MaxSize and MaxAge in apt.cron.daily, to prevent the cache
       from growing too large (Ubuntu #6761)
-    * some comments about the pkgAcqMetaSig::Custom600Headers() added
-    * use gpg --with-colons
-    * commented the ftp no_proxy unseting in methods/ftp.cc
-    * added support for "Acquire::gpgv::options" in methods/gpgv.cc
+    - some comments about the pkgAcqMetaSig::Custom600Headers() added
+    - use gpg --with-colons
+    - commented the ftp no_proxy unseting in methods/ftp.cc
+    - added support for "Acquire::gpgv::options" in methods/gpgv.cc
+  * Merge bubulle@debian.org--2005/apt--main--0
+    - Make capitalization more consistent
+    - Un-fuzzy translations resulting from capitalization changes
+    - Italian translation update
 
  -- Matt Zimmerman <mdz@ubuntu.com>  Mon,  7 Mar 2005 20:08:33 -0800
 
-- 
cgit v1.2.3