summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Fritsch <sf@debian.org>2010-01-27 20:41:35 +0000
committerStefan Fritsch <sf@sfritsch.de>2012-01-02 10:37:06 +0100
commit44c00752aa9fc85f3ddc6415ad034fd2f6fa7026 (patch)
tree96700ca22dc18f8af8a6a2946c40f0d94024990f
parentf204e07b5027422f446e317fb2016ccff52e98a3 (diff)
downloadapache2-44c00752aa9fc85f3ddc6415ad034fd2f6fa7026.tar.gz
Fix symlinks in apache2-dbg package
git-svn-id: svn+ssh://svn.debian.org/svn/pkg-apache/trunk/apache2@1121 01b336ce-410b-0410-9a02-a0e7f243c266
-rw-r--r--debian/changelog1
-rwxr-xr-xdebian/rules6
2 files changed, 4 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index 40b1f1f1..a9202561 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,7 @@
apache2 (2.2.14-6) UNRELEASED; urgency=low
* Move ab and logresolve from /usr/sbin to /usr/bin. Closes: #351450, #564061
+ * Fix symlinks in apache2-dbg package. Closes: #567076
* Add new init script action graceful-stop (LP: #456381)
* Make bug script also display php extensions.
diff --git a/debian/rules b/debian/rules
index eb67551e..5f08f5dc 100755
--- a/debian/rules
+++ b/debian/rules
@@ -281,10 +281,10 @@ install: build install-dev
if [ "$(LSB_RELEASE)" != "Ubuntu" ] && [ -n "$(DEB_BUILD_STRIP)" ] ; then \
for i in worker prefork event itk; do \
MPM=usr/lib/apache2/mpm-$$i/apache2 ;\
- objcopy --only-keep-debug $(BUILD)/$$i/apache2 debian/apache2-dbg/usr/lib/debug/$$MPM-mpm-$$i ;\
- chmod 644 debian/apache2-dbg/usr/lib/debug/$$MPM-mpm-$$i ;\
+ objcopy --only-keep-debug $(BUILD)/$$i/apache2 debian/apache2-dbg/usr/lib/debug/$$MPM ;\
+ chmod 644 debian/apache2-dbg/usr/lib/debug/$$MPM ;\
strip --remove-section=.comment --remove-section=.note --strip-unneeded debian/apache2.2-bin/$$MPM ;\
- objcopy --add-gnu-debuglink=debian/apache2-dbg/usr/lib/debug/$$MPM-mpm-$$i debian/apache2.2-bin/$$MPM ;\
+ objcopy --add-gnu-debuglink=debian/apache2-dbg/usr/lib/debug/$$MPM debian/apache2.2-bin/$$MPM ;\
done ;\
fi