summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Fritsch <sf@debian.org>2010-04-14 20:30:29 +0000
committerStefan Fritsch <sf@sfritsch.de>2012-01-02 10:37:08 +0100
commitbcb326df15ac3799a7b4d200a205496ed46ecc8a (patch)
tree8ec5854517864cd2d8957025a85734d16830daa7
parent477c5d90a8509a04270776cbd2aa6ad339a70ce3 (diff)
downloadapache2-bcb326df15ac3799a7b4d200a205496ed46ecc8a.tar.gz
Fix apxs2 to work with perl 5.12rc3
git-svn-id: svn+ssh://svn.debian.org/svn/pkg-apache/trunk/apache2@1178 01b336ce-410b-0410-9a02-a0e7f243c266
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/00list1
-rwxr-xr-xdebian/patches/081_apxs_perl_5.12.dpatch28
3 files changed, 30 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 7989f5ba..16dc6313 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -6,6 +6,7 @@ apache2 (2.2.15-4) UNRELEASED; urgency=low
* Simplify logrotate script. Closes: #576105
* Remove empty directory /usr/lib/debug/usr/sbin in mpm packages.
Closes: #576089
+ * Fix apxs2 to work with perl 5.12rc3. Closes: #577239
-- Stefan Fritsch <sf@debian.org> Sat, 03 Apr 2010 15:20:42 +0200
diff --git a/debian/patches/00list b/debian/patches/00list
index b3c9d5fb..f4b66235 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -24,6 +24,7 @@
077_CacheIgnoreURLSessionIdentifiers.dpatch
079_polish_translation.dpatch
080_mod_reqtimeout_fixes.dpatch
+081_apxs_perl_5.12.dpatch
099_config_guess_sub_update
200_cp_suexec.dpatch
201_build_suexec-custom.dpatch
diff --git a/debian/patches/081_apxs_perl_5.12.dpatch b/debian/patches/081_apxs_perl_5.12.dpatch
new file mode 100755
index 00000000..816ef31e
--- /dev/null
+++ b/debian/patches/081_apxs_perl_5.12.dpatch
@@ -0,0 +1,28 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 081_apxs_perl_5.12.dpatch
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: fix apxs for perl 5.12, submitted by Roderich Schupp
+## DP: Debian bug #577239
+## DP: upstream: http://svn.apache.org/viewvc?view=revision&revision=932791
+@DPATCH@
+diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' httpd-2.2.15~/support/apxs.in httpd-2.2.15/support/apxs.in
+--- httpd-2.2.15~/support/apxs.in 2010-04-14 22:25:37.344175682 +0200
++++ httpd-2.2.15/support/apxs.in 2010-04-14 22:25:53.211177881 +0200
+@@ -83,7 +83,6 @@
+ my ($argumentative, @ARGV) = @_;
+ my $errs = 0;
+ local $_;
+- local $[ = 0;
+
+ my @args = split / */, $argumentative;
+ while (@ARGV && ($_ = $ARGV[0]) =~ /^-(.)(.*)/) {
+@@ -93,7 +92,7 @@
+ last;
+ }
+ my $pos = index($argumentative,$first);
+- if ($pos >= $[) {
++ if ($pos >= 0) {
+ if ($pos < $#args && $args[$pos+1] eq ':') {
+ shift @ARGV;
+ if ($rest eq '') {