summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Fritsch <sf@debian.org>2011-02-27 23:03:39 +0000
committerStefan Fritsch <sf@sfritsch.de>2012-01-02 10:37:11 +0100
commit7bf5e60ae775e422ebb9ebb70bc87ae0d7d1e879 (patch)
treec287d70d1c08f2dee58f19388b79018fc3594d9e
parent3bacd40042b0fc9ac184db312a0e2d102049ae03 (diff)
downloadapache2-7bf5e60ae775e422ebb9ebb70bc87ae0d7d1e879.tar.gz
Set the default file descriptor limit to 8192 instead of whatever the
current limit is (usually 1024). Document how to change it. git-svn-id: svn+ssh://svn.debian.org/svn/pkg-apache/trunk/apache2@1285 01b336ce-410b-0410-9a02-a0e7f243c266
-rw-r--r--debian/README.Debian3
-rwxr-xr-xdebian/apache2ctl2
-rw-r--r--debian/changelog3
-rw-r--r--debian/config-dir/envvars4
4 files changed, 10 insertions, 2 deletions
diff --git a/debian/README.Debian b/debian/README.Debian
index 2be0c4ad..c4a5337e 100644
--- a/debian/README.Debian
+++ b/debian/README.Debian
@@ -48,7 +48,8 @@ envvars
This contains environment variables that may be used in the
configuration. Some settings, like user and pid file, need to
go in here so that other scripts can use them. It can also
- be used to change some default settings used by apache2ctl.
+ be used to change some default settings used by apache2ctl,
+ including the ulimit value for the max number of open files.
Here is also the default LANG=C setting that can be changed
to a different language.
diff --git a/debian/apache2ctl b/debian/apache2ctl
index 7abe23b5..57b112ed 100755
--- a/debian/apache2ctl
+++ b/debian/apache2ctl
@@ -78,7 +78,7 @@ STATUSURL="${APACHE_STATUSURL:-http://localhost:80/server-status}"
# number of file descriptors allowed per child process. This is
# critical for configurations that use many file descriptors,
# such as mass vhosting, or a multithreaded server.
-ULIMIT_MAX_FILES="${APACHE_ULIMIT_MAX_FILES:-ulimit -S -n `ulimit -H -n`}"
+ULIMIT_MAX_FILES="${APACHE_ULIMIT_MAX_FILES:-ulimit -n 8192}"
# -------------------- --------------------
# |||||||||||||||||||| END CONFIGURATION SECTION ||||||||||||||||||||
diff --git a/debian/changelog b/debian/changelog
index 10d2741b..83998102 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,9 @@ apache2 (2.2.17-2) UNRELEASED; urgency=low
* Make exit code of '/etc/init.d/apache2 status' more LSB compatible.
Closes: #613969
+ * Set the default file descriptor limit to 8192 instead of whatever the
+ current limit is (usually 1024). Document how to change it in
+ /etc/apache2/envvars . Closes: #615632
* Add hint in README.Debian about 403 error with mod_dav PUT. Closes: #613438
-- Stefan Fritsch <sf@debian.org> Sat, 26 Feb 2011 15:04:45 +0100
diff --git a/debian/config-dir/envvars b/debian/config-dir/envvars
index ea5804c1..0a4cc949 100644
--- a/debian/config-dir/envvars
+++ b/debian/config-dir/envvars
@@ -31,3 +31,7 @@ export LANG
## The command to get the status for 'apache2ctl status'.
## Some packages providing 'www-browser' need '--dump' instead of '-dump'.
#export APACHE_LYNX='www-browser -dump'
+
+## If you need a higher file descriptor limit, uncomment and adjust the
+## following line (default is 8192):
+#APACHE_ULIMIT_MAX_FILES='ulimit -n 65536'