summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTollef Fog Heen <tfheen@debian.org>2006-10-22 08:09:27 +0000
committerStefan Fritsch <sf@sfritsch.de>2012-01-02 10:36:38 +0100
commit60eed0c2a623e6b54d5a1600b73b5ebae8526b86 (patch)
tree6ec13c869003f0c173039a584adfe76b6211be16
parent6e4fe8a0e00f786dddf10ea6de5a7e0e806b84d9 (diff)
downloadapache2-60eed0c2a623e6b54d5a1600b73b5ebae8526b86.tar.gz
Make sure -I flags are included too
git-svn-id: svn+ssh://svn.debian.org/svn/pkg-apache/trunk/apache2@252 01b336ce-410b-0410-9a02-a0e7f243c266
-rw-r--r--debian/changelog3
-rwxr-xr-xdebian/rules6
2 files changed, 5 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 60ad2e8a..30a50cc0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -14,7 +14,8 @@ apache2 (2.2.3-3) UNRELEASED; urgency=medium
have had. Closes: #392349
* Set default IndexWidth to *.
* Clean up CPPFLAGS and CFLAGS, including making all of CFLAGS a
- superset of CPPFLAGS.
+ superset of CPPFLAGS. Also make sure to include -I switches with
+ absolute paths so the apache headers are useful.
* Warn when not starting HTTPD due to missing apache binary.
Closes: #384128
* Provide sample disk and memory cache configurations. Closes: #278564
diff --git a/debian/rules b/debian/rules
index 816168b0..de7d0dcb 100755
--- a/debian/rules
+++ b/debian/rules
@@ -129,11 +129,11 @@ install-dev:
cp $(BUILD)/$$i/support/apxs debian/apache2-$$TARGET-dev/usr/bin/apxs2 ;\
done
# Clean up config_vars.mk
- for i in threaded prefork; do \
+ set -x ; for i in threaded prefork; do \
( cd debian/apache2-$$i-dev/usr/share/apache2/build/ ; \
grep -v -E '(^|_)(CPP|C)FLAGS' config_vars.mk > tmp_config_vars.mk ; \
- printf "CPPFLAGS = %s\n" "`grep -E '(^|_)CPPFLAGS' config_vars.mk | cut -d= -f 2- | tr ' ' '\n' | grep -E '^-([DI]|pthread)' | sort | uniq | tr '\n' ' '`" >> tmp_config_vars.mk ; \
- printf "CFLAGS = %s\n" "`grep -E '(^|_)(CPP|C)FLAGS' config_vars.mk | cut -d= -f 2- | tr ' ' '\n' | grep -E '^-([DI]|pthread)' | sort | uniq | tr '\n' ' '`" >> tmp_config_vars.mk ; \
+ printf "CPPFLAGS = %s\n" "`grep -E '(^|_)(CPPFLAGS|INCLUDES)' config_vars.mk | cut -d= -f 2- | tr ' ' '\n' | grep -E '^-([DI]|pthread)' | sort | uniq | tr '\n' ' '`" >> tmp_config_vars.mk ; \
+ printf "CFLAGS = %s\n" "`grep -E '(^|_)(CPPFLAGS|CFLAGS|INCLUDES)' config_vars.mk | cut -d= -f 2- | tr ' ' '\n' | grep -E '^-(D|I/|pthread)' | sort | uniq | tr '\n' ' '`" >> tmp_config_vars.mk ; \
printf "NOTEST_CPPFLAGS = \n" >> tmp_config_vars.mk ; \
printf "EXTRA_CPPFLAGS = \n" >> tmp_config_vars.mk ; \
printf "EXTRA_CFLAGS = \n" >> tmp_config_vars.mk ; \