summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Fritsch <sf@debian.org>2008-07-03 18:17:55 +0000
committerStefan Fritsch <sf@sfritsch.de>2012-01-02 10:36:56 +0100
commitb5eca7a38d1953c55b7bc45f46602a7047fedbf7 (patch)
tree32075ca2d1466b8c9eb9171c4a34f09892ea7f44
parentf94ab29b998890b37084e659ebcb0959dd9d35c0 (diff)
downloadapache2-b5eca7a38d1953c55b7bc45f46602a7047fedbf7.tar.gz
Make postinst more quiet
git-svn-id: svn+ssh://svn.debian.org/svn/pkg-apache/trunk/apache2@759 01b336ce-410b-0410-9a02-a0e7f243c266
-rw-r--r--debian/apache2.2-common.postinst44
-rw-r--r--debian/changelog6
2 files changed, 28 insertions, 22 deletions
diff --git a/debian/apache2.2-common.postinst b/debian/apache2.2-common.postinst
index 7386899d..9d9c36cb 100644
--- a/debian/apache2.2-common.postinst
+++ b/debian/apache2.2-common.postinst
@@ -36,7 +36,7 @@ fi
if [ $UPGRADE = new_install ]; then
if [ ! -L /etc/apache2/sites-enabled/000-default -a \
! -f /etc/apache2/sites-enabled/000-default ]; then
- ln -s /etc/apache2/sites-available/default /etc/apache2/sites-enabled/000-default
+ a2ensite -q default
fi
touch /var/log/apache2/error.log /var/log/apache2/access.log
chown root:adm /var/log/apache2/error.log /var/log/apache2/access.log
@@ -45,40 +45,40 @@ fi
# Note, this line catches new installs as well as upgrades
if dpkg --compare-versions "$2" lt 2.2.3-3.1; then
- a2enmod alias
- a2enmod autoindex
- a2enmod dir
- a2enmod env
- a2enmod mime
- a2enmod negotiation
- a2enmod setenvif
- a2enmod status
- a2enmod auth_basic
- a2enmod deflate
+ a2enmod -q alias
+ a2enmod -q autoindex
+ a2enmod -q dir
+ a2enmod -q env
+ a2enmod -q mime
+ a2enmod -q negotiation
+ a2enmod -q setenvif
+ a2enmod -q status
+ a2enmod -q auth_basic
+ a2enmod -q deflate
# Those come from mod_auth:
- a2enmod authz_default
- a2enmod authz_user
- a2enmod authz_groupfile
- a2enmod authn_file
+ a2enmod -q authz_default
+ a2enmod -q authz_user
+ a2enmod -q authz_groupfile
+ a2enmod -q authn_file
# This comes from mod_access:
- a2enmod authz_host
+ a2enmod -q authz_host
fi
if [ $UPGRADE = from_2_0 ]; then
# Module replacements from previous versions of apache2
if mod_is_enabled proxy; then
- a2enmod proxy_http
- a2enmod disk_cache
+ a2enmod -q proxy_http
+ a2enmod -q disk_cache
fi
if mod_is_enabled imap; then
- a2dismod imap
- a2enmod imagemap
+ a2dismod -q imap
+ a2enmod -q imagemap
fi
if mod_is_enabled auth_ldap; then
- a2dismod auth_ldap
- a2enmod authnz_ldap
+ a2dismod -q auth_ldap
+ a2enmod -q authnz_ldap
fi
fi
diff --git a/debian/changelog b/debian/changelog
index 85ddced3..bc24eff0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+apache2 (2.2.9-4) UNRELEASED; urgency=low
+
+ * Make postinst more quiet. (Closes: #489153)
+
+ -- Stefan Fritsch <sf@debian.org> Thu, 03 Jul 2008 20:16:01 +0200
+
apache2 (2.2.9-3) unstable; urgency=low
[ Stefan Fritsch ]