summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Fritsch <sf@debian.org>2007-09-26 21:58:58 +0000
committerStefan Fritsch <sf@sfritsch.de>2012-01-02 10:36:47 +0100
commit008e99cc3748a01e68938f589cd4980a1cec8c46 (patch)
tree5a1113dac9aa978327cc67b058e1882138216e57
parentb903126168d95128a52616851457a4143044580c (diff)
downloadapache2-008e99cc3748a01e68938f589cd4980a1cec8c46.tar.gz
Fix "Bad file descriptor" error on reload
git-svn-id: svn+ssh://svn.debian.org/svn/pkg-apache/trunk/apache2@480 01b336ce-410b-0410-9a02-a0e7f243c266
-rw-r--r--debian/changelog3
-rw-r--r--debian/patches/00list1
-rw-r--r--debian/patches/051Bad_file_descriptor_PR42829.dpatch26
3 files changed, 29 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index eb23eadf..76924f3e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,9 +1,10 @@
apache2 (2.2.6-2) UNRELEASED; urgency=low
+ * Fix "Bad file descriptor" error on reload (Closes: #443310)
* Remove duplicate config examples (Closes: #294662)
* Add CVE reference to 2.2.6-1 changelog entry
- -- Stefan Fritsch <sf@debian.org> Tue, 18 Sep 2007 21:04:38 +0200
+ -- Stefan Fritsch <sf@debian.org> Wed, 26 Sep 2007 23:35:16 +0200
apache2 (2.2.6-1) unstable; urgency=low
diff --git a/debian/patches/00list b/debian/patches/00list
index 4ac8bdbf..99ecead7 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -15,4 +15,5 @@
046_proxy_ftp_dirparse_crash.dpatch
047_fix_usage_message.dpatch
050_enhance_apache2ctl.dpatch
+051Bad_file_descriptor_PR42829.dpatch
099_config_guess_sub_update
diff --git a/debian/patches/051Bad_file_descriptor_PR42829.dpatch b/debian/patches/051Bad_file_descriptor_PR42829.dpatch
new file mode 100644
index 00000000..f3ac4cdc
--- /dev/null
+++ b/debian/patches/051Bad_file_descriptor_PR42829.dpatch
@@ -0,0 +1,26 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 051Bad_file_descriptor_PR42829.dpatch
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: fix [error] (9)Bad file descriptor: apr_socket_accept: (client socket)
+## DP: on graceful reload
+
+@DPATCH@
+--- a/server/mpm/prefork/prefork.c.orig Fri Jul 6 11:12:53 2007
++++ a/server/mpm/prefork/prefork.c Fri Jul 6 11:18:24 2007
+@@ -330,8 +330,6 @@
+
+ static void stop_listening(int sig)
+ {
+- ap_close_listeners();
+-
+ /* For a graceful stop, we want the child to exit when done */
+ die_now = 1;
+ }
+@@ -657,6 +655,7 @@
+ die_now = 1;
+ }
+ }
++ ap_close_listeners();
+ clean_child_exit(0);
+ }