summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Fritsch <sf@debian.org>2008-01-03 18:17:09 +0000
committerStefan Fritsch <sf@sfritsch.de>2012-01-02 10:36:49 +0100
commit348727253be37c3d16c0679dfbc865d7b6df6350 (patch)
tree76d04a8e75e0ddc3c9a989ace003c2d10f9b0d05
parent8d87284f87de1f1f9535888e3c528fb879cf342a (diff)
downloadapache2-348727253be37c3d16c0679dfbc865d7b6df6350.tar.gz
rename AP2_CONFLAGS to AP2_CFLAGS, which is more apropriate
git-svn-id: svn+ssh://svn.debian.org/svn/pkg-apache/trunk/apache2@521 01b336ce-410b-0410-9a02-a0e7f243c266
-rwxr-xr-xdebian/rules8
1 files changed, 4 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index b5a854d1..5ab8a316 100755
--- a/debian/rules
+++ b/debian/rules
@@ -70,14 +70,14 @@ AP2_COMMON_CONFARGS = --enable-layout=Debian --enable-so \
# This is insufficiently flexible.
# --enable-mods-shared=all --enable-modules=all
-AP2_CONFLAGS = $(CFLAGS) -pipe -I/usr/include/xmltok -I/usr/include/openssl -Wall
+AP2_CFLAGS = $(CFLAGS) -pipe -I/usr/include/xmltok -I/usr/include/openssl -Wall
AP2_LDFLAGS = -Wl,--as-needed
#support debug building
ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
-AP2_CONFLAGS += -g -O0
+AP2_CFLAGS += -g -O0
else
-AP2_CONFLAGS += -O2
+AP2_CFLAGS += -O2
endif
ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
@@ -103,7 +103,7 @@ mpm-%:
dh_testdir
mkdir -p $(BUILD)/$*
cd $(BUILD)/$* ;\
- CFLAGS="$(AP2_CONFLAGS)" LDFLAGS="$(AP2_LDFLAGS)" $(CONFFLAGS) $(REALCURDIR)/configure --srcdir=$(REALCURDIR) $(AP2_COMMON_CONFARGS) $(AP2_CONFARGS) --with-mpm=$* ;\
+ CFLAGS="$(AP2_CFLAGS)" LDFLAGS="$(AP2_LDFLAGS)" $(CONFFLAGS) $(REALCURDIR)/configure --srcdir=$(REALCURDIR) $(AP2_COMMON_CONFARGS) $(AP2_CONFARGS) --with-mpm=$* ;\
$(MAKE)
touch $@