summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Fritsch <sf@debian.org>2008-01-03 17:57:40 +0000
committerStefan Fritsch <sf@sfritsch.de>2012-01-02 10:36:49 +0100
commit8d87284f87de1f1f9535888e3c528fb879cf342a (patch)
tree4db032612eda8ac1a22e08eff4d2a7b438f71798
parentf33c469d2055d6094f345289751d30acef039718 (diff)
downloadapache2-8d87284f87de1f1f9535888e3c528fb879cf342a.tar.gz
use -Wl,--as-needed
git-svn-id: svn+ssh://svn.debian.org/svn/pkg-apache/trunk/apache2@520 01b336ce-410b-0410-9a02-a0e7f243c266
-rw-r--r--debian/changelog2
-rwxr-xr-xdebian/rules4
2 files changed, 4 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 47df2f08..f306f9a4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -8,6 +8,8 @@ apache2 (2.2.6-4) UNRELEASED; urgency=low
RedirectMatch line from sites-available/default.
(Closes: #411774, #458093)
* Add some information to README.Debian (Apache wiki, default virtual host)
+ * Build with LDFLAGS=-Wl,--as-needed to drop a lot of unnecessary
+ dependencies, easing library transitions (closes: #458857).
* Fix some lintian warnings:
- Pass --no-start to dh_installinit instead of omitting the debhelper token
in various maintainer scripts. Also move the update-rc.d call to
diff --git a/debian/rules b/debian/rules
index 1f7a1770..b5a854d1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -71,7 +71,7 @@ AP2_COMMON_CONFARGS = --enable-layout=Debian --enable-so \
# --enable-mods-shared=all --enable-modules=all
AP2_CONFLAGS = $(CFLAGS) -pipe -I/usr/include/xmltok -I/usr/include/openssl -Wall
-#AP2_LDFLAGS = -ldl -lexpat -lcrypt -ldb-4.3
+AP2_LDFLAGS = -Wl,--as-needed
#support debug building
ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
@@ -103,7 +103,7 @@ mpm-%:
dh_testdir
mkdir -p $(BUILD)/$*
cd $(BUILD)/$* ;\
- CFLAGS="$(AP2_CONFLAGS)" $(CONFFLAGS) $(REALCURDIR)/configure --srcdir=$(REALCURDIR) $(AP2_COMMON_CONFARGS) $(AP2_CONFARGS) --with-mpm=$* ;\
+ CFLAGS="$(AP2_CONFLAGS)" LDFLAGS="$(AP2_LDFLAGS)" $(CONFFLAGS) $(REALCURDIR)/configure --srcdir=$(REALCURDIR) $(AP2_COMMON_CONFARGS) $(AP2_CONFARGS) --with-mpm=$* ;\
$(MAKE)
touch $@