summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Fritsch <sf@debian.org>2008-06-27 09:13:04 +0000
committerStefan Fritsch <sf@sfritsch.de>2012-01-02 10:36:55 +0100
commit23af0178ef0ba4323e0937d864529c1c963a8a7f (patch)
tree6eb78740207c3d113f479b6d9a3c77789f9971c7
parente3e678b249c85bf8823e1f9ea50b1bbf6ac53094 (diff)
downloadapache2-23af0178ef0ba4323e0937d864529c1c963a8a7f.tar.gz
Always pass -g to gcc
git-svn-id: svn+ssh://svn.debian.org/svn/pkg-apache/trunk/apache2@723 01b336ce-410b-0410-9a02-a0e7f243c266
-rw-r--r--debian/changelog2
-rwxr-xr-xdebian/rules14
2 files changed, 7 insertions, 9 deletions
diff --git a/debian/changelog b/debian/changelog
index 276a87cc..dd99b6c4 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -19,6 +19,8 @@ apache2 (2.2.9-3) UNRELEASED; urgency=low
home directories.
* Disable SSLv2 by default. It is insecure. Also only enable ciphers with
key lengths of at least 128 bit.
+ * Always pass -g to gcc instead of relying on dpkg-buildpackage to set
+ CFLAGS. We always want the debug info for the apache2-dbg package.
[ Ryan Niebur ]
* Upgraded to policy 3.8.0
diff --git a/debian/rules b/debian/rules
index 05ef7106..23963b79 100755
--- a/debian/rules
+++ b/debian/rules
@@ -70,18 +70,14 @@ AP2_MODS_CONFARGS = --enable-authn-alias=shared --enable-authnz-ldap=shared \
--enable-rewrite=shared --enable-mime=shared \
--enable-substitute=shared
-AP2_CFLAGS = $(CFLAGS) -pipe -I/usr/include/xmltok -I/usr/include/openssl -Wall
+AP2_CFLAGS = $(CFLAGS) -g -pipe -I/usr/include/xmltok -I/usr/include/openssl -Wall
AP2_LDFLAGS = -Wl,--as-needed
-#support debug building
-ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
- AP2_CFLAGS += -g -O0
+#support noopt building
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ AP2_CFLAGS += -O0
else
- ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- AP2_CFLAGS += -O0
- else
- AP2_CFLAGS += -O2
- endif
+ AP2_CFLAGS += -O2
endif
ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))