summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArno Töll <debian@toell.net>2012-03-18 23:00:36 +0100
committerArno Töll <debian@toell.net>2012-03-19 00:13:12 +0100
commitf2beb333924f44e0bf8ff3f254cf81570d17df22 (patch)
tree405d3c878b1aeb9e6cd9649fd99d46aa34f26331
parent985bc52fec3707568988762b013ccf73306127ed (diff)
downloadapache2-f2beb333924f44e0bf8ff3f254cf81570d17df22.tar.gz
* Change MPM transition packages to arch:all
* Add ${perl:Depends} where required (though probably useless) * Fix syntax error in apache2-maintscript-helper introduced recently * Update apache2-doc maintainer scripts
-rw-r--r--debian/apache2-doc.postinst4
-rw-r--r--debian/apache2-doc.postrm4
-rw-r--r--debian/clean2
-rw-r--r--debian/control18
-rw-r--r--debian/debhelper/apache2-maintscript-helper2
-rwxr-xr-xdebian/rules1
6 files changed, 14 insertions, 17 deletions
diff --git a/debian/apache2-doc.postinst b/debian/apache2-doc.postinst
index ee9465fd..e7e1e5a7 100644
--- a/debian/apache2-doc.postinst
+++ b/debian/apache2-doc.postinst
@@ -9,9 +9,7 @@ set -e
if [ "$1" = "configure" ] ; then
if [ -e /usr/share/apache2/apache2-maintscript-helper ] ; then
- if [ -z $EXPORT_APACHE2_MAINTSCRIPT_HELPER ] ; then
- . /usr/share/apache2/apache2-maintscript-helper
- fi
+ . /usr/share/apache2/apache2-maintscript-helper
apache2_invoke enconf apache2-doc || true
fi
fi
diff --git a/debian/apache2-doc.postrm b/debian/apache2-doc.postrm
index 5159100e..d35dca8d 100644
--- a/debian/apache2-doc.postrm
+++ b/debian/apache2-doc.postrm
@@ -6,9 +6,7 @@ set -e
if [ "$1" = "purge" ] ; then
if [ -e /usr/share/apache2/apache2-maintscript-helper ] ; then
- if [ -z $EXPORT_APACHE2_MAINTSCRIPT_HELPER ] ; then
- . /usr/share/apache2/apache2-maintscript-helper
- fi
+ . /usr/share/apache2/apache2-maintscript-helper
apache2_invoke disconf apache2-doc || true
fi
diff --git a/debian/clean b/debian/clean
index e4a13be0..650d6475 100644
--- a/debian/clean
+++ b/debian/clean
@@ -11,8 +11,8 @@ debian/apache2-suexec-pristine.links
debian/apache2-suexec-pristine.dirs
debian/apache2-suexec-pristine.lintian-overrides
debian/a2query
+debian/manpages/a2query.8
debian/manpages/dh_apache2.1
debian/debhelper/dh_apache2
-debian/manpages/a2query.8
support/suexec-custom.c
config.nice
diff --git a/debian/control b/debian/control
index c8b1a963..9806c8e4 100644
--- a/debian/control
+++ b/debian/control
@@ -18,7 +18,7 @@ Package: apache2
Architecture: any
Depends: ${misc:Depends}, lsb-base, procps [!hurd-i386],
perl, mime-support, apache2-bin (= ${binary:Version}),
- apache2-data (= ${source:Version})
+ apache2-data (= ${source:Version}), ${perl:Depends}
Replaces: apache2.2-common
Conflicts: apache2.2-common
Recommends: ssl-cert
@@ -47,7 +47,7 @@ Description: Apache HTTP Server (common files)
Package: apache2-bin
Architecture: any
-Depends: ${shlibs:Depends}, ${misc:Depends}
+Depends: ${shlibs:Depends}, ${misc:Depends}, ${perl:Depends}
# MODULE_MAGIC_NUMBER_MAJOR from apache2/include/ap_mmn.h
Provides: ${apache2:API}
Suggests: www-browser, apache2-doc, apache2-suexec-pristine | apache2-suexec-custom
@@ -67,7 +67,7 @@ Package: apache2-mpm-worker
Architecture: any
Section: oldlibs
Priority: extra
-Depends: ${shlibs:Depends}, ${misc:Depends}, apache2 (= ${binary:Version})
+Depends: ${misc:Depends}, apache2 (= ${binary:Version})
Description: transitional worker MPM package for apache2
This is a transitional package to apache2 for users of apache2-mpm-worker and
can be safely removed after the installation is complete.
@@ -76,7 +76,7 @@ Package: apache2-mpm-prefork
Architecture: any
Section: oldlibs
Priority: extra
-Depends: ${shlibs:Depends}, ${misc:Depends}, apache2 (= ${binary:Version})
+Depends: ${misc:Depends}, apache2 (= ${binary:Version})
Description: transitional prefork MPM package for apache2
This is a transitional package to apache2 for users of apache2-mpm-prefork and
can be safely removed after the installation is complete.
@@ -85,7 +85,7 @@ Package: apache2-mpm-event
Architecture: any
Section: oldlibs
Priority: extra
-Depends: ${shlibs:Depends}, ${misc:Depends}, apache2 (= ${binary:Version})
+Depends: ${misc:Depends}, apache2 (= ${binary:Version})
Description: transitional event MPM package for apache2
This is a transitional package to apache2 for users of apache2-mpm-event and
can be safely removed after the installation is complete.
@@ -96,14 +96,14 @@ Package: apache2.2-bin
Architecture: any
Section: oldlibs
Priority: extra
-Depends: ${shlibs:Depends}, ${misc:Depends}, apache2-bin (>= 2.3~)
+Depends: ${misc:Depends}, apache2-bin (>= 2.3~)
Description: Transitional package for apache2-bin
This is a transitional package for apache2-bin, and can be safely removed
after the installation is complete.
Package: apache2-utils
Architecture: any
-Depends: ${misc:Depends}, ${shlibs:Depends}
+Depends: ${misc:Depends}, ${shlibs:Depends}, ${perl:Depends}
Description: Apache HTTP Server (utility programs for web servers)
Provides some add-on programs useful for any web server. These include:
- ab (Apache benchmark tool)
@@ -124,7 +124,7 @@ Package: apache2-suexec
Architecture: any
Section: oldlibs
Priority: extra
-Depends: ${shlibs:Depends}, ${misc:Depends},
+Depends: ${misc:Depends},
apache2-suexec-pristine (= ${binary:Version}) | apache2-suexec-custom (= ${binary:Version})
Description: transitional package for apache2-suexec-pristine
This is a transitional package for apache2-suexec-pristine, and can be safely
@@ -177,7 +177,7 @@ Description: Apache HTTP Server (on-site documentation)
Package: apache2-dev
Architecture: any
Depends: ${misc:Depends}, apache2 (= ${binary:Version}), openssl,
- libapr1-dev, libaprutil1-dev, debhelper (>= 7.0.50~)
+ libapr1-dev, libaprutil1-dev, debhelper (>= 7.0.50~), ${perl:Depends}
Provides: apache2-prefork-dev, apache2-threaded-dev, dh-apache2
Replaces: apache2-prefork-dev, apache2-threaded-dev
Conflicts: apache2-prefork-dev, apache2-threaded-dev
diff --git a/debian/debhelper/apache2-maintscript-helper b/debian/debhelper/apache2-maintscript-helper
index a89b4c1d..9da558b5 100644
--- a/debian/debhelper/apache2-maintscript-helper
+++ b/debian/debhelper/apache2-maintscript-helper
@@ -18,7 +18,7 @@
# IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
-if [ -z "${EXPORT_APACHE2_MAINTSCRIPT_HELPER:-} ] ; then
+if [ -n "${EXPORT_APACHE2_MAINTSCRIPT_HELPER:-}" ] ; then
return
fi
EXPORT_APACHE2_MAINTSCRIPT_HELPER=1
diff --git a/debian/rules b/debian/rules
index e4140f50..a48a2689 100755
--- a/debian/rules
+++ b/debian/rules
@@ -33,6 +33,7 @@ clean-config-vars:
%: %.in
sed 's#__SERVER_VERSION__#$(SERVER_VERSION)#; s#__MODULE_DIR__#$(MODULE_DIR)#; s#__API__#$(API)#;' $< > $@
+ chmod `/usr/bin/stat -c '%a' "$<"` $@
prepare-scripts: debian/a2query debian/debhelper/dh_apache2
(grep -s -v apache2:API debian/apache2-bin.substvars; echo apache2:API=apache2-api-$(API)) > debian/apache2-bin.substvars.new