summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Fritsch <sf@sfritsch.de>2013-05-30 17:07:16 +0200
committerStefan Fritsch <sf@sfritsch.de>2013-05-30 17:07:16 +0200
commit4dc7cca2005054a6356c82d5f00b7c6569e2560f (patch)
tree4db477ce3671cc5ad57656dfe61a9b4a5be91bbf
parent50112865a3c02ac5289d08048be7235c48c730a7 (diff)
downloadapache2-4dc7cca2005054a6356c82d5f00b7c6569e2560f.tar.gz
Add a note to README.Debian about max file limit
Make apache2ctl print a message pointing to README.Debian if setting the limit fails.
-rw-r--r--debian/apache2.README.Debian9
-rwxr-xr-xdebian/apache2ctl4
-rw-r--r--debian/changelog3
3 files changed, 15 insertions, 1 deletions
diff --git a/debian/apache2.README.Debian b/debian/apache2.README.Debian
index 825c5e38..fd7dcb87 100644
--- a/debian/apache2.README.Debian
+++ b/debian/apache2.README.Debian
@@ -428,6 +428,15 @@ Use apache2ctl (it accepts all the same options as apache2).
Apache also needs write permission to the directory containing the file, in
order to replace it atomically.
+10) When starting/reloading Apache, there is the error message
+ "ulimit: open files: cannot modify limit: Operation not permitted"
+
+If you are running Apache in a vserver environment, the start script may not
+be allowed to set the maximum number of open files. You should adjust
+APACHE_ULIMIT_MAX_FILES in /etc/apache2/envvars to your setup. You can
+disable changing the limits by setting APACHE_ULIMIT_MAX_FILES=true .
+
+
For Developers
==============
diff --git a/debian/apache2ctl b/debian/apache2ctl
index aeb61a2e..63db198f 100755
--- a/debian/apache2ctl
+++ b/debian/apache2ctl
@@ -84,7 +84,9 @@ ULIMIT_MAX_FILES="${APACHE_ULIMIT_MAX_FILES:-ulimit -n 8192}"
# Set the maximum number of file descriptors allowed per child process.
if [ "x$ULIMIT_MAX_FILES" != "x" ] && [ `id -u` -eq 0 ] ; then
- $ULIMIT_MAX_FILES
+ if ! $ULIMIT_MAX_FILES ; then
+ echo Setting ulimit failed. See README.Debian for more information. >&2
+ fi
fi
ERROR=0
diff --git a/debian/changelog b/debian/changelog
index 4e9949ae..2ca73662 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -8,6 +8,9 @@ apache2 (2.4.4-4) UNRELEASED; urgency=low
- don't use /lib/init/vars.sh in init script
* Add note to README.Debian about CVE-2013-0966 if the document root is
on HFS+ or on ZFS with filename normalization.
+ * Add a note to README.Debian about how to change the max file limit.
+ Make apache2ctl print a message pointing to README.Debian if setting
+ the limit fails. (Closes: #706822)
[ Arno Töll ]
* Correct maintainer scripts by removing forgotten left-overs of our Squeeze