summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArno Töll <arno@debian.org>2013-06-07 17:42:51 +0200
committerArno Töll <arno@debian.org>2013-06-07 17:42:51 +0200
commit20e2f28a32b6fdef29a68b88ea044e8deb73202b (patch)
tree39f22801b15f0ee525fe19713ab7e628fc7bfca2
parent128294e9dfb3204d5193678526eb80a0b6f57407 (diff)
downloadapache2-20e2f28a32b6fdef29a68b88ea044e8deb73202b.tar.gz
apache2.2-bin depends on apache2 because we link docs to it. That happened by accident, as we could just link to apache2-bin too
-rw-r--r--debian/apache2.2-bin.postinst49
-rw-r--r--debian/changelog6
-rwxr-xr-xdebian/rules3
3 files changed, 56 insertions, 2 deletions
diff --git a/debian/apache2.2-bin.postinst b/debian/apache2.2-bin.postinst
new file mode 100644
index 00000000..27a551bf
--- /dev/null
+++ b/debian/apache2.2-bin.postinst
@@ -0,0 +1,49 @@
+#! /bin/bash
+# postinst script for apache2.2-bin
+#
+# see: dh_installdeb(1)
+
+set -e
+
+
+# summary of how this script can be called:
+# * <postinst> `configure' <most-recently-configured-version>
+# * <old-postinst> `abort-upgrade' <new version>
+# * <conflictor's-postinst> `abort-remove' `in-favour' <package>
+# <new-version>
+# * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
+# <failed-install-package> <version> `removing'
+# <conflicting-package> <version>
+#
+# for details, see http://www.debian.org/doc/debian-policy/ or
+# the debian-policy package
+
+case "$1" in
+ configure)
+ if [ -n "$2" ] && dpkg --compare-versions "$2" lt "2.4.4-5" ; then
+ if [ -d /usr/share/doc/apache2.2-bin ] ; then
+ RET=0
+ rmdir /usr/share/doc/apache2.2-bin > /dev/null 2>&1|| RET=$?
+ if [ $RET = 0 ] ; then
+ ln -s /usr/share/doc/apache2-bin /usr/share/doc/apache2.2-bin
+ fi
+ fi
+ fi
+ ;;
+
+ abort-upgrade|abort-remove|abort-deconfigure)
+
+ ;;
+
+ *)
+ echo "postinst called with unknown argument \`$1'" >&2
+ exit 1
+ ;;
+esac
+
+# dh_installdeb will replace this with shell code automatically
+# generated by other debhelper scripts.
+
+#DEBHELPER#
+
+exit 0
diff --git a/debian/changelog b/debian/changelog
index 2a2b73f1..f9c3812d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -29,8 +29,12 @@ apache2 (2.4.4-6) UNRELEASED; urgency=low
Beckert for demangling shell specifics (Closes: #711479)
* Fix "copyright file missing after upgrade (policy 12.5)" and add these for
MPM transitional packages (Closes: #710914)
+ * Fix "apache2.2-bin transitional package (binaries only) should not
+ depend on apache2 package (which runs a system daemon)". This happened by
+ accident added by debhelper since we are linking docs. We do to
+ apache2-bin instead (Closes: #711127)
- -- Arno Töll <arno@debian.org> Fri, 07 Jun 2013 16:56:44 +0200
+ -- Arno Töll <arno@debian.org> Fri, 07 Jun 2013 17:41:18 +0200
apache2 (2.4.4-5) unstable; urgency=low
diff --git a/debian/rules b/debian/rules
index 35621eb1..a58cae13 100755
--- a/debian/rules
+++ b/debian/rules
@@ -135,8 +135,9 @@ override_dh_installdocs-indep:
override_dh_installdocs-arch:
dh_installdocs --link-doc=apache2 -papache2 -papache2-dbg \
-papache2-mpm-worker -papache2-mpm-prefork -papache2-mpm-event \
- -papache2-mpm-itk -plibapache2-mod-proxy-html -papache2.2-bin \
+ -papache2-mpm-itk -plibapache2-mod-proxy-html \
-plibapache2-mod-proxy-html
+ dh_installdocs --link-doc=apache2-bin -papache2.2-bin
dh_installdocs --link-doc=apache2-suexec-pristine -papache2-suexec
dh_installdocs -a