summaryrefslogtreecommitdiff
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rwxr-xr-xdebian/patches/002_apachectl20
-rwxr-xr-xdebian/patches/004_usr_bin_perl_0wnz_j0015
-rw-r--r--debian/patches/00list2
-rwxr-xr-xdebian/patches/031_apxs2_sucks_more28
4 files changed, 64 insertions, 1 deletions
diff --git a/debian/patches/002_apachectl b/debian/patches/002_apachectl
new file mode 100755
index 00000000..cffbcaf8
--- /dev/null
+++ b/debian/patches/002_apachectl
@@ -0,0 +1,20 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 002_apachectl by Adam Conrad <adconrad@0c3.net>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: envvars lives in /etc/apache2 in our setup.
+
+@DPATCH@
+--- apache2/support/apachectl.in 2003-05-07 13:18:19.000000000 +0100
++++ apache2/support/apachectl.in 2003-05-07 13:17:37.000000000 +0100
+@@ -31,8 +31,8 @@
+ HTTPD='@exp_sbindir@/@progname@'
+ #
+ # pick up any necessary environment variables
+-if test -f @exp_sbindir@/envvars; then
+- . @exp_sbindir@/envvars
++if test -f @exp_sysconfdir@/envvars; then
++ . @exp_sysconfdir@/envvars
+ fi
+ #
+ # a command that outputs a formatted text version of the HTML at the
diff --git a/debian/patches/004_usr_bin_perl_0wnz_j00 b/debian/patches/004_usr_bin_perl_0wnz_j00
new file mode 100755
index 00000000..decdf74d
--- /dev/null
+++ b/debian/patches/004_usr_bin_perl_0wnz_j00
@@ -0,0 +1,15 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 004_usr_bin_perl_0wnz_j00 by Adam Conrad <adconrad@0c3.net>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Call /usr/bin/perl in printenv, not /usr/local/bin/perl
+
+@DPATCH@
+--- apache2/docs/cgi-examples/printenv.orig Fri Sep 21 17:31:24 2001
++++ apache2/docs/cgi-examples/printenv Fri Sep 21 17:31:29 2001
+@@ -1,4 +1,4 @@
+-#!/usr/local/bin/perl
++#!/usr/bin/perl
+ ##
+ ## printenv -- demo CGI program which just prints its environment
+ ##
diff --git a/debian/patches/00list b/debian/patches/00list
index d82fc30a..f684351f 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -1,4 +1,6 @@
001_branding
+002_apachectl
+004_usr_bin_perl_0wnz_j00
008_make_include_safe
009_apache2_has_dso
010_fhs_compliance
diff --git a/debian/patches/031_apxs2_sucks_more b/debian/patches/031_apxs2_sucks_more
index 5bd1e6d6..e595dcdc 100755
--- a/debian/patches/031_apxs2_sucks_more
+++ b/debian/patches/031_apxs2_sucks_more
@@ -2,11 +2,28 @@
## 031_apxs2_sucks_more by Adam Conrad <adconrad@0c3.net>
##
## All lines beginning with `## DP:' are a description of the patch.
-## DP: Make apxs2 use httpd.conf, instead of apache2.conf.
+## DP: Make apxs2 use httpd.conf, instead of apache2.conf, plus other random fixes.
@DPATCH@
--- apache2/support/apxs.in 2005-06-10 10:18:14.000000000 +0100
+++ apache2/support/apxs.in 2006-01-26 16:50:17.000000000 +0000
+@@ -190,7 +190,7 @@
+ my $httpd = get_vars("sbindir") . "/" . get_vars("progname");
+ $httpd = eval qq("$httpd");
+ $httpd = eval qq("$httpd");
+-my $envvars = get_vars("sbindir") . "/envvars";
++my $envvars = "$CFG_SYSCONFDIR" . "/envvars";
+ $envvars = eval qq("$envvars");
+ $envvars = eval qq("$envvars");
+
+@@ -331,6 +331,7 @@
+ $data =~ s|%TARGET%|$CFG_TARGET|sg;
+ $data =~ s|%PREFIX%|$prefix|sg;
+ $data =~ s|%INSTALLBUILDDIR%|$installbuilddir|sg;
++ $data =~ s|%DATADIR%|$datadir|sg;
+
+ my ($mkf, $mods, $src) = ($data =~ m|^(.+)-=#=-\n(.+)-=#=-\n(.+)|s);
+
@@ -480,7 +480,7 @@
if ($opt_i) {
push(@cmds, "$installbuilddir/instdso.sh SH_LIBTOOL='" .
@@ -69,3 +86,12 @@
} else {
notice("unable to open configuration file");
}
+@@ -694,7 +695,7 @@
+
+ builddir=.
+ top_srcdir=%PREFIX%
+-top_builddir=%PREFIX%
++top_builddir=%DATADIR%
+ include %INSTALLBUILDDIR%/special.mk
+
+ # the used tools