summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMarc Haber <zugschlus@debian.org>2007-01-05 15:10:23 +0000
committerMarc Haber <zugschlus@debian.org>2007-01-05 15:10:23 +0000
commitc7ce872bd4f73202b75ad20b24a58c327772da1d (patch)
tree78b76e1c7c2f22f5a4d9a42f2bbcabdb790f2579 /debian/rules
parentc4ce72a5b60203361081621cb4041cf35f259f04 (diff)
downloadexim4-c7ce872bd4f73202b75ad20b24a58c327772da1d.tar.gz
* merge trunk -14 changes
* Fix update-exim4.conf.8 manpage * FILES section is no longer doubled * NAME is no longer multi-line * proper reference to ue4cc in FILES section * Thanks to Angus Mackenzie * debian/rules * allow buildbasepackages and extradaemonpackages to be set from the environment * fix buildbasepackages=no and extradaemonpackages which were broken due to the new -dev binary package * remove "" in various places, this is Make not shell * add optional debugging output for variables that are meant to be set externally * clean now unpatches first, otherwise clean fails because files are first deleted and then non-existing files are unpatched * take config.h from first non-light daemon package built instead of -heavy (we might not be building -heavy but still need -dev) * Thanks to Gerfried Fuchs for actually using these features and finding this bug group. * exim4.init: Now returns 0 when starting and daemon already running, and when stopping and daemon already stopped. This fixes LSB compliance. Thanks to Heiko Schlittermann. Closes: #404182 svn path=/exim/branches/experimental/; revision=1877
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules28
1 files changed, 19 insertions, 9 deletions
diff --git a/debian/rules b/debian/rules
index 587f1e7..660db94 100755
--- a/debian/rules
+++ b/debian/rules
@@ -30,9 +30,13 @@ endif
export CFLAGS
# Which packages should we build?
+ifndef buildbasepackages
buildbasepackages=yes
+endif
+ifndef extradaemonpackages
extradaemonpackages=exim4-daemon-heavy
+endif
# If you want to build a daemon with a configuration tailored to YOUR special
# needs, call "fakeroot debian/rules unpack-configs", copy EDITME.exim4-light
# to EDITME.exim4-custom and modify it. Please note that you _need_ to
@@ -69,16 +73,20 @@ basedaemonpackages=exim4-daemon-light
combinedadbgpackage=exim4-base eximon4
combinedidbgpackage=exim4-config exim4
exim4dbg=exim4-dbg
+dhstripparm=--dbg-package=$(exim4dbg)
exim4dev=exim4-dev
extraadbgpackage=$(basedaemonpackages) $(extradaemonpackages)
else
-basedaemonpackages=""
-combinedadbgpackage=""
-combinedidbgpackage=""
-exim4dbg=""
-exim4dev=""
+basedaemonpackages=
+combinedadbgpackage=
+combinedidbgpackage=
+exim4dbg=
+dhstripparm=
+exim4dev=
extraadbgpackage=$(extradaemonpackages)
endif
+#DEBUGOUT:=$(shell echo >&2 buildbasepackages $(buildbasepackages))
+#DEBUGOUT:=$(shell echo >&2 extradaemonpackages $(extradaemonpackages))
# If you want to build with OpenSSL instead of GnuTLS, uncomment this
# OPENSSL:=1
@@ -216,7 +224,7 @@ endif
build: build-arch build-indep
-clean: cleanfiles unpatch
+clean: unpatch cleanfiles
cleanfiles:
dh_testdir
@@ -351,7 +359,7 @@ ifeq ($(buildbasepackages),yes)
dh_installppp -i --name=exim4
dh_installman -i
dh_install -i
- dh_strip $(dhcombinedidbgpackage) --dbg-package=$(exim4dbg)
+ dh_strip $(dhcombinedidbgpackage) $(dhstripparm)
#for pkg in $(extraidbgpackage); do \
# dh_strip -p$$pkg --dbg-package=$${pkg}-dbg; \
#done
@@ -403,8 +411,10 @@ binary-arch: build $(install)
# dh_installinfo $(dhbuildpackages)
# dh_undocumented $(dhbuildpackages)
dh_installman $(dhbuildpackages)
- dh_install $(dhbuildpackages)
- dh_strip $(dhcombinedadbgpackage) --dbg-package=$(exim4dbg)
+ # install config.h from daemon package, but not from exim4-daemon-light
+ dh_install $(dhbuildpackages) $(shell ls -1 build-tree/build-exim4-daemon-*/config.h | grep -v build-tree/build-exim4-daemon-light/config.h) usr/include/exim4
+ dh_install -p exim4-dev $(shell ls -1 build-tree/build-exim4-daemon-*/config.h | grep -v build-tree/build-exim4-daemon-light/config.h) usr/include/exim4
+ dh_strip $(dhcombinedadbgpackage) $(dhstripparm)
for pkg in $(extraadbgpackage); do \
dh_strip -p$$pkg --dbg-package=$${pkg}-dbg; \
done