summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Stapelberg <michael@stapelberg.de>2013-08-12 09:20:09 +0200
committerMichael Stapelberg <michael@stapelberg.de>2013-08-12 09:21:18 +0200
commit05cc04cd5e3b09971b8de97720870cc6772a1af9 (patch)
tree68aa8d7fa4c97b8794907eac474e1b5896ed5460
parent730025ce5c7c574b0056f9f41b7f97ce7eed2a35 (diff)
downloadgolang-05cc04cd5e3b09971b8de97720870cc6772a1af9.tar.gz
emacsen: skip a number of old emacs versions (Thanks Kevin)
-rw-r--r--debian/changelog2
-rw-r--r--debian/golang-mode.emacsen-install10
-rw-r--r--debian/golang-mode.emacsen-remove14
3 files changed, 18 insertions, 8 deletions
diff --git a/debian/changelog b/debian/changelog
index 98cdf6f4b..31fd0fcda 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,8 @@ golang (2:1.1.1-5) UNRELEASED; urgency=low
* Relicense debian/ under the Go license to match upstream. All copyright
holders agreed to this. (Closes: #716907)
+ * golang-mode: don’t install for a number of emacs versions which are not
+ supported upstream (Thanks Kevin Ryde) (Closes: #702511, #717521)
-- Michael Stapelberg <stapelberg@debian.org> Fri, 19 Jul 2013 19:56:46 +0200
diff --git a/debian/golang-mode.emacsen-install b/debian/golang-mode.emacsen-install
index 5521e515c..c028dfdb1 100644
--- a/debian/golang-mode.emacsen-install
+++ b/debian/golang-mode.emacsen-install
@@ -4,10 +4,12 @@
FLAVOR=$1
PACKAGE=golang-mode
-# Do nothing if generic flavor.
-if [ ${FLAVOR} = emacs ]; then
- exit 0;
-fi
+# A number of old emacs versions are not supported by upstream:
+case $FLAVOR in
+ emacs|emacs19|emacs20|emacs21|xemacs21)
+ exit 0
+ ;;
+esac
echo install/${PACKAGE}: Handling install for emacsen flavor ${FLAVOR}
diff --git a/debian/golang-mode.emacsen-remove b/debian/golang-mode.emacsen-remove
index a56922eb6..42231d3c9 100644
--- a/debian/golang-mode.emacsen-remove
+++ b/debian/golang-mode.emacsen-remove
@@ -2,8 +2,14 @@
# /usr/lib/emacsen-common/packages/remove/golang-mode
FLAVOR=$1
PACKAGE=golang-mode
-if [ ${FLAVOR} != emacs ]; then
- echo remove/${PACKAGE}: purging byte-compiled files for ${FLAVOR}
- rm -rf /usr/share/${FLAVOR}/site-lisp/${PACKAGE}
-fi
+
+# A number of old emacs versions are not supported by upstream:
+case $FLAVOR in
+ emacs|emacs19|emacs20|emacs21|xemacs21)
+ exit 0
+ ;;
+esac
+
+echo remove/${PACKAGE}: purging byte-compiled files for ${FLAVOR}
+rm -rf /usr/share/${FLAVOR}/site-lisp/${PACKAGE}
exit 0