summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Stapelberg <michael@stapelberg.de>2013-07-11 19:46:51 +0200
committerMichael Stapelberg <michael@stapelberg.de>2013-07-11 20:25:59 +0200
commit40c893b1dc1599ae9013fc527b15cb93623c5a0e (patch)
tree8e7e950f33b9ceee45d7441c2856a83e85d4e505
parentbaa9e8fb94689f6b9daff5304966cf53ee12f4ef (diff)
downloadgolang-40c893b1dc1599ae9013fc527b15cb93623c5a0e.tar.gz
install runtime/cgo into golang-godebian/2%1.1.1-3
-rw-r--r--debian/changelog11
-rwxr-xr-xdebian/rules10
2 files changed, 21 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 6b8d49507..82bc612fe 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,14 @@
+golang (2:1.1.1-3) unstable; urgency=low
+
+ * Ship */runtime/cgo.a in golang-go to ensure it is present. It can only be
+ used on the native architecture anyway (cannot be used when
+ cross-compiling), so having it in golang-go-$GOOS-$GOARCH is not
+ necessary. Even worse, since these packages are arch: all, they will be
+ built precisely once, and only the runtime/cgo.a for the buildd’s native
+ arch will be present. (Closes: #715025)
+
+ -- Michael Stapelberg <stapelberg@debian.org> Thu, 11 Jul 2013 20:25:52 +0200
+
golang (2:1.1.1-2) unstable; urgency=low
[ James Page ]
diff --git a/debian/rules b/debian/rules
index 0959d236e..83726813a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -59,6 +59,16 @@ override_dh_install:
[ "$$arch" = "amd64" ] && [ "$$os" = "linux" ] && echo "pkg/linux_amd64_race /usr/lib/go/pkg" >> debian/golang-go-$$os-$$arch.install; \
echo "golang-go-$$os-$$arch: arch-independent-package-contains-binary-or-object" > debian/golang-go-$$os-$$arch.lintian-overrides; \
${FOR_GO_ARCH_END}
+ # Install the native runtime/cgo.a to the golang-go package.
+ # runtime/cgo is only built for the native architecture, but the
+ # golang-go-OS-ARCH packages are built on one particular buildd, which
+ # might either be i386 or amd64.
+ echo "listing of $$(pwd):"; ls -hlR .
+ echo "listing of GOBIN: ($(GOBIN))"; ls -hlR $(GOBIN)
+ for file in $$(cd pkg/ && ls */runtime/cgo.a); do \
+ mkdir -p $(CURDIR)/debian/golang-go/usr/lib/go/pkg/$$(dirname $$file); \
+ mv pkg/$$file $(CURDIR)/debian/golang-go/usr/lib/go/pkg/$$file; \
+ done
dh_install --fail-missing
# Replace jquery in the html documentation with a symlink to libjs-jquery.
-rm $(CURDIR)/debian/golang-doc/usr/share/doc/golang-doc/html/jquery.js && \