summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Stapelberg <michael@stapelberg.de>2013-07-17 18:34:48 +0200
committerMichael Stapelberg <michael@stapelberg.de>2013-07-17 19:15:23 +0200
commitdf33f38de90060c4c5ee3b0b70d4e5d037fc3641 (patch)
tree572de653023b1f43d2ae37c2476159eb64623e80
parentc05ea968b0d51cb8e3a767642d5342de46a3a82d (diff)
downloadgolang-df33f38de90060c4c5ee3b0b70d4e5d037fc3641.tar.gz
Disable stripping, it breaks go binaries on some architecturesdebian/2%1.1.1-4
-rw-r--r--debian/changelog8
-rw-r--r--debian/control24
-rw-r--r--debian/control.base24
-rwxr-xr-xdebian/rules3
4 files changed, 10 insertions, 49 deletions
diff --git a/debian/changelog b/debian/changelog
index 82bc612fe..e39e023f3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+golang (2:1.1.1-4) unstable; urgency=low
+
+ * Disable stripping, it breaks go binaries on some architectures. This drops
+ the golang-dbg package which would be empty now. (Thanks Robie Basak)
+ (Closes: #717172)
+
+ -- Michael Stapelberg <stapelberg@debian.org> Wed, 17 Jul 2013 19:15:18 +0200
+
golang (2:1.1.1-3) unstable; urgency=low
* Ship */runtime/cgo.a in golang-go to ensure it is present. It can only be
diff --git a/debian/control b/debian/control
index cd33321a0..cbd1206e3 100644
--- a/debian/control
+++ b/debian/control
@@ -76,30 +76,6 @@ Description: Go programming language compiler - documentation
language. You can view the formatted documentation by running "godoc
--http=:6060", and then visiting http://localhost:6060/doc/install.html.
-Package: golang-dbg
-Replaces: golang-weekly-dbg
-Conflicts: golang-weekly-dbg
-Provides: golang-weekly-dbg
-Architecture: i386 amd64 armel armhf
-Depends: ${misc:Depends}, golang-go (= ${binary:Version})
-Recommends: gdb
-Section: debug
-Priority: extra
-Description: Go programming language compiler - debug files
- The Go programming language is an open source project to make
- programmers more productive. Go is expressive, concise, clean, and
- efficient. Its concurrency mechanisms make it easy to write programs
- that get the most out of multicore and networked machines, while its
- novel type system enables flexible and modular program construction.
- Go compiles quickly to machine code yet has the convenience of
- garbage collection and the power of run-time reflection. It's a
- fast, statically typed, compiled language that feels like a
- dynamically typed, interpreted language.
- .
- This package provides the debug symbols for Google's Go tool
- chain binaries (assembler, compiler, linker) needed for properly
- debugging errors in the tool chain with gdb.
-
Package: golang
Replaces: golang-weekly
Conflicts: golang-weekly
diff --git a/debian/control.base b/debian/control.base
index c7a8a0b42..a0a7334e6 100644
--- a/debian/control.base
+++ b/debian/control.base
@@ -75,30 +75,6 @@ Description: Go programming language compiler - documentation
language. You can view the formatted documentation by running "godoc
--http=:6060", and then visiting http://localhost:6060/doc/install.html.
-Package: golang-dbg
-Replaces: golang-weekly-dbg
-Conflicts: golang-weekly-dbg
-Provides: golang-weekly-dbg
-Architecture: i386 amd64 armel armhf
-Depends: ${misc:Depends}, golang-go (= ${binary:Version})
-Recommends: gdb
-Section: debug
-Priority: extra
-Description: Go programming language compiler - debug files
- The Go programming language is an open source project to make
- programmers more productive. Go is expressive, concise, clean, and
- efficient. Its concurrency mechanisms make it easy to write programs
- that get the most out of multicore and networked machines, while its
- novel type system enables flexible and modular program construction.
- Go compiles quickly to machine code yet has the convenience of
- garbage collection and the power of run-time reflection. It's a
- fast, statically typed, compiled language that feels like a
- dynamically typed, interpreted language.
- .
- This package provides the debug symbols for Google's Go tool
- chain binaries (assembler, compiler, linker) needed for properly
- debugging errors in the tool chain with gdb.
-
Package: golang
Replaces: golang-weekly
Conflicts: golang-weekly
diff --git a/debian/rules b/debian/rules
index 83726813a..694ddfee9 100755
--- a/debian/rules
+++ b/debian/rules
@@ -95,7 +95,8 @@ override_dh_install:
find $(CURDIR)/debian/golang-go/usr/lib/go/pkg -exec touch -r $(CURDIR)/debian/golang-go/usr/lib/go/pkg {} \;
override_dh_strip:
- dh_strip -X".a" -Xgoinstall -Xgodoc -Xgoyacc -Xbin/cgo -Xebnflint -Xgofix -Xgofmt -Xgovet -Xgotest --dbg-package=$(PACKAGE)-dbg
+ # strip disabled as golang upstream doesn't support it and it makes go
+ # crash. See http://bugs.debian.org/717172
override_dh_prep:
dh_prep