summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Stapelberg <stapelberg@debian.org>2013-12-02 19:01:28 +0100
committerMichael Stapelberg <stapelberg@debian.org>2013-12-03 09:44:00 +0100
commit1e78b232e28c799ad364fe2205ba40aa164751b2 (patch)
treef368dc8f901d12e2775e6de532a9517146d0ffb7
parentf9686b2f44872e1980da2be44574ec56f7644eb3 (diff)
downloadgolang-1e78b232e28c799ad364fe2205ba40aa164751b2.tar.gz
golang-src: install test/, golang-go.tools (and possibly others) use it
-rw-r--r--debian/golang-src.install1
-rwxr-xr-xdebian/rules6
2 files changed, 4 insertions, 3 deletions
diff --git a/debian/golang-src.install b/debian/golang-src.install
index 8885d62db..f034ba538 100644
--- a/debian/golang-src.install
+++ b/debian/golang-src.install
@@ -1 +1,2 @@
src /usr/share/go/
+test /usr/share/go/
diff --git a/debian/rules b/debian/rules
index c66207aa2..436b9e938 100755
--- a/debian/rules
+++ b/debian/rules
@@ -75,9 +75,6 @@ override_dh_install:
# Replace jquery in the html documentation with a symlink to libjs-jquery.
-rm $(CURDIR)/debian/golang-doc/usr/share/doc/golang-doc/html/jquery.js && \
ln -s /usr/share/javascript/jquery/jquery.min.js $(CURDIR)/debian/golang-doc/usr/share/doc/golang-doc/html/jquery.js
- # Remove testdata and tests from installed src directory
- find $(CURDIR)/debian/golang-src/usr/share/go/src -type d -name testdata -prune -execdir rm -rf {} \;
- find $(CURDIR)/debian/golang-src/usr/share/go/src -type f -name '*_test.go' -delete
# Remove .syso files of the race detector; it is not used yet and the files are arch-dependent.
find $(CURDIR)/debian/golang-src/usr/share/go/src/pkg/runtime/race -type f -name '*.syso' -delete
# Remove Plan9 rc(1) scripts
@@ -105,6 +102,9 @@ override_dh_prep:
override_dh_builddeb:
dh_builddeb -- -Zxz
+override_dh_shlibdeps:
+ dh_shlibdeps -Xtestdata -Xtest
+
debian/build.stamp:
rm -f debian/build.stamp
mkdir -p $(GOBIN)