summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEvan Shaw <chickencha@gmail.com>2010-04-23 00:43:59 +1000
committerEvan Shaw <chickencha@gmail.com>2010-04-23 00:43:59 +1000
commit290a00cb1fd8823b727aeeaadf9cba7e1e7a39d3 (patch)
tree57e0e820ac34db9fcb9a98002bcf3f2fdb46ac31
parentbda084bc07c5c13a5ff5526424e469f777736a3e (diff)
downloadgolang-290a00cb1fd8823b727aeeaadf9cba7e1e7a39d3.tar.gz
vector: Don't always regenerate {int,string}vector.go
R=golang-dev, adg CC=golang-dev http://codereview.appspot.com/917042 Committer: Andrew Gerrand <adg@golang.org>
-rw-r--r--src/pkg/container/vector/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/pkg/container/vector/Makefile b/src/pkg/container/vector/Makefile
index 1f58f7bba..ffd8937a7 100644
--- a/src/pkg/container/vector/Makefile
+++ b/src/pkg/container/vector/Makefile
@@ -11,6 +11,8 @@ GOFILES=\
stringvector.go\
vector.go\
+include ../../../Make.pkg
+
generate: vector.go vector_test.go
< vector.go cat\
| gofmt -r='Vector -> IntVector'\
@@ -65,5 +67,3 @@ generate: vector.go vector_test.go
| gofmt -r='TestIter -> TestStrIter'\
| gofmt -r='TestVectorData -> TestStrVectorData'\
> stringvector_test.go
-
-include ../../../Make.pkg