summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRuss Cox <rsc@golang.org>2009-10-14 18:08:10 -0700
committerRuss Cox <rsc@golang.org>2009-10-14 18:08:10 -0700
commit3e916d927d418cbeca49e50077f99c88dc7751d7 (patch)
tree00952921c702b3e708c4b0085da2c1ccbe9dd680
parent746fb9c39aa121b957c85a9242f9c29379fb72fc (diff)
downloadgolang-3e916d927d418cbeca49e50077f99c88dc7751d7.tar.gz
delete one cgo playpen
R=r DELTA=111 (0 added, 111 deleted, 0 changed) OCL=35739 CL=35744
-rw-r--r--usr/rsc/fib/6c.c20
-rw-r--r--usr/rsc/fib/Makefile36
-rw-r--r--usr/rsc/fib/gcc.c34
-rw-r--r--usr/rsc/fib/go.go8
-rw-r--r--usr/rsc/fib/main.go13
5 files changed, 0 insertions, 111 deletions
diff --git a/usr/rsc/fib/6c.c b/usr/rsc/fib/6c.c
deleted file mode 100644
index 23ed84638..000000000
--- a/usr/rsc/fib/6c.c
+++ /dev/null
@@ -1,20 +0,0 @@
-// Copyright 2009 The Go Authors. All rights reserved.
-// Use of this source code is governed by a BSD-style
-// license that can be found in the LICENSE file.
-
-#include "runtime.h"
-#include "cgocall.h"
-
-// turn on ffi
-#pragma dynld initcgo initcgo "libcgo.so"
-#pragma dynld cgo cgo "libcgo.so"
-
-// pull in fib from fib.so
-#pragma dynld extern_c_fib fib "fib.so"
-void (*extern_c_fib)(void*);
-
-void
-fibĀ·Fib(int32 n, int32, int32)
-{
- cgocall(extern_c_fib, &n);
-}
diff --git a/usr/rsc/fib/Makefile b/usr/rsc/fib/Makefile
deleted file mode 100644
index 0597633aa..000000000
--- a/usr/rsc/fib/Makefile
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 2009 The Go Authors. All rights reserved.
-# Use of this source code is governed by a BSD-style
-# license that can be found in the LICENSE file.
-
-# FFI demo
-
-all: fib.a fib.so
-
-gcc.o: gcc.c
- gcc -fPIC -O2 -o gcc.o -c gcc.c
-
-fib.so: gcc.o
- gcc -shared -o fib.so gcc.o -L$(GOROOT)/pkg/$(GOOS)_$(GOARCH) -lcgo
-
-fib.a: 6c.6 go.6
- gopack grc fib.a 6c.6 go.6
-
-6c.6: 6c.c
- 6c -FVw -I$(GOROOT)/src/pkg/runtime 6c.c
-
-go.6: go.go
- 6g go.go
-
-PKG=$(GOROOT)/pkg/$(GOOS)_$(GOARCH)
-
-install: $(PKG)/fib.so $(PKG)/fib.a
-
-$(PKG)/fib.so: fib.so
- cp fib.so $@
-
-$(PKG)/fib.a: fib.a
- cp fib.a $@
-
-clean:
- rm -f *.6 *.o *.so *.a
-
diff --git a/usr/rsc/fib/gcc.c b/usr/rsc/fib/gcc.c
deleted file mode 100644
index a89839031..000000000
--- a/usr/rsc/fib/gcc.c
+++ /dev/null
@@ -1,34 +0,0 @@
-// Copyright 2009 The Go Authors. All rights reserved.
-// Use of this source code is governed by a BSD-style
-// license that can be found in the LICENSE file.
-
-#include <stdint.h>
-
-typedef int32_t int32;
-
-static int32
-fib1(int32 n)
-{
- int32 a, b, t;
-
- a = 0;
- b = 1;
- for(; n>0; n--) {
- t = a;
- a = b;
- b += t;
- }
- return a;
-}
-
-void
-fib(void *v)
-{
- struct { // 6g func(n int) int
- int32 n;
- int32 pad;
- int32 ret;
- } *args = v;
-
- args->ret = fib1(args->n);
-}
diff --git a/usr/rsc/fib/go.go b/usr/rsc/fib/go.go
deleted file mode 100644
index 8145974f1..000000000
--- a/usr/rsc/fib/go.go
+++ /dev/null
@@ -1,8 +0,0 @@
-// Copyright 2009 The Go Authors. All rights reserved.
-// Use of this source code is governed by a BSD-style
-// license that can be found in the LICENSE file.
-
-package fib
-
-func Fib(n int) int
-
diff --git a/usr/rsc/fib/main.go b/usr/rsc/fib/main.go
deleted file mode 100644
index 3ac5d5914..000000000
--- a/usr/rsc/fib/main.go
+++ /dev/null
@@ -1,13 +0,0 @@
-// Copyright 2009 The Go Authors. All rights reserved.
-// Use of this source code is governed by a BSD-style
-// license that can be found in the LICENSE file.
-
-package main
-
-import "fib"
-
-func main() {
- for i := 0; i < 10; i++ {
- println(fib.Fib(i));
- }
-}