summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Stapelberg <stapelberg@debian.org>2013-05-14 19:33:44 +0200
committerMichael Stapelberg <michael@stapelberg.de>2013-05-14 19:43:09 +0200
commit915f72c2bc7812fdac9a0f4f2a52160ebc5821a3 (patch)
tree006ef9025da7dc880b99b056ecb4ee57b9b59712
parentf4baf0dd7391f4a67aefda3cfd2582e852a5c358 (diff)
downloadgolang-915f72c2bc7812fdac9a0f4f2a52160ebc5821a3.tar.gz
remove the long obsolete goinstall debconf question/config file
-rw-r--r--debian/README.Debian9
-rw-r--r--debian/changelog4
-rw-r--r--debian/golang-go.config20
-rw-r--r--debian/golang-go.postinst61
-rw-r--r--debian/golang-go.templates24
-rw-r--r--debian/patches/005-goinstall_dont_call_home_by_default.patch22
-rw-r--r--debian/patches/009-goinstall_can_install_to_GOPATH.patch13
-rw-r--r--debian/patches/010-goinstall_check_conf.patch28
-rw-r--r--debian/patches/series2
-rw-r--r--debian/po/POTFILES.in1
-rw-r--r--debian/po/cs.po56
-rw-r--r--debian/po/da.po56
-rw-r--r--debian/po/de.po58
-rw-r--r--debian/po/es.po84
-rw-r--r--debian/po/fr.po57
-rw-r--r--debian/po/it.po59
-rw-r--r--debian/po/nl.po58
-rw-r--r--debian/po/pl.po61
-rw-r--r--debian/po/pt.po70
-rw-r--r--debian/po/ru.po60
-rw-r--r--debian/po/sv.po58
-rw-r--r--debian/po/templates.pot50
22 files changed, 16 insertions, 895 deletions
diff --git a/debian/README.Debian b/debian/README.Debian
deleted file mode 100644
index 5eb699d99..000000000
--- a/debian/README.Debian
+++ /dev/null
@@ -1,9 +0,0 @@
- == Installation of additional packages with goinstall ==
-
-Debian's goinstall was modified to not install dependencies by
-default, because it tries to recompile system libraries, which fails.
-If you want to use goinstall you are probably better using golang-go
-installed in your home, because goinstall is not very FHS friendly
-now.
-
- -- Ondřej Surý <ondrej@debian.org>, Fri, 18 Feb 2011 15:38:47 +0100
diff --git a/debian/changelog b/debian/changelog
index b7250b8ad..4b7b20330 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,10 @@
golang (2:1.1-1) unstable; urgency=low
* New upstream release: Go 1.1!
+ * Remove the long obsolete goinstall debconf question and config file.
+ goinstall does not exist anymore since a long time.
+ This also obsoletes the need for any translations
+ (Closes: #685923, #692478)
-- Michael Stapelberg <stapelberg@debian.org> Tue, 14 May 2013 18:52:37 +0200
diff --git a/debian/golang-go.config b/debian/golang-go.config
index 30fe76ffa..f71492181 100644
--- a/debian/golang-go.config
+++ b/debian/golang-go.config
@@ -2,22 +2,8 @@
set -e
-conffile=/etc/golang/goinstall.conf
-
. /usr/share/debconf/confmodule
-if [ -f $conffile ] ; then
- if grep -q DASHBOARD $conffile; then
- :;
- fi
- . $conffile
- if [ "$DASHBOARD" = "yes" ] ; then
- DASHBOARD=true
- else
- DASHBOARD=false
- fi
- db_set golang-go/dashboard "$DASHBOARD"
-fi
-
-db_input high golang-go/dashboard || [ $? -eq 30 ]
-db_go || true
+# Cleanup old debconf dashboard question that was removed in golang-go 2:1.1
+# -- 2013-05-14 stapelberg
+db_purge
diff --git a/debian/golang-go.postinst b/debian/golang-go.postinst
index 9ef650615..2f5bd34fb 100644
--- a/debian/golang-go.postinst
+++ b/debian/golang-go.postinst
@@ -1,66 +1,23 @@
#!/bin/sh
-# Load debconf variables
-. /usr/share/debconf/confmodule
-
confdir=/etc/golang
conffile=$confdir/goinstall.conf
set -e
-if [ -e $conffile ] ; then
- # Fetch current values.
- . $conffile
-fi
-
-# Get this setting from debconf. It was set based on the content of
-# /etc/golang/goinstall.conf in the 'config' script, so it should be
-# safe to ignore the value fetched by loading the file above. This
-# should allow for using debconf to reconfigure the package.
-db_get golang-go/dashboard || true
-if [ "$RET" = "yes" ] || [ "$RET" = "YES" ] || [ "$RET" = "true" ]; then
- DASHBOARD="yes"
-else
- DASHBOARD="no"
-fi
-
-generate_conffile() {
- if [ ! -d $confdir ]; then
- mkdir $confdir
- fi
- cat <<-EOF >$conffile
- # Config file for goinstall tool.
- #
- # To change this file, use:
- # dpkg-reconfigure golang-go
- #
- # You can also edit it by hand, if you so choose.
-
- DASHBOARD="$DASHBOARD"
- EOF
+. /usr/share/debconf/confmodule
- # Make sure user nobody can read the file.
- chmod a+r $conffile
-}
+# Cleanup old debconf dashboard question that was removed in golang-go 2:1.1
+# -- 2013-05-14 stapelberg
+db_purge
case "$1" in
configure)
- if [ ! -e $conffile ]; then
- generate_conffile
- else
- # Replace only if the content changed, to avoid changing the
- # config file date when no change was done.
- sedopts=" \
- s/^DASHBOARD=.*$/DASHBOARD=\"$DASHBOARD\"/; \
- "
- if sed "$sedopts" < $conffile > $conffile.new &&
- ! cmp $conffile $conffile.new > /dev/null; then
- mv $conffile.new $conffile
- # Make sure user nobody can read the file.
- chmod a+r $conffile
- else
- rm $conffile.new
- fi
+ # Remove obsolete goinstall.conf.
+ # -- 2013-05-14 stapelberg
+ if [ -e $conffile ]; then
+ rm -f $conffile
+ rmdir /etc/golang || true
fi
# Very ugly hack to set timestamps same as /usr/bin/go
find /usr/lib/go/pkg -exec touch -r /usr/bin/go {} \;
diff --git a/debian/golang-go.templates b/debian/golang-go.templates
deleted file mode 100644
index 8ec7bd3fc..000000000
--- a/debian/golang-go.templates
+++ /dev/null
@@ -1,24 +0,0 @@
-# These templates have been reviewed by the debian-l10n-english
-# team
-#
-# If modifications/additions/rewording are needed, please ask
-# debian-l10n-english@lists.debian.org for advice.
-#
-# Even minor modifications require translation updates and such
-# changes should be coordinated with translators and reviewers.
-
-Template: golang-go/dashboard
-Type: boolean
-Default: true
-_Description: Report installation of public packages to Go Dashboard?
- The goinstall program reports the successful installation of the public Go
- packages to godashboard.appspot.com, which increments a count associated
- with the package and the time of its most recent installation. This mechanism
- powers the package list at the Go Dashboard, allowing Go programmers to
- learn about popular packages that might be worth looking at.
- .
- If you choose to participate, each successful
- installation will be reported to the Go Dashboard.
- .
- This choice can be modified by running "dpkg-reconfigure
- golang-go".
diff --git a/debian/patches/005-goinstall_dont_call_home_by_default.patch b/debian/patches/005-goinstall_dont_call_home_by_default.patch
deleted file mode 100644
index b0866a59a..000000000
--- a/debian/patches/005-goinstall_dont_call_home_by_default.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/src/cmd/goinstall/main.go
-+++ b/src/cmd/goinstall/main.go
-@@ -38,7 +38,7 @@ var (
- schemeRe = regexp.MustCompile(`^[a-z]+://`)
-
- allpkg = flag.Bool("a", false, "install all previously installed packages")
-- reportToDashboard = flag.Bool("dashboard", true, "report public packages at "+dashboardURL)
-+ reportToDashboard = flag.Bool("dashboard", false, "report public packages at "+dashboardURL)
- update = flag.Bool("u", false, "update already-downloaded packages")
- doInstall = flag.Bool("install", true, "build and install")
- clean = flag.Bool("clean", false, "clean the package directory before installing")
---- a/src/cmd/goinstall/doc.go
-+++ b/src/cmd/goinstall/doc.go
-@@ -15,7 +15,7 @@ Usage:
- Flags and default settings:
- -a=false install all previously installed packages
- -clean=false clean the package directory before installing
-- -dashboard=true tally public packages on godashboard.appspot.com
-+ -dashboard=false tally public packages on godashboard.appspot.com
- -install=true build and install the package and its dependencies
- -nuke=false remove the target object and clean before installing
- -u=false update already-downloaded packages
diff --git a/debian/patches/009-goinstall_can_install_to_GOPATH.patch b/debian/patches/009-goinstall_can_install_to_GOPATH.patch
deleted file mode 100644
index 026b41d0a..000000000
--- a/debian/patches/009-goinstall_can_install_to_GOPATH.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/src/cmd/goinstall/main.go
-+++ b/src/cmd/goinstall/main.go
-@@ -121,6 +121,10 @@ func main() {
- }
- readPackageList()
-
-+ if os.Getuid() != 0 && os.Getenv("GOPATH") == "" {
-+ fmt.Fprintf(os.Stderr, "%s: set $GOPATH to the directory you want packages installed to if you get permission denied error\n", argv0)
-+ }
-+
- // special case - "unsafe" is already installed
- visit["unsafe"] = done
-
diff --git a/debian/patches/010-goinstall_check_conf.patch b/debian/patches/010-goinstall_check_conf.patch
deleted file mode 100644
index 64657a484..000000000
--- a/debian/patches/010-goinstall_check_conf.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- a/src/cmd/goinstall/main.go
-+++ b/src/cmd/goinstall/main.go
-@@ -38,7 +38,7 @@ var (
- schemeRe = regexp.MustCompile(`^[a-z]+://`)
-
- allpkg = flag.Bool("a", false, "install all previously installed packages")
-- reportToDashboard = flag.Bool("dashboard", true, "report public packages at "+dashboardURL)
-+ reportToDashboard *bool
- update = flag.Bool("u", false, "update already-downloaded packages")
- doGofix = flag.Bool("fix", false, "gofix each package before building it")
- doInstall = flag.Bool("install", true, "build and install")
-@@ -48,6 +48,16 @@ var (
- verbose = flag.Bool("v", false, "verbose")
- )
-
-+func init() {
-+ d := true
-+ b, err := ioutil.ReadFile("/etc/golang/goinstall.conf")
-+ if err == nil {
-+ re := regexp.MustCompile(`(^|\n)DASHBOARD="[nN][oO]"($|\n)`)
-+ d = !re.Match(b)
-+ }
-+ reportToDashboard = flag.Bool("dashboard", d, "report public packages at "+dashboardURL)
-+}
-+
- type status int // status for visited map
- const (
- unvisited status = iota
diff --git a/debian/patches/series b/debian/patches/series
index b628f2ded..f8377bd57 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -4,8 +4,6 @@
#003-set_correct_runpath.patch
#006-fix_kfreebsd_build.patch
#007-use_native_dynamic_linker_on_kfreebsd.patch
-#009-goinstall_can_install_to_GOPATH.patch
-#010-goinstall_check_conf.patch
#011-__FreeBSD_kernel__.patch
#012-sigfillset_kFreeBSD.patch
#013-kFreeBSD-AI_MASK.patch
diff --git a/debian/po/POTFILES.in b/debian/po/POTFILES.in
deleted file mode 100644
index 3e70bb3d9..000000000
--- a/debian/po/POTFILES.in
+++ /dev/null
@@ -1 +0,0 @@
-[type: gettext/rfc822deb] golang-go.templates
diff --git a/debian/po/cs.po b/debian/po/cs.po
deleted file mode 100644
index dc2311755..000000000
--- a/debian/po/cs.po
+++ /dev/null
@@ -1,56 +0,0 @@
-# Czech PO debconf template translation of golang.
-# Copyright (C) 2012 Michal Simunek <michal.simunek@gmail.com>
-# This file is distributed under the same license as the golang package.
-# Michal Simunek <michal.simunek@gmail.com>, 2012.
-#
-msgid ""
-msgstr ""
-"Project-Id-Version: golang 1:60.3-3\n"
-"Report-Msgid-Bugs-To: golang@packages.debian.org\n"
-"POT-Creation-Date: 2012-03-17 08:50+0100\n"
-"PO-Revision-Date: 2012-03-23 17:01+0100\n"
-"Last-Translator: Michal Simunek <michal.simunek@gmail.com>\n"
-"Language-Team: Czech <debian-l10n-czech@lists.debian.org>\n"
-"Language: cs\n"
-"MIME-Version: 1.0\n"
-"Content-Type: text/plain; charset=utf-8\n"
-"Content-Transfer-Encoding: 8bit\n"
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid "Report installation of public packages to Go Dashboard?"
-msgstr "Nahlašovat instalaci veřejných balíčků do Go Dashboard?"
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid ""
-"The goinstall program reports the successful installation of the public Go "
-"packages to godashboard.appspot.com, which increments a count associated "
-"with the package and the time of its most recent installation. This "
-"mechanism powers the package list at the Go Dashboard, allowing Go "
-"programmers to learn about popular packages that might be worth looking at."
-msgstr ""
-"Program goinstall nahlašuje úspěšné instalace veřejných Go balíčků do "
-"godashboard.appspot.com, který zvýší počet jeho instalací a čas poslední "
-"instalace. Tento mechanizmus vytváří přehled o balíčcích v Go Dashboard, "
-"umožňuje tak Go programátorům, aby se dozvěděly o oblíbených balíčcích, "
-"kterým stojí za to se věnovat."
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid ""
-"If you choose to participate, each successful installation will be reported "
-"to the Go Dashboard."
-msgstr ""
-"Rozhodnete-li se k účasti, každá úspěšná instalace se nahlásí do Go "
-"Dashboard."
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid ""
-"This choice can be modified by running \"dpkg-reconfigure golang-go\"."
-msgstr "Tuto volbu lze změnit spuštěním \"dpkg-reconfigure golang-go\"."
diff --git a/debian/po/da.po b/debian/po/da.po
deleted file mode 100644
index f6d1e3cd3..000000000
--- a/debian/po/da.po
+++ /dev/null
@@ -1,56 +0,0 @@
-# Danish translation golang.
-# Copyright (C) 2012 golang & nedenstående oversættere.
-# This file is distributed under the same license as the golang package.
-# Joe Hansen (joedalton2@yahoo.dk), 2012.
-#
-msgid ""
-msgstr ""
-"Project-Id-Version: golang\n"
-"Report-Msgid-Bugs-To: golang@packages.debian.org\n"
-"POT-Creation-Date: 2012-03-17 08:50+0100\n"
-"PO-Revision-Date: 2012-03-31 12:52+0000\n"
-"Last-Translator: Joe Hansen <joedalton2@yahoo.dk>\n"
-"Language-Team: Danish <debian-l10n-danish@lists.debian.org>\n"
-"Language: da\n"
-"MIME-Version: 1.0\n"
-"Content-Type: text/plain; charset=UTF-8\n"
-"Content-Transfer-Encoding: 8bit\n"
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid "Report installation of public packages to Go Dashboard?"
-msgstr "Rapporter installation af offentlige pakker til Go Dashboard?"
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid ""
-"The goinstall program reports the successful installation of the public Go "
-"packages to godashboard.appspot.com, which increments a count associated "
-"with the package and the time of its most recent installation. This "
-"mechanism powers the package list at the Go Dashboard, allowing Go "
-"programmers to learn about popular packages that might be worth looking at."
-msgstr ""
-"Programmet goinstall rapporterer installationen af de offentlige Go-pakker "
-"til godashboard.appspot.com, som trinvis øger en optælling forbundet med "
-"pakken og tidspunktet for dets seneste installation. Denne mekanisme styrer "
-"pakkelisten for Go Dashboard, så at Go-programmører kan få viden om populære "
-"pakker, som kan være interessante at kigge på."
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid ""
-"If you choose to participate, each successful installation will be reported "
-"to the Go Dashboard."
-msgstr ""
-"Hvis du vælger at deltage, så vil goinstall rapportere hver succesfuld "
-"installation til Go Dashboard."
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid ""
-"This choice can be modified by running \"dpkg-reconfigure golang-go\"."
-msgstr "Dette valg kan ændres ved at køre »dpkg-reconfigure golang-go«."
diff --git a/debian/po/de.po b/debian/po/de.po
deleted file mode 100644
index 6a9f0f81b..000000000
--- a/debian/po/de.po
+++ /dev/null
@@ -1,58 +0,0 @@
-# German debconf translation of golang.
-# This file is distributed under the same license as the golang package.
-# Copyright (C) 2009, 2010, The Go Authors.
-# Copyright (C) of this file 2012 Chris Leick <c.leick@vollbio.de>.
-#
-msgid ""
-msgstr ""
-"Project-Id-Version: golang 2012.01.27-3\n"
-"Report-Msgid-Bugs-To: golang@packages.debian.org\n"
-"POT-Creation-Date: 2012-03-17 08:50+0100\n"
-"PO-Revision-Date: 2012-03-01 18:44+0100\n"
-"Last-Translator: Chris Leick <c.leick@vollbio.de>\n"
-"Language-Team: German <debian-l10n-german@lists.debian.org>\n"
-"Language: de\n"
-"MIME-Version: 1.0\n"
-"Content-Type: text/plain; charset=UTF-8\n"
-"Content-Transfer-Encoding: 8bit\n"
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid "Report installation of public packages to Go Dashboard?"
-msgstr "Installation öffentlicher Pakete an das Go Dashboard melden?"
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid ""
-"The goinstall program reports the successful installation of the public Go "
-"packages to godashboard.appspot.com, which increments a count associated "
-"with the package and the time of its most recent installation. This "
-"mechanism powers the package list at the Go Dashboard, allowing Go "
-"programmers to learn about popular packages that might be worth looking at."
-msgstr ""
-"Das Programm Goinstall meldet die erfolgreiche Installation der öffentlichen "
-"Go-Pakete an godashboard.appspot.com, das einen Zähler erhöht, der mit dem "
-"Paket verbunden ist sowie die Zeit der aktuellsten Installation. Dieser "
-"Mechanismus befeuert die Paketliste auf dem Go Dashboard, die es Go-"
-"Programmierern ermöglicht, etwas über populäre Pakete zu lernen, die es Wert "
-"sind, einen Blick darauf zu werfen."
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid ""
-"If you choose to participate, each successful installation will be reported "
-"to the Go Dashboard."
-msgstr ""
-"Falls Sie auswählen teilzunehmen, wird jede erfolgreiche Installation an das "
-"Go Dashboard gemeldet."
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid ""
-"This choice can be modified by running \"dpkg-reconfigure golang-go\"."
-msgstr ""
-"Diese Auswahl kann durch Ausführen von »dpkg-reconfigure golang-go« geändert werden."
diff --git a/debian/po/es.po b/debian/po/es.po
deleted file mode 100644
index 19c7edc28..000000000
--- a/debian/po/es.po
+++ /dev/null
@@ -1,84 +0,0 @@
-# golang po-debconf translation to Spanish
-# Copyright (C) 2010 Software in the Public Interest
-# This file is distributed under the same license as the golang package.
-#
-# Changes:
-# - Initial translation
-# Camaleón <noelamac@gmail.com>, 2012
-#
-# - Updates
-#
-#
-# Traductores, si no conocen el formato PO, merece la pena leer la
-# documentación de gettext, especialmente las secciones dedicadas a este
-# formato, por ejemplo ejecutando:
-# info -n '(gettext)PO Files'
-# info -n '(gettext)Header Entry'
-#
-# Equipo de traducción al español, por favor lean antes de traducir
-# los siguientes documentos:
-#
-# - El proyecto de traducción de Debian al español
-# http://www.debian.org/intl/spanish/
-# especialmente las notas y normas de traducción en
-# http://www.debian.org/intl/spanish/notas
-#
-# - La guía de traducción de po's de debconf:
-# /usr/share/doc/po-debconf/README-trans
-# o http://www.debian.org/intl/l10n/po-debconf/README-trans
-#
-msgid ""
-msgstr ""
-"Project-Id-Version: golang 1:60.3-3\n"
-"Report-Msgid-Bugs-To: golang@packages.debian.org\n"
-"POT-Creation-Date: 2012-03-17 08:50+0100\n"
-"PO-Revision-Date: 2012-03-25 11:55+0200\n"
-"Last-Translator: Camaleón <noelamac@gmail.com>\n"
-"Language-Team: Debian Spanish <debian-l10n-spanish@lists.debian.org>\n"
-"Language: \n"
-"MIME-Version: 1.0\n"
-"Content-Type: text/plain; charset=UTF-8\n"
-"Content-Transfer-Encoding: 8bit\n"
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid "Report installation of public packages to Go Dashboard?"
-msgstr ""
-"¿Desea informar sobre la instalación de paquetes públicos en Go Dashboard?"
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid ""
-"The goinstall program reports the successful installation of the public Go "
-"packages to godashboard.appspot.com, which increments a count associated "
-"with the package and the time of its most recent installation. This "
-"mechanism powers the package list at the Go Dashboard, allowing Go "
-"programmers to learn about popular packages that might be worth looking at."
-msgstr ""
-"El programa goinstall envía informes a «godashboard.appspot.com» de los "
-"paquetes públicos de Go instalados correctamente. Esta información hace que "
-"se incremente el contador asociado al paquete así como la fecha almacenada "
-"de su instalación más reciente. Este mecanismo es el que se utiliza dentro "
-"de la lista de paquetes en el panel de Go Dashboard y ayuda a los "
-"programadores de Go a conocer cuáles son los paquetes más populares que "
-"puede merecer la pena revisar."
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid ""
-"If you choose to participate, each successful installation will be reported "
-"to the Go Dashboard."
-msgstr ""
-"Si decide participar, se informará de cada instalación satisfactoria en Go "
-"Dashboard."
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid ""
-"This choice can be modified by running \"dpkg-reconfigure golang-go\"."
-msgstr ""
-"Puede modificar esta elección ejecutando «dpkg-reconfigure golang-go»."
diff --git a/debian/po/fr.po b/debian/po/fr.po
deleted file mode 100644
index 91b031472..000000000
--- a/debian/po/fr.po
+++ /dev/null
@@ -1,57 +0,0 @@
-# Translation of golang debconf templates to French.
-# Copyright (C) 2012, French l10n team <debian-l10n-french@lists.debian.org>
-# This file is distributed under the same license as the golang package.
-# François LANKAR <lankarf@gmail.com>, 2012.
-#
-msgid ""
-msgstr ""
-"Project-Id-Version: golang\n"
-"Report-Msgid-Bugs-To: golang@packages.debian.org\n"
-"POT-Creation-Date: 2012-03-17 08:50+0100\n"
-"PO-Revision-Date: 2012-03-01 18:36+0100\n"
-"Last-Translator: François LANKAR <lankarf@gmail.com>\n"
-"Language-Team: FRENCH <debian-l10n-french@lists.debian.org>\n"
-"Language: \n"
-"MIME-Version: 1.0\n"
-"Content-Type: text/plain; charset=UTF-8\n"
-"Content-Transfer-Encoding: 8bit\n"
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid "Report installation of public packages to Go Dashboard?"
-msgstr "Signaler les installations des paquets publics à Go Dashboard?"
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid ""
-"The goinstall program reports the successful installation of the public Go "
-"packages to godashboard.appspot.com, which increments a count associated "
-"with the package and the time of its most recent installation. This "
-"mechanism powers the package list at the Go Dashboard, allowing Go "
-"programmers to learn about popular packages that might be worth looking at."
-msgstr ""
-"Le programme goinstall signale l'installation réussie des paquets publics Go "
-"à godashboard.appspot.com, ce qui incrémente un compteur associé au paquet "
-"et le moment de son installation la plus récente. Ce mécanisme envoie la "
-"liste des paquets à Go Dashboard, ce qui permet aux développeurs Go de "
-"connaître les paquets populaires éventuellement intéressants à regarder."
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid ""
-"If you choose to participate, each successful installation will be reported "
-"to the Go Dashboard."
-msgstr ""
-"Si vous choisissez de participer, chaque installation réussie sera signalée "
-"à Go Dashboard."
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid ""
-"This choice can be modified by running \"dpkg-reconfigure golang-go\"."
-msgstr ""
-"Ce choix peut être modifié avec la commande « dpkg-reconfigure golang-go »."
diff --git a/debian/po/it.po b/debian/po/it.po
deleted file mode 100644
index 049378cb0..000000000
--- a/debian/po/it.po
+++ /dev/null
@@ -1,59 +0,0 @@
-# Italian description of golang debconf messages.
-# Copyright (C) 2012, golang package copyright holder.
-# This file is distributed under the same license as the golang package.
-# Beatrice Torracca <beatricet@libero.it>, 2012.
-msgid ""
-msgstr ""
-"Project-Id-Version: golang\n"
-"Report-Msgid-Bugs-To: golang@packages.debian.org\n"
-"POT-Creation-Date: 2012-03-17 08:50+0100\n"
-"PO-Revision-Date: 2012-03-15 20:28+0200\n"
-"Last-Translator: Beatrice Torracca <beatricet@libero.it>\n"
-"Language-Team: Italian <debian-l10n-italian@lists.debian.org>\n"
-"Language: it\n"
-"MIME-Version: 1.0\n"
-"Content-Type: text/plain; charset=UTF-8\n"
-"Content-Transfer-Encoding: 8bit\n"
-"Plural-Forms: nplurals=2; plural=(n != 1);\n"
-"X-Generator: Virtaal 0.7.1\n"
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid "Report installation of public packages to Go Dashboard?"
-msgstr "Segnalare a Go Dashboard l'installazione di pacchetti pubblici?"
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid ""
-"The goinstall program reports the successful installation of the public Go "
-"packages to godashboard.appspot.com, which increments a count associated "
-"with the package and the time of its most recent installation. This "
-"mechanism powers the package list at the Go Dashboard, allowing Go "
-"programmers to learn about popular packages that might be worth looking at."
-msgstr ""
-"Il programma goinstall segnala le installazioni dei pacchetti pubblici Go "
-"avvenute con successo a godashboard.appshot.com, che incrementa un contatore "
-"associato con il pacchetto e aggiorna l'orario della sua installazione più "
-"recente. Questo meccanismo è alla base dell'elenco dei pacchetti di Go "
-"Dashboard e permette ai programmatori Go di conoscere i pacchetti popolari "
-"che vale la pena tenere d'occhio."
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid ""
-"If you choose to participate, each successful installation will be reported "
-"to the Go Dashboard."
-msgstr ""
-"Se si sceglie di partecipare, ogni installazione avvenuta con successo sarà "
-"segnalata a Go Dashboard."
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid ""
-"This choice can be modified by running \"dpkg-reconfigure golang-go\"."
-msgstr ""
-"Questa scelta può essere modificata eseguendo «dpkg-reconfigure golang-go»."
diff --git a/debian/po/nl.po b/debian/po/nl.po
deleted file mode 100644
index f396fdcd5..000000000
--- a/debian/po/nl.po
+++ /dev/null
@@ -1,58 +0,0 @@
-# Dutch translation of golang debconf templates.
-# Copyright (C) 2012 THE PACKAGE'S COPYRIGHT HOLDER
-# This file is distributed under the same license as the golang package.
-# Jeroen Schot <schot@a-eskwadraat.nl>, 2012.
-#
-msgid ""
-msgstr ""
-"Project-Id-Version: golang 1:60.3-3\n"
-"Report-Msgid-Bugs-To: golang@packages.debian.org\n"
-"POT-Creation-Date: 2012-03-17 08:50+0100\n"
-"PO-Revision-Date: 2012-03-19 10:27+0100\n"
-"Last-Translator: Jeroen Schot <schot@a-eskwadraat.nl>\n"
-"Language-Team: Debian l10n Dutch <debian-l10n-dutch@lists.debian.org>\n"
-"Language: nl\n"
-"MIME-Version: 1.0\n"
-"Content-Type: text/plain; charset=UTF-8\n"
-"Content-Transfer-Encoding: 8bit\n"
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid "Report installation of public packages to Go Dashboard?"
-msgstr "Installatie van publieke pakketten melden bij het Go Dashboard?"
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid ""
-"The goinstall program reports the successful installation of the public Go "
-"packages to godashboard.appspot.com, which increments a count associated "
-"with the package and the time of its most recent installation. This "
-"mechanism powers the package list at the Go Dashboard, allowing Go "
-"programmers to learn about popular packages that might be worth looking at."
-msgstr ""
-"Het programma goinstall meldt de succesvolle installatie van de publieke Go-"
-"pakketten bij godashboard.appspot.com, welke voor pakketten een teller en de "
-"tijd van laatste installatie bijhoudt. Dit is de basis van de pakketlijst "
-"van het Go Dasboard en brengt Go-programmeurs op de hoogte van populaire "
-"pakketten die interessant kunnen zijn."
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid ""
-"If you choose to participate, each successful installation will be reported "
-"to the Go Dashboard."
-msgstr ""
-"Als u ervoor kiest om mee te doen zal elke succesvolle installatie worden "
-"gemeld bij het Go Dashboard."
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid ""
-"This choice can be modified by running \"dpkg-reconfigure golang-go\"."
-msgstr ""
-"U kunt uw keuze altijd nog herzien via het commando \"dpkg-reconfigure "
-"golang-go\"."
diff --git a/debian/po/pl.po b/debian/po/pl.po
deleted file mode 100644
index 5ff99808f..000000000
--- a/debian/po/pl.po
+++ /dev/null
@@ -1,61 +0,0 @@
-# Translation of golang debconf templates to Polish.
-# Copyright (C) 2012
-# This file is distributed under the same license as the golang package.
-#
-# Michał Kułach <michal.kulach@gmail.com>, 2012.
-msgid ""
-msgstr ""
-"Project-Id-Version: golang\n"
-"Report-Msgid-Bugs-To: golang@packages.debian.org\n"
-"POT-Creation-Date: 2012-03-17 08:50+0100\n"
-"PO-Revision-Date: 2012-03-01 19:15+0100\n"
-"Last-Translator: Michał Kułach <michal.kulach@gmail.com>\n"
-"Language-Team: Polish <debian-l10n-polish@lists.debian.org>\n"
-"Language: pl\n"
-"MIME-Version: 1.0\n"
-"Content-Type: text/plain; charset=UTF-8\n"
-"Content-Transfer-Encoding: 8bit\n"
-"X-Generator: Lokalize 1.2\n"
-"Plural-Forms: nplurals=3; plural=(n==1 ? 0 : n%10>=2 && n%10<=4 && (n%100<10 "
-"|| n%100>=20) ? 1 : 2);\n"
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid "Report installation of public packages to Go Dashboard?"
-msgstr "Odnotowywać instalację publicznych pakietów na Go Dashboard?"
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid ""
-"The goinstall program reports the successful installation of the public Go "
-"packages to godashboard.appspot.com, which increments a count associated "
-"with the package and the time of its most recent installation. This "
-"mechanism powers the package list at the Go Dashboard, allowing Go "
-"programmers to learn about popular packages that might be worth looking at."
-msgstr ""
-"Program goinstall odnotowuje pomyślne instalacje publicznych pakietów Go pod "
-"adresem godashboard.appspot.com, zwiększając wynik związany z pakietem i "
-"czasem jego ostatnich instalacji. Mechanizm ten jest używany przez listę "
-"pakietów na Go Dashboard, pozwalając programistom Go dowiedzieć się o "
-"popularnych pakietach, którymi, być może, warto się zainteresować."
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid ""
-"If you choose to participate, each successful installation will be reported "
-"to the Go Dashboard."
-msgstr ""
-"Jeśli ta opcja zostanie aktywowana, każda pomyślna instalacja zostanie "
-"odnotowana na Go Dashboard."
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid ""
-"This choice can be modified by running \"dpkg-reconfigure golang-go\"."
-msgstr ""
-"Można zmienić swój wybór później, wykonując polecenie \"dpkg-reconfigure "
-"golang-go\"."
diff --git a/debian/po/pt.po b/debian/po/pt.po
deleted file mode 100644
index e9bb01b7c..000000000
--- a/debian/po/pt.po
+++ /dev/null
@@ -1,70 +0,0 @@
-# golang's portuguese debconf messages
-# Copyright (C) 2012
-# This file is distributed under the same license as the golang package.
-# Pedro Ribeiro <p.m42.ribeiro@gmail.com>, 2012
-#
-msgid ""
-msgstr ""
-"Project-Id-Version: golang\n"
-"Report-Msgid-Bugs-To: \n"
-"POT-Creation-Date: 2012-05-21 16:29+0200\n"
-"PO-Revision-Date: 2012-05-28 23:09+0000\n"
-"Last-Translator: Pedro Ribeiro <p.m42.ribeiro@gmail.com>, 2012\n"
-"Language-Team: Portuguese <traduz@debianpt.org>\n"
-"Language: \n"
-"MIME-Version: 1.0\n"
-"Content-Type: text/plain; charset=UTF-8\n"
-"Content-Transfer-Encoding: 8bit\n"
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid "Report installation of public packages to Go Dashboard?"
-msgstr ""
-"Relatar a instalação de pacotes públicos no Painel de Instrumentos do Go?"
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-#| msgid ""
-#| "goinstall reports the successful installation of the public packages to "
-#| "godashboard.appspot.com, which increments a count associated with the "
-#| "package and the time of its most recent installation. This mechanism "
-#| "powers the package list at the Go Dashboard, allowing Go programmers to "
-#| "learn about popular packages that might be worth looking at."
-msgid ""
-"The goinstall program reports the successful installation of the public Go "
-"packages to godashboard.appspot.com, which increments a count associated "
-"with the package and the time of its most recent installation. This "
-"mechanism powers the package list at the Go Dashboard, allowing Go "
-"programmers to learn about popular packages that might be worth looking at."
-msgstr ""
-"O programa goinstall relata o sucesso de instalação dos pacotes públicos do "
-"Go para godashboard.appspot.com, o que incrementa um contador associado com "
-"o pacote e a data da instalação mais recente. Este mecanismo alimenta a "
-"lista de pacotes no Painel de Instrumentos do Go, permitindo que os "
-"programadores Go saibam quais os pacotes mais populares a que vale a pena "
-"dar atenção."
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-#| msgid ""
-#| "If you choose to participate, the goinstall will report each successful "
-#| "installation to the Go Dashboard."
-msgid ""
-"If you choose to participate, each successful installation will be reported "
-"to the Go Dashboard."
-msgstr ""
-"Se escolher participar, cada instalação bem sucedida será reportada ao "
-"Painel de Instrumentos do Go."
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-#| msgid ""
-#| "This choice can be later modified by running \"dpkg-reconfigure golang-go"
-#| "\"."
-msgid "This choice can be modified by running \"dpkg-reconfigure golang-go\"."
-msgstr ""
-"Esta escolha pode ser modificada executando \"dpkg-reconfigure golang-go\"."
diff --git a/debian/po/ru.po b/debian/po/ru.po
deleted file mode 100644
index be37747c7..000000000
--- a/debian/po/ru.po
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
-# This file is distributed under the same license as the golang package.
-#
-# Yuri Kozlov <yuray@komyakino.ru>, 2012.
-msgid ""
-msgstr ""
-"Project-Id-Version: golang 2012.01.27-3\n"
-"Report-Msgid-Bugs-To: golang@packages.debian.org\n"
-"POT-Creation-Date: 2012-03-17 08:50+0100\n"
-"PO-Revision-Date: 2012-03-03 12:36+0400\n"
-"Last-Translator: Yuri Kozlov <yuray@komyakino.ru>\n"
-"Language-Team: Russian <debian-l10n-russian@lists.debian.org>\n"
-"Language: \n"
-"MIME-Version: 1.0\n"
-"Content-Type: text/plain; charset=UTF-8\n"
-"Content-Transfer-Encoding: 8bit\n"
-"X-Generator: Lokalize 1.0\n"
-"Plural-Forms: nplurals=3; plural=(n%10==1 && n%100!=11 ? 0 : n%10>=2 && n"
-"%10<=4 && (n%100<10 || n%100>=20) ? 1 : 2);\n"
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid "Report installation of public packages to Go Dashboard?"
-msgstr "Сообщать об установке общедоступных пакетов в Go Dashboard?"
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid ""
-"The goinstall program reports the successful installation of the public Go "
-"packages to godashboard.appspot.com, which increments a count associated "
-"with the package and the time of its most recent installation. This "
-"mechanism powers the package list at the Go Dashboard, allowing Go "
-"programmers to learn about popular packages that might be worth looking at."
-msgstr ""
-"Программа goinstall отправляет информацию об успешной установке "
-"общедоступных пакетов Go на сайт godashboard.appspot.com, что увеличивает "
-"счётчик, связанный с пакетом, и обновляет время его последней установки. "
-"Данный механизм поддерживает список пакетов в Go Dashboard, позволяя "
-"программистам Go узнать о популярных пакетах, на которые стоит обратить "
-"внимание."
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid ""
-"If you choose to participate, each successful installation will be reported "
-"to the Go Dashboard."
-msgstr ""
-"Если вы ответите утвердительно, то о каждой успешной установке будет "
-"сообщено Go Dashboard."
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid ""
-"This choice can be modified by running \"dpkg-reconfigure golang-go\"."
-msgstr ""
-"Данный ответ можно изменить с помощью команды «dpkg-reconfigure golang-go»."
diff --git a/debian/po/sv.po b/debian/po/sv.po
deleted file mode 100644
index 5105554c0..000000000
--- a/debian/po/sv.po
+++ /dev/null
@@ -1,58 +0,0 @@
-# Translation of golang debconf template to Swedish
-# Copyright (C) 2012 Martin Bagge <brother@bsnet.se>
-# This file is distributed under the same license as the golang package.
-#
-# Martin Bagge <brother@bsnet.se>, 2012
-msgid ""
-msgstr ""
-"Project-Id-Version: golang\n"
-"Report-Msgid-Bugs-To: golang@packages.debian.org\n"
-"POT-Creation-Date: 2012-03-17 08:50+0100\n"
-"PO-Revision-Date: 2012-03-03 01:10+0100\n"
-"Last-Translator: Martin Bagge / brother <brother@bsnet.se>\n"
-"Language-Team: Swedish <debian-l10n-swedish@lists.debian.org>\n"
-"Language: \n"
-"MIME-Version: 1.0\n"
-"Content-Type: text/plain; charset=UTF-8\n"
-"Content-Transfer-Encoding: 8bit\n"
-"X-Poedit-Language: Swedish\n"
-"X-Poedit-Country: Sweden\n"
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid "Report installation of public packages to Go Dashboard?"
-msgstr "Rapportera installation av publika paket till Go-panelen?"
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid ""
-"The goinstall program reports the successful installation of the public Go "
-"packages to godashboard.appspot.com, which increments a count associated "
-"with the package and the time of its most recent installation. This "
-"mechanism powers the package list at the Go Dashboard, allowing Go "
-"programmers to learn about popular packages that might be worth looking at."
-msgstr ""
-"Programmet goinstall rapporterar lyckades installationer av de publika Go-"
-"paketen till godashboard.appspot.com vilket ökar en räknare knuten till "
-"paketet och en tidsstämpel för senaste lyckade installationen. Denna "
-"funktion aktiverar paketlistan på Go-panelen och gör att Go-programmerare "
-"kan få reda på vilka paket som kan vara värda att titta extra på."
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid ""
-"If you choose to participate, each successful installation will be reported "
-"to the Go Dashboard."
-msgstr ""
-"Väljer du att delta kommer alla lyckade installationer att rapporteras till "
-"Go-panelen."
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid ""
-"This choice can be modified by running \"dpkg-reconfigure golang-go\"."
-msgstr "Detta val kan ändras genom att köra \"dpkg-reconfigure golang-go\"."
diff --git a/debian/po/templates.pot b/debian/po/templates.pot
deleted file mode 100644
index abd5c1429..000000000
--- a/debian/po/templates.pot
+++ /dev/null
@@ -1,50 +0,0 @@
-# SOME DESCRIPTIVE TITLE.
-# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
-# This file is distributed under the same license as the PACKAGE package.
-# FIRST AUTHOR <EMAIL@ADDRESS>, YEAR.
-#
-#, fuzzy
-msgid ""
-msgstr ""
-"Project-Id-Version: golang\n"
-"Report-Msgid-Bugs-To: golang@packages.debian.org\n"
-"POT-Creation-Date: 2012-03-17 08:50+0100\n"
-"PO-Revision-Date: YEAR-MO-DA HO:MI+ZONE\n"
-"Last-Translator: FULL NAME <EMAIL@ADDRESS>\n"
-"Language-Team: LANGUAGE <LL@li.org>\n"
-"Language: \n"
-"MIME-Version: 1.0\n"
-"Content-Type: text/plain; charset=CHARSET\n"
-"Content-Transfer-Encoding: 8bit\n"
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid "Report installation of public packages to Go Dashboard?"
-msgstr ""
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid ""
-"The goinstall program reports the successful installation of the public Go "
-"packages to godashboard.appspot.com, which increments a count associated "
-"with the package and the time of its most recent installation. This "
-"mechanism powers the package list at the Go Dashboard, allowing Go "
-"programmers to learn about popular packages that might be worth looking at."
-msgstr ""
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid ""
-"If you choose to participate, each successful installation will be reported "
-"to the Go Dashboard."
-msgstr ""
-
-#. Type: boolean
-#. Description
-#: ../golang-go.templates:2001
-msgid ""
-"This choice can be modified by running \"dpkg-reconfigure golang-go\"."
-msgstr ""