summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOndřej Surý <ondrej@sury.org>2012-04-10 11:12:56 +0200
committerOndřej Surý <ondrej@sury.org>2012-04-11 18:36:13 +0200
commitb7252247eeefea7637a10b03c3e76b01773bedb3 (patch)
treedeac1eff580abc616d788f545359cf0832274da4
parent8cf3e44fdd54b5247f8ba418680841f1abdf9d06 (diff)
downloadgolang-b7252247eeefea7637a10b03c3e76b01773bedb3.tar.gz
Fix upstream version botched by my packaging scripts
-rw-r--r--debian/patches/000-fix_upstream_version.patch5
-rw-r--r--debian/patches/series1
-rwxr-xr-xdebian/rules4
3 files changed, 7 insertions, 3 deletions
diff --git a/debian/patches/000-fix_upstream_version.patch b/debian/patches/000-fix_upstream_version.patch
new file mode 100644
index 000000000..03b52ef8f
--- /dev/null
+++ b/debian/patches/000-fix_upstream_version.patch
@@ -0,0 +1,5 @@
+--- a/VERSION
++++ b/VERSION
+@@ -1 +1 @@
+-release.r60 9481
++go1
diff --git a/debian/patches/series b/debian/patches/series
index df1559b36..6b6a7610a 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,4 @@
+000-fix_upstream_version.patch
001-allow_IPv4_on_IPv6_sockets.patch
#003-set_correct_runpath.patch
#006-fix_kfreebsd_build.patch
diff --git a/debian/rules b/debian/rules
index a32fe31c2..96106224f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -131,10 +131,8 @@ get-orig-source:
cd "$(GOLANG_ORIG_DIR)"; \
hg pull; \
hg update "$(REV)"; \
- VERSION=$$(hg identify -t -r"$(REV)" | perl -e '<> =~ /go([\d.]+)/; print "$$1"'); \
+ VERSION=$$(cat VERSION | perl -e '<> =~ /go([\d.]+)/; print "$$1"'); \
hg archive -tfiles -r"$(REV)" -X'.hg*' -X'doc/talks/go_talk-20091030.pdf' "$(CURDIR)/../$(PACKAGE)-$$VERSION/"; \
- src/version.bash -save; \
- cp VERSION "$(CURDIR)/../$(PACKAGE)-$$VERSION/"; \
cd ..; \
tar -czf "$(CURDIR)/../$(PACKAGE)_$$VERSION.orig.tar.gz" "$(PACKAGE)-$$VERSION/"; \
rm -rf "$(CURDIR)/../$(PACKAGE)-$$VERSION/"; \