summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor Pashev <pashev.igor@gmail.com>2015-07-17 22:35:35 +0300
committerIgor Pashev <pashev.igor@gmail.com>2015-07-17 22:35:35 +0300
commitd2601165ca410cb75fa5084a39d8e2b2c11ebd82 (patch)
tree19279eda6d265e155d4e2377d914208a5b1472a8
parent4ee90514e98535427abaffc96ffa1a54d42f4fec (diff)
downloadgolang-d2601165ca410cb75fa5084a39d8e2b2c11ebd82.tar.gz
Support illumos
-rw-r--r--debian/changelog1
-rw-r--r--debian/control40
-rw-r--r--debian/control.base4
-rwxr-xr-xdebian/rules6
4 files changed, 46 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 733fc443a..7cd3a74e3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,6 +2,7 @@ golang (2:1.4.2-3+dyson1) UNRELEASED; urgency=medium
* Package for Dyson
* Added debian/patches/dyson-EOF.patch
+ * Added support for illumos-amd64 (d/rules, d/control*)
-- Igor Pashev <pashev.igor@gmail.com> Fri, 17 Jul 2015 22:22:51 +0300
diff --git a/debian/control b/debian/control
index dfde545f6..0ccce7ef0 100644
--- a/debian/control
+++ b/debian/control
@@ -14,7 +14,7 @@ Standards-Version: 3.9.6
Homepage: http://golang.org/
Package: golang-go
-Architecture: i386 amd64 armel armhf
+Architecture: i386 amd64 armel armhf illumos-amd64
Depends: ${shlibs:Depends}, ${misc:Depends}, ${perl:Depends},
golang-src (>= ${source:Version}),
golang-go-linux-${go:Hostarch} (= ${source:Version})
@@ -42,7 +42,7 @@ Replaces: golang-weekly-src, golang-go (<< 2:1-3~)
Conflicts: golang-weekly-src
Provides: golang-weekly-src
Breaks: golang-go (<< 2:1-3~)
-Architecture: i386 amd64 armel armhf
+Architecture: i386 amd64 armel armhf illumos-amd64
Depends: ${shlibs:Depends}, ${misc:Depends}
Description: Go programming language compiler - source files
The Go programming language is an open source project to make
@@ -103,6 +103,42 @@ Description: Go programming language compiler - metapackage
This package is a metapackage that, when installed, guarantees
that (most of) a full Go development environment is installed.
+Package: golang-go-solaris-amd64
+Architecture: all
+Depends: ${shlibs:Depends}, ${misc:Depends}, ${perl:Depends}
+Breaks: golang-go (<< 2:1.1-2)
+Replaces: golang-go (<< 2:1.1-2)
+Description: Go standard library compiled for solaris_amd64
+ This package contains the Go standard library,
+ compiled for solaris_amd64.
+ .
+ This package is just one of a number of packages, each providing the Go
+ standard library for a specific operating system/architecture combination.
+ Go supports cross-compilation, so each of these packages is useful on any
+ architecture.
+ .
+ The files contained in this package are independent of the host architecture,
+ that is, you can use golang-go-linux-amd64 to generate a binary for
+ linux_amd64, even though you are executing the Go compiler on linux_386.
+
+Package: golang-go-solaris-386
+Architecture: all
+Depends: ${shlibs:Depends}, ${misc:Depends}, ${perl:Depends}
+Breaks: golang-go (<< 2:1.1-2)
+Replaces: golang-go (<< 2:1.1-2)
+Description: Go standard library compiled for solaris_386
+ This package contains the Go standard library,
+ compiled for solaris_386.
+ .
+ This package is just one of a number of packages, each providing the Go
+ standard library for a specific operating system/architecture combination.
+ Go supports cross-compilation, so each of these packages is useful on any
+ architecture.
+ .
+ The files contained in this package are independent of the host architecture,
+ that is, you can use golang-go-linux-amd64 to generate a binary for
+ linux_amd64, even though you are executing the Go compiler on linux_386.
+
Package: golang-go-linux-amd64
Architecture: i386 amd64 armel armhf
Depends: ${shlibs:Depends}, ${misc:Depends}, ${perl:Depends}
diff --git a/debian/control.base b/debian/control.base
index 94e2823fd..3ac9dde5c 100644
--- a/debian/control.base
+++ b/debian/control.base
@@ -13,7 +13,7 @@ Standards-Version: 3.9.6
Homepage: http://golang.org/
Package: golang-go
-Architecture: i386 amd64 armel armhf
+Architecture: i386 amd64 armel armhf illumos-amd64
Depends: ${shlibs:Depends}, ${misc:Depends}, ${perl:Depends},
golang-src (>= ${source:Version}),
golang-go-linux-${go:Hostarch} (= ${source:Version})
@@ -41,7 +41,7 @@ Replaces: golang-weekly-src, golang-go (<< 2:1-3~)
Conflicts: golang-weekly-src
Provides: golang-weekly-src
Breaks: golang-go (<< 2:1-3~)
-Architecture: i386 amd64 armel armhf
+Architecture: i386 amd64 armel armhf illumos-amd64
Depends: ${shlibs:Depends}, ${misc:Depends}
Description: Go programming language compiler - source files
The Go programming language is an open source project to make
diff --git a/debian/rules b/debian/rules
index b2545c220..048a271dc 100755
--- a/debian/rules
+++ b/debian/rules
@@ -11,7 +11,7 @@ bindir := /bin
# We loop over supported operating systems and architectures multiple times,
# so these two variables contain a centralized version of that code.
# The variables $$os and $$arch can be used inside such a loop.
-FOR_GO_ARCH := for os in $$(echo linux freebsd windows darwin netbsd); do \
+FOR_GO_ARCH := for os in $$(echo solaris linux freebsd windows darwin netbsd); do \
archs="amd64 386"; \
[ "$$os" = "linux" ] || [ "$$os" = "freebsd" ] && archs="amd64 arm 386"; \
for arch in $$(echo $$archs); do
@@ -160,6 +160,8 @@ ifeq ($(DEB_BUILD_ARCH_OS), kfreebsd)
GOHOSTOS := freebsd
else ifeq ($(DEB_BUILD_ARCH_OS), linux)
GOHOSTOS := linux
+else ifeq ($(DEB_BUILD_ARCH_OS), illumos)
+ GOHOSTOS := solaris
else
$(error unrecongized build host kernel $(DEB_BUILD_ARCH_OS)!)
endif
@@ -169,6 +171,8 @@ ifeq ($(DEB_HOST_ARCH_OS), kfreebsd)
GOOS := freebsd
else ifeq ($(DEB_HOST_ARCH_OS), linux)
GOOS := linux
+else ifeq ($(DEB_HOST_ARCH_OS), illumos)
+ GOOS := solaris
else
$(error unrecognized kernel $(DEB_HOST_ARCH_OS)!)
endif