summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Stapelberg <stapelberg@debian.org>2014-06-19 09:23:41 +0200
committerMichael Stapelberg <stapelberg@debian.org>2014-06-19 09:25:21 +0200
commitd40f6cfdb511cc9449a425241954bd7192d43d21 (patch)
treeb79d8e6387de34ef4973e122736d62ddbdc22225
parent8fcc691d6fa80c9ddf38bf0d34b803bab0e421d5 (diff)
downloadgolang-d40f6cfdb511cc9449a425241954bd7192d43d21.tar.gz
update debian/changelog, drop patches merged upstreamdebian/2%1.3-1
-rw-r--r--debian/changelog8
-rw-r--r--debian/patches/add-src-pkg-debug-elf-testdata-hello.patch17
-rw-r--r--debian/patches/add-tar-xattr-support.patch175
-rw-r--r--debian/patches/series2
4 files changed, 6 insertions, 196 deletions
diff --git a/debian/changelog b/debian/changelog
index 7fb81ed46..ee78b469e 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,9 +1,13 @@
-golang (2:1.2.1-3) UNRELEASED; urgency=low
+golang (2:1.3-1) unstable; urgency=medium
+ * New upstream version.
+ * Drop patches merged upstream:
+ - debian/patches/add-tar-xattr-support.patch
+ - debian/patches/add-tar-xattr-support.patch
* Fix debian/watch (Thanks Tianon) (Closes: #748290)
* Remove dangling symlink /usr/lib/go/lib/godoc (Closes: #747968)
- -- Michael Stapelberg <stapelberg@debian.org> Fri, 16 May 2014 19:45:17 +0200
+ -- Michael Stapelberg <stapelberg@debian.org> Thu, 19 Jun 2014 09:23:36 +0200
golang (2:1.2.1-2) unstable; urgency=low
diff --git a/debian/patches/add-src-pkg-debug-elf-testdata-hello.patch b/debian/patches/add-src-pkg-debug-elf-testdata-hello.patch
deleted file mode 100644
index 4518bd157..000000000
--- a/debian/patches/add-src-pkg-debug-elf-testdata-hello.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Description: Source file to fix http://bugs.debian.org/716853
-Author: Michael Stapelberg <stapelberg@debian.org>
-Last-Update: 2013-12-31
-Forwarded: https://codereview.appspot.com/46780043
-
-Index: golang/src/pkg/debug/elf/testdata/hello.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ golang/src/pkg/debug/elf/testdata/hello.c 2013-12-31 18:25:09.268498582 +0100
-@@ -0,0 +1,7 @@
-+#include <stdio.h>
-+
-+void
-+main(int argc, char *argv[])
-+{
-+ printf("hello, world\n");
-+}
diff --git a/debian/patches/add-tar-xattr-support.patch b/debian/patches/add-tar-xattr-support.patch
deleted file mode 100644
index 904e0110d..000000000
--- a/debian/patches/add-tar-xattr-support.patch
+++ /dev/null
@@ -1,175 +0,0 @@
---- a/src/pkg/archive/tar/common.go
-+++ b/src/pkg/archive/tar/common.go
-@@ -57,6 +57,7 @@
- Devminor int64 // minor number of character or block device
- AccessTime time.Time // access time
- ChangeTime time.Time // status change time
-+ Xattrs map[string]string
- }
-
- // File name constants from the tar spec.
-@@ -189,6 +190,7 @@
- paxSize = "size"
- paxUid = "uid"
- paxUname = "uname"
-+ paxXattr = "SCHILY.xattr."
- paxNone = ""
- )
-
---- a/src/pkg/archive/tar/reader.go
-+++ b/src/pkg/archive/tar/reader.go
-@@ -139,8 +139,14 @@
- return err
- }
- hdr.Size = int64(size)
-+ default:
-+ if strings.HasPrefix(k, paxXattr) {
-+ if hdr.Xattrs == nil {
-+ hdr.Xattrs = make(map[string]string)
-+ }
-+ hdr.Xattrs[k[len(paxXattr):]] = v
-+ }
- }
--
- }
- return nil
- }
---- a/src/pkg/archive/tar/reader_test.go
-+++ b/src/pkg/archive/tar/reader_test.go
-@@ -161,6 +161,46 @@
- },
- },
- },
-+ {
-+ file: "testdata/xattrs.tar",
-+ headers: []*Header{
-+ {
-+ Name: "small.txt",
-+ Mode: 0644,
-+ Uid: 1000,
-+ Gid: 10,
-+ Size: 5,
-+ ModTime: time.Unix(1386065770, 448252320),
-+ Typeflag: '0',
-+ Uname: "alex",
-+ Gname: "wheel",
-+ AccessTime: time.Unix(1389782991, 419875220),
-+ ChangeTime: time.Unix(1389782956, 794414986),
-+ Xattrs: map[string]string{
-+ "user.key": "value",
-+ "user.key2": "value2",
-+ // Interestingly, selinux encodes the terminating null inside the xattr
-+ "security.selinux": "unconfined_u:object_r:default_t:s0\x00",
-+ },
-+ },
-+ {
-+ Name: "small2.txt",
-+ Mode: 0644,
-+ Uid: 1000,
-+ Gid: 10,
-+ Size: 11,
-+ ModTime: time.Unix(1386065770, 449252304),
-+ Typeflag: '0',
-+ Uname: "alex",
-+ Gname: "wheel",
-+ AccessTime: time.Unix(1389782991, 419875220),
-+ ChangeTime: time.Unix(1386065770, 449252304),
-+ Xattrs: map[string]string{
-+ "security.selinux": "unconfined_u:object_r:default_t:s0\x00",
-+ },
-+ },
-+ },
-+ },
- }
-
- func TestReader(t *testing.T) {
-@@ -180,7 +220,7 @@
- f.Close()
- continue testLoop
- }
-- if *hdr != *header {
-+ if !reflect.DeepEqual(*hdr, *header) {
- t.Errorf("test %d, entry %d: Incorrect header:\nhave %+v\nwant %+v",
- i, j, *hdr, *header)
- }
-@@ -253,7 +293,7 @@
- }
-
- // check the header
-- if *hdr != *headers[nread] {
-+ if !reflect.DeepEqual(*hdr, *headers[nread]) {
- t.Errorf("Incorrect header:\nhave %+v\nwant %+v",
- *hdr, headers[nread])
- }
-Binary files /dev/null and b/src/pkg/archive/tar/testdata/xattrs.tar differ
---- a/src/pkg/archive/tar/writer.go
-+++ b/src/pkg/archive/tar/writer.go
-@@ -236,6 +236,12 @@
- return tw.err
- }
-
-+ if allowPax {
-+ for k, v := range hdr.Xattrs {
-+ paxHeaders[paxXattr+k] = v
-+ }
-+ }
-+
- if len(paxHeaders) > 0 {
- if !allowPax {
- return errInvalidHeader
---- a/src/pkg/archive/tar/writer_test.go
-+++ b/src/pkg/archive/tar/writer_test.go
-@@ -10,6 +10,7 @@
- "io"
- "io/ioutil"
- "os"
-+ "reflect"
- "strings"
- "testing"
- "testing/iotest"
-@@ -338,6 +339,45 @@
- }
- }
-
-+func TestPaxXattrs(t *testing.T) {
-+ xattrs := map[string]string{
-+ "user.key": "value",
-+ }
-+
-+ // Create an archive with an xattr
-+ fileinfo, err := os.Stat("testdata/small.txt")
-+ if err != nil {
-+ t.Fatal(err)
-+ }
-+ hdr, err := FileInfoHeader(fileinfo, "")
-+ if err != nil {
-+ t.Fatalf("os.Stat: %v", err)
-+ }
-+ contents := "Kilts"
-+ hdr.Xattrs = xattrs
-+ var buf bytes.Buffer
-+ writer := NewWriter(&buf)
-+ if err := writer.WriteHeader(hdr); err != nil {
-+ t.Fatal(err)
-+ }
-+ if _, err = writer.Write([]byte(contents)); err != nil {
-+ t.Fatal(err)
-+ }
-+ if err := writer.Close(); err != nil {
-+ t.Fatal(err)
-+ }
-+ // Test that we can get the xattrs back out of the archive.
-+ reader := NewReader(&buf)
-+ hdr, err = reader.Next()
-+ if err != nil {
-+ t.Fatal(err)
-+ }
-+ if !reflect.DeepEqual(hdr.Xattrs, xattrs) {
-+ t.Fatalf("xattrs did not survive round trip: got %+v, want %+v",
-+ hdr.Xattrs, xattrs)
-+ }
-+}
-+
- func TestPAXHeader(t *testing.T) {
- medName := strings.Repeat("CD", 50)
- longName := strings.Repeat("AB", 100)
diff --git a/debian/patches/series b/debian/patches/series
deleted file mode 100644
index 0a51bc14f..000000000
--- a/debian/patches/series
+++ /dev/null
@@ -1,2 +0,0 @@
-add-src-pkg-debug-elf-testdata-hello.patch
-add-tar-xattr-support.patch