summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTianon Gravi <admwiggin@gmail.com>2015-01-15 12:51:00 -0700
committerTianon Gravi <admwiggin@gmail.com>2015-01-15 12:51:00 -0700
commitf971d23c25b6660e666da64eedec69e77b9abbd7 (patch)
tree95a2ba428d14c5f063f0e515aab4b2720aea9df6
parent2a0db60599fdd75b1bc3e297180fbe1282763759 (diff)
downloadgolang-f971d23c25b6660e666da64eedec69e77b9abbd7.tar.gz
Update to 1.4
-rw-r--r--debian/changelog10
-rw-r--r--debian/control26
-rw-r--r--debian/control.base26
-rw-r--r--debian/golang-mode.emacsen-compat1
-rw-r--r--debian/golang-mode.emacsen-install36
-rw-r--r--debian/golang-mode.emacsen-remove15
-rw-r--r--debian/golang-mode.emacsen-startup7
-rw-r--r--debian/golang-mode.install1
-rw-r--r--debian/kate-syntax-go.install1
-rw-r--r--debian/patches/0001-backport-delete-whole-line.patch65
-rw-r--r--debian/patches/0002-archive-tar-reuse-temporary-buffer-in-writeHeader.patch33
-rw-r--r--debian/patches/0003-archive-tar-reuse-temporary-buffer-in-readHeader.patch38
-rw-r--r--debian/patches/0004-archive-tar-fix-writing-of-pax-headers.patch82
-rw-r--r--debian/patches/series4
-rwxr-xr-xdebian/rules2
-rw-r--r--debian/vim-registry/vim-syntax-go.yaml8
-rw-r--r--debian/vim-syntax-go.install5
17 files changed, 11 insertions, 349 deletions
diff --git a/debian/changelog b/debian/changelog
index fe8d3d52a..57d1f4690 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+golang (2:1.4-1) experimental; urgency=low
+
+ * New upstream version (https://golang.org/doc/go1.4)
+ - all editor support files have been removed from misc/ upstream upstream,
+ so golang-mode, kate-syntax-go, and vim-syntax-go can no longer be
+ provided; see https://github.com/golang/go/wiki/IDEsAndTextEditorPlugins
+ for an upstream-maintained list of potential replacements
+
+ -- Tianon Gravi <admwiggin@gmail.com> Mon, 29 Dec 2014 20:58:38 +0000
+
golang (2:1.3.3-1) unstable; urgency=medium
* New upstream version (https://code.google.com/p/go/source/list?name=go1.3.3)
diff --git a/debian/control b/debian/control
index aca2e15ac..a3de30a03 100644
--- a/debian/control
+++ b/debian/control
@@ -103,32 +103,6 @@ Description: Go programming language compiler - metapackage
This package is a metapackage that, when installed, guarantees
that (most of) a full Go development environment is installed.
-Package: golang-mode
-Architecture: all
-Depends: ${misc:Depends}, emacs | emacsen, emacsen-common (>= 2.0.8)
-Conflicts: emacsen-common (<< 2.0.0)
-Suggests: golang-go
-Description: Go programming language - mode for GNU Emacs
- This package provides a GNU Emacs major mode for editing code in
- Google's Go programming language.
-
-Package: kate-syntax-go
-Architecture: all
-Depends: ${misc:Depends}, kate
-Suggests: golang-go
-Description: Go programming language - Kate highlighting syntax files
- This package provides syntax files for the Kate editor for editing code
- in Google's Go programming language.
-
-Package: vim-syntax-go
-Architecture: all
-Depends: ${misc:Depends}, vim
-Recommends: vim-addon-manager
-Suggests: golang-go
-Description: Go programming language - Vim highlighting syntax files
- This package provides syntax files for the Vim editor for editing code
- in Google's Go programming language.
-
Package: golang-go-linux-amd64
Architecture: i386 amd64 armel armhf
Depends: ${shlibs:Depends}, ${misc:Depends}, ${perl:Depends}
diff --git a/debian/control.base b/debian/control.base
index 99edc3b91..2d2f5aa85 100644
--- a/debian/control.base
+++ b/debian/control.base
@@ -101,29 +101,3 @@ Description: Go programming language compiler - metapackage
.
This package is a metapackage that, when installed, guarantees
that (most of) a full Go development environment is installed.
-
-Package: golang-mode
-Architecture: all
-Depends: ${misc:Depends}, emacs | emacsen, emacsen-common (>= 2.0.8)
-Conflicts: emacsen-common (<< 2.0.0)
-Suggests: golang-go
-Description: Go programming language - mode for GNU Emacs
- This package provides a GNU Emacs major mode for editing code in
- Google's Go programming language.
-
-Package: kate-syntax-go
-Architecture: all
-Depends: ${misc:Depends}, kate
-Suggests: golang-go
-Description: Go programming language - Kate highlighting syntax files
- This package provides syntax files for the Kate editor for editing code
- in Google's Go programming language.
-
-Package: vim-syntax-go
-Architecture: all
-Depends: ${misc:Depends}, vim
-Recommends: vim-addon-manager
-Suggests: golang-go
-Description: Go programming language - Vim highlighting syntax files
- This package provides syntax files for the Vim editor for editing code
- in Google's Go programming language.
diff --git a/debian/golang-mode.emacsen-compat b/debian/golang-mode.emacsen-compat
deleted file mode 100644
index 573541ac9..000000000
--- a/debian/golang-mode.emacsen-compat
+++ /dev/null
@@ -1 +0,0 @@
-0
diff --git a/debian/golang-mode.emacsen-install b/debian/golang-mode.emacsen-install
deleted file mode 100644
index c028dfdb1..000000000
--- a/debian/golang-mode.emacsen-install
+++ /dev/null
@@ -1,36 +0,0 @@
-#!/bin/sh -e
-# /usr/lib/emacsen-common/packages/install/golang-mode
-
-FLAVOR=$1
-PACKAGE=golang-mode
-
-# A number of old emacs versions are not supported by upstream:
-case $FLAVOR in
- emacs|emacs19|emacs20|emacs21|xemacs21)
- exit 0
- ;;
-esac
-
-echo install/${PACKAGE}: Handling install for emacsen flavor ${FLAVOR}
-
-# The byte-compiled files goes into the site-lisp directory.
-BCDIR=/usr/share/${FLAVOR}/site-lisp/${PACKAGE}
-install -m 755 -d ${BCDIR}
-
-# The elisp source files are in the generic site-list directory.
-SRCDIR=/usr/share/emacs/site-lisp/${PACKAGE}
-SRC=`find ${SRCDIR} -name '*.el' -exec basename '{}' ';'`
-
-# Prepare for byte-compiling the source files.
-cd ${BCDIR}
-ln -sf ${SRCDIR}/*.el .
-cat << EOF > path.el
-(setq load-path (cons "." load-path) byte-compile-warnings nil)
-EOF
-
-# Byte-compile elisp files.
-FLAGS="--no-site-file --no-init-file --batch -l path.el -f batch-byte-compile"
-${FLAVOR} ${FLAGS} ${SRC}
-rm -f path.el
-
-exit 0
diff --git a/debian/golang-mode.emacsen-remove b/debian/golang-mode.emacsen-remove
deleted file mode 100644
index 42231d3c9..000000000
--- a/debian/golang-mode.emacsen-remove
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/bin/sh -e
-# /usr/lib/emacsen-common/packages/remove/golang-mode
-FLAVOR=$1
-PACKAGE=golang-mode
-
-# A number of old emacs versions are not supported by upstream:
-case $FLAVOR in
- emacs|emacs19|emacs20|emacs21|xemacs21)
- exit 0
- ;;
-esac
-
-echo remove/${PACKAGE}: purging byte-compiled files for ${FLAVOR}
-rm -rf /usr/share/${FLAVOR}/site-lisp/${PACKAGE}
-exit 0
diff --git a/debian/golang-mode.emacsen-startup b/debian/golang-mode.emacsen-startup
deleted file mode 100644
index 5565b9a2e..000000000
--- a/debian/golang-mode.emacsen-startup
+++ /dev/null
@@ -1,7 +0,0 @@
-;; -*-emacs-lisp-*-
-
-(let ((path "/usr/share/emacs/site-lisp/golang-mode"))
- (when (file-exists-p path)
- (debian-pkg-add-load-path-item path)
- (require 'go-mode-load)))
-
diff --git a/debian/golang-mode.install b/debian/golang-mode.install
deleted file mode 100644
index 1453aa7b5..000000000
--- a/debian/golang-mode.install
+++ /dev/null
@@ -1 +0,0 @@
-misc/emacs/*.el usr/share/emacs/site-lisp/golang-mode/
diff --git a/debian/kate-syntax-go.install b/debian/kate-syntax-go.install
deleted file mode 100644
index 978ab81e3..000000000
--- a/debian/kate-syntax-go.install
+++ /dev/null
@@ -1 +0,0 @@
-misc/kate/go.xml /usr/share/kde4/apps/katepart/syntax/
diff --git a/debian/patches/0001-backport-delete-whole-line.patch b/debian/patches/0001-backport-delete-whole-line.patch
deleted file mode 100644
index be68c7f3a..000000000
--- a/debian/patches/0001-backport-delete-whole-line.patch
+++ /dev/null
@@ -1,65 +0,0 @@
-Description: flet is obsolete as of emacs 24.3
-Author: Dominik Honnef <dominikh@fork-bomb.org>
-Last-Update: 2014-07-03
-Forwarded: not-needed
-Origin: vendor, https://github.com/dominikh/go-mode.el/commit/6b5fe38
-
----
-
-diff --git i/misc/emacs/go-mode.el w/misc/emacs/go-mode.el
-index 6333ff9..6a2fcc0 100644
---- i/misc/emacs/go-mode.el
-+++ w/misc/emacs/go-mode.el
-@@ -33,29 +33,35 @@
- ;; - Use go--old-completion-list-style when using a plain list as the
- ;; collection for completing-read
- ;;
--;; - Use go--kill-whole-line instead of kill-whole-line (called
--;; kill-entire-line in XEmacs)
--;;
- ;; - Use go--position-bytes instead of position-bytes
- (defmacro go--xemacs-p ()
- `(featurep 'xemacs))
-
--(defalias 'go--kill-whole-line
-- (if (fboundp 'kill-whole-line)
-- #'kill-whole-line
-- #'kill-entire-line))
--
- ;; Delete the current line without putting it in the kill-ring.
- (defun go--delete-whole-line (&optional arg)
-- ;; Emacs uses both kill-region and kill-new, Xemacs only uses
-- ;; kill-region. In both cases we turn them into operations that do
-- ;; not modify the kill ring. This solution does depend on the
-- ;; implementation of kill-line, but it's the only viable solution
-- ;; that does not require to write kill-line from scratch.
-- (flet ((kill-region (beg end)
-- (delete-region beg end))
-- (kill-new (s) ()))
-- (go--kill-whole-line arg)))
-+ ;; Derived from `kill-whole-line'.
-+ ;; ARG is defined as for that function.
-+ (setq arg (or arg 1))
-+ (if (and (> arg 0)
-+ (eobp)
-+ (save-excursion (forward-visible-line 0) (eobp)))
-+ (signal 'end-of-buffer nil))
-+ (if (and (< arg 0)
-+ (bobp)
-+ (save-excursion (end-of-visible-line) (bobp)))
-+ (signal 'beginning-of-buffer nil))
-+ (cond ((zerop arg)
-+ (delete-region (progn (forward-visible-line 0) (point))
-+ (progn (end-of-visible-line) (point))))
-+ ((< arg 0)
-+ (delete-region (progn (end-of-visible-line) (point))
-+ (progn (forward-visible-line (1+ arg))
-+ (unless (bobp)
-+ (backward-char))
-+ (point))))
-+ (t
-+ (delete-region (progn (forward-visible-line 0) (point))
-+ (progn (forward-visible-line arg) (point))))))
-
- ;; declare-function is an empty macro that only byte-compile cares
- ;; about. Wrap in always false if to satisfy Emacsen without that
diff --git a/debian/patches/0002-archive-tar-reuse-temporary-buffer-in-writeHeader.patch b/debian/patches/0002-archive-tar-reuse-temporary-buffer-in-writeHeader.patch
deleted file mode 100644
index bd30f92a1..000000000
--- a/debian/patches/0002-archive-tar-reuse-temporary-buffer-in-writeHeader.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-Description: archive/tar: reuse temporary buffer in writeHeader
-Author: Cristian Staretu <unclejacksons@gmail.com>
-Last-Update: 2014-07-03
-Forwarded: not-needed
-Origin: vendor, https://code.google.com/p/go/source/detail?r=837348e418f33fc7a242f56dbe2feff829532526#
-
----
-
-diff -r c5f72a685e25 -r 837348e418f3 src/pkg/archive/tar/writer.go
---- a/src/pkg/archive/tar/writer.go Wed Jul 02 15:28:57 2014 -0700
-+++ b/src/pkg/archive/tar/writer.go Thu Jul 03 09:40:53 2014 +1000
-@@ -37,8 +37,9 @@
- nb int64 // number of unwritten bytes for current file entry
- pad int64 // amount of padding to write after current file entry
- closed bool
-- usedBinary bool // whether the binary numeric field extension was used
-- preferPax bool // use pax header instead of binary numeric header
-+ usedBinary bool // whether the binary numeric field extension was used
-+ preferPax bool // use pax header instead of binary numeric header
-+ hdrBuff [blockSize]byte // buffer to use in writeHeader
- }
-
- // NewWriter creates a new Writer writing to w.
-@@ -160,7 +161,8 @@
- // subsecond time resolution, but for now let's just capture
- // too long fields or non ascii characters
-
-- header := make([]byte, blockSize)
-+ header := tw.hdrBuff[:]
-+ copy(header, zeroBlock)
- s := slicer(header)
-
- // keep a reference to the filename to allow to overwrite it later if we detect that we can use ustar longnames instead of pax
diff --git a/debian/patches/0003-archive-tar-reuse-temporary-buffer-in-readHeader.patch b/debian/patches/0003-archive-tar-reuse-temporary-buffer-in-readHeader.patch
deleted file mode 100644
index 01da10797..000000000
--- a/debian/patches/0003-archive-tar-reuse-temporary-buffer-in-readHeader.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-Description: archive/tar: reuse temporary buffer in readHeader
-Author: Cristian Staretu <unclejacksons@gmail.com>
-Last-Update: 2014-07-03
-Forwarded: not-needed
-Origin: vendor, https://code.google.com/p/go/source/detail?r=17404efd6b02d4b3acd17070e3f89de97a145877
-
----
-
-diff -r 837348e418f3 -r 17404efd6b02 src/pkg/archive/tar/reader.go
---- a/src/pkg/archive/tar/reader.go Thu Jul 03 09:40:53 2014 +1000
-+++ b/src/pkg/archive/tar/reader.go Thu Jul 03 09:41:19 2014 +1000
-@@ -29,10 +29,11 @@
- // The Next method advances to the next file in the archive (including the first),
- // and then it can be treated as an io.Reader to access the file's data.
- type Reader struct {
-- r io.Reader
-- err error
-- pad int64 // amount of padding (ignored) after current file entry
-- curr numBytesReader // reader for current file entry
-+ r io.Reader
-+ err error
-+ pad int64 // amount of padding (ignored) after current file entry
-+ curr numBytesReader // reader for current file entry
-+ hdrBuff [blockSize]byte // buffer to use in readHeader
- }
-
- // A numBytesReader is an io.Reader with a numBytes method, returning the number
-@@ -426,7 +427,9 @@
- }
-
- func (tr *Reader) readHeader() *Header {
-- header := make([]byte, blockSize)
-+ header := tr.hdrBuff[:]
-+ copy(header, zeroBlock)
-+
- if _, tr.err = io.ReadFull(tr.r, header); tr.err != nil {
- return nil
- }
diff --git a/debian/patches/0004-archive-tar-fix-writing-of-pax-headers.patch b/debian/patches/0004-archive-tar-fix-writing-of-pax-headers.patch
deleted file mode 100644
index 4b0634d52..000000000
--- a/debian/patches/0004-archive-tar-fix-writing-of-pax-headers.patch
+++ /dev/null
@@ -1,82 +0,0 @@
-Description: archive/tar: fix writing of pax headers
-Author: Cristian Staretu <unclejacksons@gmail.com>
-Last-Update: 2014-07-16
-Forwarded: not-needed
-Origin: vendor, https://code.google.com/p/go/source/detail?r=1b17b3426e3c281a973d2d7bbf235b936d6a0942
-
----
-
-diff -r 278365dff593 -r 1b17b3426e3c src/pkg/archive/tar/writer.go
---- a/src/pkg/archive/tar/writer.go
-+++ b/src/pkg/archive/tar/writer.go
-@@ -39,7 +39,8 @@
- closed bool
- usedBinary bool // whether the binary numeric field extension was used
- preferPax bool // use pax header instead of binary numeric header
-- hdrBuff [blockSize]byte // buffer to use in writeHeader
-+ hdrBuff [blockSize]byte // buffer to use in writeHeader when writing a regular header
-+ paxHdrBuff [blockSize]byte // buffer to use in writeHeader when writing a pax header
- }
-
- // NewWriter creates a new Writer writing to w.
-@@ -161,7 +162,17 @@
- // subsecond time resolution, but for now let's just capture
- // too long fields or non ascii characters
-
-- header := tw.hdrBuff[:]
-+ var header []byte
-+
-+ // We need to select which scratch buffer to use carefully,
-+ // since this method is called recursively to write PAX headers.
-+ // If allowPax is true, this is the non-recursive call, and we will use hdrBuff.
-+ // If allowPax is false, we are being called by writePAXHeader, and hdrBuff is
-+ // already being used by the non-recursive call, so we must use paxHdrBuff.
-+ header = tw.hdrBuff[:]
-+ if !allowPax {
-+ header = tw.paxHdrBuff[:]
-+ }
- copy(header, zeroBlock)
- s := slicer(header)
-
-diff -r 278365dff593 -r 1b17b3426e3c src/pkg/archive/tar/writer_test.go
---- a/src/pkg/archive/tar/writer_test.go
-+++ b/src/pkg/archive/tar/writer_test.go
-@@ -454,3 +454,38 @@
- t.Fatal("Couldn't recover long name")
- }
- }
-+
-+func TestValidTypeflagWithPAXHeader(t *testing.T) {
-+ var buffer bytes.Buffer
-+ tw := NewWriter(&buffer)
-+
-+ fileName := strings.Repeat("ab", 100)
-+
-+ hdr := &Header{
-+ Name: fileName,
-+ Size: 4,
-+ Typeflag: 0,
-+ }
-+ if err := tw.WriteHeader(hdr); err != nil {
-+ t.Fatalf("Failed to write header: %s", err)
-+ }
-+ if _, err := tw.Write([]byte("fooo")); err != nil {
-+ t.Fatalf("Failed to write the file's data: %s", err)
-+ }
-+ tw.Close()
-+
-+ tr := NewReader(&buffer)
-+
-+ for {
-+ header, err := tr.Next()
-+ if err == io.EOF {
-+ break
-+ }
-+ if err != nil {
-+ t.Fatalf("Failed to read header: %s", err)
-+ }
-+ if header.Typeflag != 0 {
-+ t.Fatalf("Typeflag should've been 0, found %d", header.Typeflag)
-+ }
-+ }
-+}
diff --git a/debian/patches/series b/debian/patches/series
index 027d48635..e69de29bb 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,4 +0,0 @@
-0001-backport-delete-whole-line.patch
-0002-archive-tar-reuse-temporary-buffer-in-writeHeader.patch
-0003-archive-tar-reuse-temporary-buffer-in-readHeader.patch
-0004-archive-tar-fix-writing-of-pax-headers.patch
diff --git a/debian/rules b/debian/rules
index d73e90fab..b2545c220 100755
--- a/debian/rules
+++ b/debian/rules
@@ -73,7 +73,7 @@ override_dh_install:
done
dh_install --fail-missing
# Remove .syso files of the race detector; it is not used yet and the files are arch-dependent.
- find $(CURDIR)/debian/golang-src/usr/share/go/src/pkg/runtime/race -type f -name '*.syso' -delete
+ find $(CURDIR)/debian/golang-src/usr/share/go/src/runtime/race -type f -name '*.syso' -delete
# Remove Plan9 rc(1) scripts
find $(CURDIR)/debian/golang-src/usr/share/go/src -type f -name "*.rc" -delete
# Remove empty /usr/share/go/src from golang-go, it is provided by golang-src
diff --git a/debian/vim-registry/vim-syntax-go.yaml b/debian/vim-registry/vim-syntax-go.yaml
deleted file mode 100644
index aee788212..000000000
--- a/debian/vim-registry/vim-syntax-go.yaml
+++ /dev/null
@@ -1,8 +0,0 @@
-addon: go-syntax
-description: "Addon to highlight Google's Go"
-files:
- - syntax/go.vim
- - ftdetect/gofiletype.vim
- - ftplugin/go/fmt.vim
- - ftplugin/go/import.vim
- - indent/go.vim \ No newline at end of file
diff --git a/debian/vim-syntax-go.install b/debian/vim-syntax-go.install
deleted file mode 100644
index 3c3bd54f4..000000000
--- a/debian/vim-syntax-go.install
+++ /dev/null
@@ -1,5 +0,0 @@
-misc/vim/ftdetect/*.vim /usr/share/vim/addons/ftdetect/
-misc/vim/syntax/*.vim /usr/share/vim/addons/syntax/
-misc/vim/ftplugin/go/*.vim /usr/share/vim/addons/ftplugin/go/
-misc/vim/indent/*.vim /usr/share/vim/addons/indent/
-debian/vim-registry/*.yaml /usr/share/vim/registry/