summaryrefslogtreecommitdiff
path: root/src/cmd/gofmt/Makefile
diff options
context:
space:
mode:
authorSergio Luis O. B. Correia <sergio@larces.uece.br>2009-11-23 17:32:51 -0800
committerSergio Luis O. B. Correia <sergio@larces.uece.br>2009-11-23 17:32:51 -0800
commit4d33b8a8cd75101d60aeef4bd38fca472943b3dd (patch)
treeb739091738e77c3d0fdbd27f77d22ed0e281dc32 /src/cmd/gofmt/Makefile
parent60c09d05acbb176013a749977f7b047930822a07 (diff)
downloadgolang-4d33b8a8cd75101d60aeef4bd38fca472943b3dd.tar.gz
go: makes it build for the case $GOROOT has whitespaces
the bash scripts and makefiles for building go didn't take into account the fact $GOROOT / $GOBIN could both be directories containing whitespaces, and was not possible to build it in such a situation. this commit adjusts the various makefiles/scripts to make it aware of that possibility, and now it builds successfully when using a path with whitespaces as well. Fixes issue 115. R=rsc, dsymonds1 http://codereview.appspot.com/157067 Committer: Russ Cox <rsc@golang.org>
Diffstat (limited to 'src/cmd/gofmt/Makefile')
-rw-r--r--src/cmd/gofmt/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/cmd/gofmt/Makefile b/src/cmd/gofmt/Makefile
index dbc134f88..2294fd1db 100644
--- a/src/cmd/gofmt/Makefile
+++ b/src/cmd/gofmt/Makefile
@@ -2,18 +2,18 @@
# Use of this source code is governed by a BSD-style
# license that can be found in the LICENSE file.
-include $(GOROOT)/src/Make.$(GOARCH)
+include ../../Make.$(GOARCH)
TARG=gofmt
GOFILES=\
gofmt.go\
rewrite.go\
-include $(GOROOT)/src/Make.cmd
+include ../../Make.cmd
test: $(TARG)
./test.sh
smoketest: $(TARG)
- ./test.sh $(GOROOT)/src/pkg/go/parser/parser.go
+ ./test.sh "$(GOROOT)"/src/pkg/go/parser/parser.go