summaryrefslogtreecommitdiff
path: root/src/cmd/gotest
diff options
context:
space:
mode:
authorSergio Luis O. B. Correia <sergio@larces.uece.br>2009-11-23 17:32:51 -0800
committerSergio Luis O. B. Correia <sergio@larces.uece.br>2009-11-23 17:32:51 -0800
commit4d33b8a8cd75101d60aeef4bd38fca472943b3dd (patch)
treeb739091738e77c3d0fdbd27f77d22ed0e281dc32 /src/cmd/gotest
parent60c09d05acbb176013a749977f7b047930822a07 (diff)
downloadgolang-4d33b8a8cd75101d60aeef4bd38fca472943b3dd.tar.gz
go: makes it build for the case $GOROOT has whitespaces
the bash scripts and makefiles for building go didn't take into account the fact $GOROOT / $GOBIN could both be directories containing whitespaces, and was not possible to build it in such a situation. this commit adjusts the various makefiles/scripts to make it aware of that possibility, and now it builds successfully when using a path with whitespaces as well. Fixes issue 115. R=rsc, dsymonds1 http://codereview.appspot.com/157067 Committer: Russ Cox <rsc@golang.org>
Diffstat (limited to 'src/cmd/gotest')
-rw-r--r--src/cmd/gotest/Makefile4
-rwxr-xr-xsrc/cmd/gotest/gotest2
2 files changed, 3 insertions, 3 deletions
diff --git a/src/cmd/gotest/Makefile b/src/cmd/gotest/Makefile
index 8a1f02386..b20b1daff 100644
--- a/src/cmd/gotest/Makefile
+++ b/src/cmd/gotest/Makefile
@@ -10,5 +10,5 @@ clean:
@true
install: $(TARG)
- ! test -f $(GOBIN)/$(TARG) || chmod u+w $(GOBIN)/$(TARG)
- cp $(TARG) $(GOBIN)/$(TARG)
+ ! test -f "$(GOBIN)"/$(TARG) || chmod u+w "$(GOBIN)"/$(TARG)
+ cp $(TARG) "$(GOBIN)"/$(TARG)
diff --git a/src/cmd/gotest/gotest b/src/cmd/gotest/gotest
index 5f87b4791..75fd19217 100755
--- a/src/cmd/gotest/gotest
+++ b/src/cmd/gotest/gotest
@@ -21,7 +21,7 @@ if [ ! -f [Mm]akefile ]; then
exit 2
fi
-. $GOROOT/src/Make.$GOARCH
+. "$GOROOT"/src/Make.$GOARCH
if [ -z "$O" ]; then
echo 'missing $O - maybe no Make.$GOARCH?' 1>&2
exit 2