summaryrefslogtreecommitdiff
path: root/src/cmd/yacc/Makefile
diff options
context:
space:
mode:
authorMichael Stapelberg <stapelberg@debian.org>2014-06-19 09:22:53 +0200
committerMichael Stapelberg <stapelberg@debian.org>2014-06-19 09:22:53 +0200
commit8a39ee361feb9bf46d728ff1ba4f07ca1d9610b1 (patch)
tree4449f2036cccf162e8417cc5841a35815b3e7ac5 /src/cmd/yacc/Makefile
parentc8bf49ef8a92e2337b69c14b9b88396efe498600 (diff)
downloadgolang-8a39ee361feb9bf46d728ff1ba4f07ca1d9610b1.tar.gz
Imported Upstream version 1.3upstream/1.3
Diffstat (limited to 'src/cmd/yacc/Makefile')
-rw-r--r--src/cmd/yacc/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/src/cmd/yacc/Makefile b/src/cmd/yacc/Makefile
index 480844805..f8c8169bd 100644
--- a/src/cmd/yacc/Makefile
+++ b/src/cmd/yacc/Makefile
@@ -2,9 +2,11 @@
# Use of this source code is governed by a BSD-style
# license that can be found in the LICENSE file.
-expr: yacc.go expr.y
+TARG=expr$(shell go env GOEXE)
+
+$(TARG): yacc.go expr.y
go run yacc.go -p expr expr.y
- go build -o expr y.go
+ go build -o $(TARG) y.go
clean:
- rm -f y.go y.output expr
+ rm -f y.go y.output $(TARG)